Bug 493309 - xrandr multiple failures
xrandr multiple failures
Status: CLOSED DUPLICATE of bug 493368
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 07:37 EDT by William Murray
Modified: 2009-04-02 17:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-02 17:39:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
output of xrandr --verbose (5.36 KB, text/plain)
2009-04-02 01:27 EDT, David Tardon
no flags Details
log file (461.98 KB, text/plain)
2009-04-02 01:28 EDT, David Tardon
no flags Details
Xorg.0.log (51.05 KB, text/plain)
2009-04-02 03:01 EDT, William Murray
no flags Details
dump from dmesg (40.89 KB, text/plain)
2009-04-02 07:15 EDT, William Murray
no flags Details

  None (edit)
Description William Murray 2009-04-01 07:37:07 EDT
Description of problem:
QA:Testcase_radeon_rotate
rotating display / enabling second monitor garble display

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.12.0-2.fc11.i586


How reproducible:


Steps to Reproduce:
1. Start gnome-display-properties
2. Rotate a display
3. Or switch propeties between two displays
  
Actual results:
For rotations: Fuzz all over screen; reboot cures it.
For enabling second monitor: Loose all displays. Reboot
Can get two in clone mode, side-by-side never worked properly

Expected results:
Nice graphics

Additional info:
Screen 0: minimum 320 x 200, current 1400 x 1050, maximum 4096 x 4096
VGA-0 connected (normal left inverted right x axis y axis)
   1024x768       60.0  
   800x600        60.3  
   640x480        59.9  
DVI-0 disconnected (normal left inverted right x axis y axis)
LVDS connected 1400x1050+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
                  60.0*+
   1280x1024      60.0  
   1280x960       60.0  
   1024x768       60.0  
   800x600        60.3  
   640x480        59.9
Comment 1 François Cami 2009-04-01 17:59:18 EDT
    Thanks for the bug report. We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue. 

    Please attach your X server log file (/var/log/Xorg.*.log) and the output of "dmesg" to the bug report as individual *uncompressed, text/plain* file attachments using the bugzilla file attachment link below.
    
    We will review this issue again once you've had a chance to attach this information. 

    Thank you in advance. 

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 David Tardon 2009-04-02 01:26:17 EDT
Same situation here (to reboot after rotating messess things is not necessary--it's enough to wait for gnome-display-properties to return to previous configuration.)
Comment 3 David Tardon 2009-04-02 01:27:07 EDT
Created attachment 337720 [details]
output of xrandr --verbose
Comment 4 David Tardon 2009-04-02 01:28:44 EDT
Created attachment 337721 [details]
log file
Comment 5 David Tardon 2009-04-02 01:36:16 EDT
Additional observations: it's just rotating the display right or left which messes up the ouptut. Rotating it upside down works, but X crashes on return to previous configuration.

Driver version:
xorg-x11-drv-ati-6.12.0-2.fc11.x86_64
Comment 6 William Murray 2009-04-02 03:01:20 EDT
Created attachment 337725 [details]
Xorg.0.log
Comment 7 William Murray 2009-04-02 07:15:39 EDT
Created attachment 337778 [details]
dump from dmesg
Comment 8 Kevin DeKorte 2009-04-02 15:15:39 EDT
Not sure if this a is single head or dual head only issue, but when I rotate the monitor connected to DVI-0 (left rotation) I get some minor corruption on the left side of a window when I move to the right (seems to be an off by one issue)

Card, ATI 3650, using the ATI driver in rawhide as of 4.2.2009
xorg-x11-drv-ati-6.12.0-2.fc11.x86_64 

DVI-1 is connected to 1680x1060 monitor 
DVI-0 is connected to 1280x1024 monitor
DVI-0 is setup to be left of DVI-1

Virtual size is set to 4096 x 2048
If I don't rotate, I don't see any corruption, and when I rotate the first display I don't see any corruption
Comment 9 François Cami 2009-04-02 15:31:57 EDT
Kevin, please open a different bug, the off-by-one problem you're
describing is too dissimilar from the original problem for it
to be mentioned here.

Switching to ASSIGNED, thanks for the logs.

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 François Cami 2009-04-02 17:39:03 EDT
On second thoughts, closing as DUP of # 493368 .

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 493368 ***

Note You need to log in before you can comment on or make changes to this bug.