This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 493314 - netstat -s does not show TcpExt
netstat -s does not show TcpExt
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: net-tools (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jiri Popelka
BaseOS QE
:
Depends On: 435554
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 07:53 EDT by Olivier Fourdan
Modified: 2013-04-15 05:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 435554
Environment:
Last Closed: 2009-12-16 04:27:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Olivier Fourdan 2009-04-01 07:53:26 EDT
+++ This bug was initially created as a clone of Bug #435554 +++

This problem also affect EL5 with the kernel-rt (2.6.24.7)

Description of problem:
because of silly fixed length buffer of 1024 bytes in statistics.c:process_fd(),
netstat -s fails with "error parsing /proc/net/netstat: Success"

Version-Release number of selected component (if applicable):
1.60-86

How reproducible:
depends on kernel, 2.6.23 works, 2.6.24.3 does not work.

Steps to Reproduce:
1. netstat -s
  
Actual results:
parsing fails

Expected results:
show TcpExt stats

Additional info:

Created an attachment (id=296453)
double fgets buffer size


--- Additional comment from rvokal@redhat.com on 2008-03-04 10:40:39 EDT ---

Patch applied on rawhide
Comment 9 errata-xmlrpc 2009-12-16 04:27:10 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1677.html

Note You need to log in before you can comment on or make changes to this bug.