Bug 493332 - Radeon Test Day: KMS breaks startup on HD3200 [1002:9610]
Radeon Test Day: KMS breaks startup on HD3200 [1002:9610]
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
http://www.smolts.org/client/show/pub...
:
: 493388 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 09:35 EDT by Stefan Becker
Modified: 2009-09-12 04:10 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-12 04:10:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
X Log file from default boot (modesetting disabled) (107.72 KB, text/plain)
2009-04-01 10:04 EDT, Tom "spot" Callaway
no flags Details
Requested dmesg from loading radeon with modeset=1 (41.61 KB, text/plain)
2009-04-01 17:56 EDT, Tom "spot" Callaway
no flags Details
Requested lspci -nn output (2.52 KB, text/plain)
2009-04-01 17:58 EDT, Tom "spot" Callaway
no flags Details
Xorg.0.log without modesetting (49.44 KB, application/octet-stream)
2009-04-02 15:39 EDT, Jeandre du Toit
no flags Details
dmesg.log from radeon crash on HD3200 (46.64 KB, text/plain)
2009-04-03 14:08 EDT, Stefan Becker
no flags Details

  None (edit)
Description Stefan Becker 2009-04-01 09:35:44 EDT
Description of problem:

When KMS is enabled with radeon.modeset=1 bootup hangs when plymouth starts up. Non-KMS startup works OK.

Version-Release number of selected component (if applicable):
kernel-2.6.29.1-35.rc1.fc11.i586
xorg-x11-drv-ati-6.12.1-2.fc11.i586
libdrm-2.4.5-3.fc11.i586
mesa-libGL-7.5-0.6.fc11.i586

How reproducible:
always

Additional info:

Smolt profile attached as URL.
Comment 1 Tom "spot" Callaway 2009-04-01 09:44:43 EDT
I reproduced this on my system as well. 
http://www.smolts.org/show?uuid=pub_dd3d0c48-9a13-4ecd-a8a7-70b3de694bf2
Comment 2 Stefan Becker 2009-04-01 09:53:33 EDT
Sorry, forgot to mention: connected to Samsung DLP TV with HDMI. It's a VDR, so there is no other monitor :-)
Comment 3 Tom "spot" Callaway 2009-04-01 10:03:32 EDT
Mine is on a Philips 170S LCD, connected via VGA.
Comment 4 Tom "spot" Callaway 2009-04-01 10:04:22 EDT
Created attachment 337535 [details]
X Log file from default boot (modesetting disabled)
Comment 5 Remy Maucherat 2009-04-01 12:11:03 EDT
It also hangs on RV730 and RV770 when doing the modesetting, but did Dave post anywhere KMS was functional on R600+ ? Personally, I don't think so.
Comment 6 Michael Madore 2009-04-01 17:43:11 EDT
According to the basic test case instructions:

If you have an r600 or r700 chipset card (Radeon HD 2xxx, HD 3xxx or HD 4xxx),
add radeon.modeset=1 as a kernel parameter: in the live CD, hit any key when
the 'automatic boot in X seconds' prompt appears, then hit tab to edit boot
options

I tried this with the live CD and the kernel complained that it didn't
understand the radeon.modeset option.  The screen then went blank and I
eventually rebooted the system.  If I don't provide the radeon.modeset option,
then it will boot up in text mode and then start X successfully. I will test it
with a rawhide install next.

My smolt profile:

http://www.smolts.org/client/show/pub_d0215872-38fe-4625-8f82-ced21a8e012f
Comment 7 Tom "spot" Callaway 2009-04-01 17:56:49 EDT
Created attachment 337672 [details]
Requested dmesg from loading radeon with modeset=1
Comment 8 Tom "spot" Callaway 2009-04-01 17:58:14 EDT
Created attachment 337673 [details]
Requested lspci -nn output
Comment 9 Kevin DeKorte 2009-04-02 15:10:14 EDT
ATI 3650 shows a blankscreen when radeon.modeset=1 is used, without this everything is fine.
Comment 10 François Cami 2009-04-02 15:38:58 EDT
*** Bug 493388 has been marked as a duplicate of this bug. ***
Comment 11 Jeandre du Toit 2009-04-02 15:39:44 EDT
Created attachment 337884 [details]
Xorg.0.log without modesetting
Comment 12 Jeandre du Toit 2009-04-02 15:42:36 EDT
Also have a blank screen when radeon.modeset=1 is used. 

lspci -nn:

01:05.0 VGA compatible controller [0300]: ATI Technologies Inc RS780M/RS780MN [Radeon HD 3200 Graphics] [1002:9612]
Comment 13 François Cami 2009-04-02 15:42:36 EDT
Thanks for the logs and information, switching severity
to high because of crash, keeping priority low because
we have a workaround.

Switching to ASSIGNED.

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 Stefan Becker 2009-04-03 14:08:00 EDT
Created attachment 338096 [details]
dmesg.log from radeon crash on HD3200

You probably have this information already, but I thought I add the log from my system too:

  boot with nomodeset 3
  modprobe -r radeon drm
  modprobe drm debug=1
  modprobe radeon modeset=1
Comment 15 Adam Williamson 2009-04-15 15:20:30 EDT
kevin dekorte, can you file a separate bug? KMS failures on different chipsets don't necessarily have the same cause, so we need separate reports for each failing chipset.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 16 Bug Zapper 2009-06-09 08:56:45 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 17 Stefan Becker 2009-09-12 04:10:33 EDT
Fedora 12 Radeon Test Day: KMS works now on this HW.

I doubt this will ever be fixed for F11, because it still uses the old radeon code base.

Note You need to log in before you can comment on or make changes to this bug.