Bug 493388 - Booting with radeon.modeset=1 fails
Summary: Booting with radeon.modeset=1 fails
Status: CLOSED DUPLICATE of bug 493332
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: rawhide
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Dave Airlie
QA Contact: Fedora Extras Quality Assurance
URL: http://fedoraproject.org/wiki/Test_Da...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-04-01 16:09 UTC by Nils Philippsen
Modified: 2009-04-02 19:38 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2009-04-02 19:38:58 UTC


Attachments (Terms of Use)
Output of "xrandr --verbose" on F-10+updates (9.90 KB, text/plain)
2009-04-01 16:11 UTC, Nils Philippsen
no flags Details
Radeon kernel bug messages (44.07 KB, text/plain)
2009-04-02 02:10 UTC, Michael Madore
no flags Details
kernel messages when inserting radeon module with modeset=1 (4.69 KB, text/plain)
2009-04-02 09:20 UTC, Nils Philippsen
no flags Details

Description Nils Philippsen 2009-04-01 16:09:06 UTC
Description of problem:
http://fedoraproject.org/wiki/QA:Testcase_radeon_basic

When booting the Live medium (x86_64, from a USB pen drive) on my Radeon HD3450 equipped system, my monitor goes to standby and the pen drive doesn't show any "disk" activity, so I suspect a crash.

Version-Release number of selected component (if applicable):
I think xorg-x11-drv-ati-6.12.0-2.fc11.x86_64 (unsquashfs doesn't work so I can't exactly say what's on the live medium ISO image).

How reproducible:
Reproducible.

Steps to Reproduce:
1. Put prepared USB pen drive into slot
2. Boot
3. <Tab>, then append "radeon.modeset=1" to the kernel command line
  
Actual results:
At the point where it should switch the graphics mode, the monitor goes blank (and indicates it's on standby), no further activity on USB pen drive.

Expected results:
Graphical boot (as described on the basic test web page)

Additional info:

lspci -v:
03:00.0 VGA compatible controller: ATI Technologies Inc Mobility Radeon HD 3450 (prog-if 00 [VGA controller])
	Subsystem: Micro-Star International Co., Ltd. Device 1180
	Flags: bus master, fast devsel, latency 0, IRQ 11
	Memory at e0000000 (64-bit, prefetchable) [size=256M]
	Memory at fdce0000 (64-bit, non-prefetchable) [size=64K]
	I/O ports at 6c00 [size=256]
	Expansion ROM at fdcc0000 [disabled] [size=128K]
	Capabilities: [50] Power Management version 3
	Capabilities: [58] Express Legacy Endpoint, MSI 00
	Capabilities: [a0] Message Signalled Interrupts: Mask- 64bit+ Count=1/1 Enable-
	Capabilities: [100] Vendor Specific Information <?>

lspci -vn:
03:00.0 0300: 1002:95c5 (prog-if 00 [VGA controller])
	Subsystem: 1462:1180
	Flags: bus master, fast devsel, latency 0, IRQ 11
	Memory at e0000000 (64-bit, prefetchable) [size=256M]
	Memory at fdce0000 (64-bit, non-prefetchable) [size=64K]
	I/O ports at 6c00 [size=256]
	Expansion ROM at fdcc0000 [disabled] [size=128K]
	Capabilities: [50] Power Management version 3
	Capabilities: [58] Express Legacy Endpoint, MSI 00
	Capabilities: [a0] Message Signalled Interrupts: Mask- 64bit+ Count=1/1 Enable-
	Capabilities: [100] Vendor Specific Information <?>

Comment 1 Nils Philippsen 2009-04-01 16:11:57 UTC
Created attachment 337572 [details]
Output of "xrandr --verbose" on F-10+updates

Comment 2 Remy Maucherat 2009-04-01 22:00:34 UTC
See bug 493332

Comment 3 François Cami 2009-04-01 22:08:49 UTC
Nils,

Could you by any chance boot without modesetting, in runlevel 3 ; then ssh in, rmmod radeon drm, modprobe drm debug=1, modprobe radeon modeset=1 .

That may allow you to get at least dmesg to us, please attach as uncompressed text/plain to this bug if at all possible.

Could you optionally post a link to your smolt profile as well ?

Thank you

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 4 Michael Madore 2009-04-02 02:10:08 UTC
Created attachment 337708 [details]
Radeon kernel bug messages

This is the dmesg output after inserting the drm and radeon modules from runlevel 3.

Mike

Comment 5 Nils Philippsen 2009-04-02 09:20:06 UTC
Created attachment 337755 [details]
kernel messages when inserting radeon module with modeset=1

This time, sending my smolt profile worked:

http://www.smolts.org/client/show/pub_cbb4f7f2-a960-4ba6-9bf2-0667e43767a9

Comment 6 François Cami 2009-04-02 19:38:58 UTC
Nils,

Very nice general protection fault, thank you.

Marking as DUPLICATE of bug # 493332 after looking at the
call traces.

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 493332 ***


Note You need to log in before you can comment on or make changes to this bug.