Bug 493339 - [radeon testday] multihead problems
[radeon testday] multihead problems
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
11
All Linux
high Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
: 493508 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 09:57 EDT by b. nutzer
Modified: 2009-06-09 13:37 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-09 13:24:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg after testing (52.87 KB, text/plain)
2009-04-01 09:57 EDT, b. nutzer
no flags Details
/var/log/messages (78.09 KB, text/plain)
2009-04-01 09:58 EDT, b. nutzer
no flags Details
/var/log/Xorg.0.log (506.99 KB, text/plain)
2009-04-01 09:58 EDT, b. nutzer
no flags Details
output of xrandr --verbose (5.91 KB, text/plain)
2009-04-01 10:16 EDT, b. nutzer
no flags Details
xrandr after first boot up (512 bytes, text/plain)
2009-04-01 11:40 EDT, Nathanael Noblet
no flags Details
verbose xrandr after a multi screen setup attempt (3.80 KB, text/plain)
2009-04-01 11:43 EDT, Nathanael Noblet
no flags Details
xrandr log (780 bytes, text/plain)
2009-04-01 12:17 EDT, Tomas Henzl
no flags Details
X-multihead-logs.tgz (42.98 KB, text/plain)
2009-04-01 14:42 EDT, James Laska
no flags Details
jlaska's dmesg (45.81 KB, text/plain)
2009-04-01 16:01 EDT, François Cami
no flags Details
jlaska's messages (92.18 KB, text/plain)
2009-04-01 16:02 EDT, François Cami
no flags Details
jlaska's Xorg.0.log (387.43 KB, text/plain)
2009-04-01 16:02 EDT, François Cami
no flags Details
jlaska's xrandr (657 bytes, text/plain)
2009-04-01 16:03 EDT, François Cami
no flags Details

  None (edit)
Description b. nutzer 2009-04-01 09:57:24 EDT
Created attachment 337529 [details]
dmesg after testing

Description of problem:
http://fedoraproject.org/wiki/Test_Day:Radeon_2009-04-01

I have two monitors: Monitor A: Laptop: 1400x1050
                     Monitor B: LCD: 1280x1024


Mirror mode works out of the box with a resolution of 1024x768.

With the same resolution and mirror mode off, the laptop screen remains black, but the mouse pointer is visible and i can move windows on it and back.

If i use different resolutions, parts of one screen are visible on both monitors, the remaining space is black.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.12.0-2.fc11.i586


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
ATI Technologies Inc Radeon Mobility X1400 [1002:7145] 

http://www.smolts.org/client/show/pub_1a07862b-a848-4833-825a-c0adca38eef3
Comment 1 b. nutzer 2009-04-01 09:58:03 EDT
Created attachment 337530 [details]
/var/log/messages
Comment 2 b. nutzer 2009-04-01 09:58:44 EDT
Created attachment 337532 [details]
/var/log/Xorg.0.log
Comment 3 b. nutzer 2009-04-01 10:16:01 EDT
Created attachment 337537 [details]
output of xrandr --verbose
Comment 4 Nathanael Noblet 2009-04-01 11:40:06 EDT
I have 2 24" Samsung monitors, I have a similar problem.
Comment 5 Nathanael Noblet 2009-04-01 11:40:53 EDT
Created attachment 337565 [details]
xrandr after first boot up
Comment 6 Nathanael Noblet 2009-04-01 11:43:00 EDT
Created attachment 337566 [details]
verbose xrandr after a multi screen setup attempt
Comment 7 Tomas Henzl 2009-04-01 12:17:23 EDT
Created attachment 337575 [details]
xrandr log

I have three monitors: Monitor A: Laptop: 1400x1050
                       Monitor B: LCD: 1280x1024 - dvi
                       Monitor C: LCD: 1280*1024 - analog

I wasn't able to see an output on Mon B in neither mode.
In mirror mode I was once able to same the same on A and C (1024*768), but was unable to repeat it.

On Monitor A I miss the 1280*1024 mode.

The GUI interface in mirror mode doesn't allow to switch individual monitors on/off.

http://www.smolts.org/client/show/pub_e1fc8df8-a902-4c5e-b8b6-7f5c45bdd200
Comment 8 Peter F. Patel-Schneider 2009-04-01 12:23:36 EDT
Also, in a Lenovo T60p with ATI Technologies Inc M56GL [Mobility FireGL V5200] [1002:71c4].  In multihead mode, the logical left-hand screen looks correct but the other screen remains black, except for the cursor
Comment 9 James Laska 2009-04-01 14:42:44 EDT
Created attachment 337610 [details]
X-multihead-logs.tgz

This bug describes the problems I am seeing as well.  Attaching log files.
-rw-rw-r-- liveuser/liveuser 657 2009-04-01 18:27 tmp/xrandr.out
-rw------- liveuser/liveuser 2484 2009-04-01 18:19 home/liveuser/.xsession-errors
-rw-r--r-- root/root       396724 2009-04-01 18:27 var/log/Xorg.0.log
-rw------- root/root        94390 2009-04-01 18:27 var/log/messages
-rw-r--r-- root/root        46912 2009-04-01 18:14 var/log/dmesg
Comment 10 François Cami 2009-04-01 16:01:54 EDT
Created attachment 337637 [details]
jlaska's dmesg
Comment 11 François Cami 2009-04-01 16:02:16 EDT
Created attachment 337638 [details]
jlaska's messages
Comment 12 François Cami 2009-04-01 16:02:40 EDT
Created attachment 337639 [details]
jlaska's Xorg.0.log
Comment 13 François Cami 2009-04-01 16:03:11 EDT
Created attachment 337640 [details]
jlaska's xrandr
Comment 14 François Cami 2009-04-01 16:05:52 EDT
Switching priority to high because this represents a major
loss of functionality.

All logs included, switching to ASSIGNED.

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 15 Mads Kiilerich 2009-04-02 05:38:21 EDT
*** Bug 493508 has been marked as a duplicate of this bug. ***
Comment 16 Mads Kiilerich 2009-04-02 05:39:40 EDT
For me with ATI Technologies Inc RV516 [Radeon X1300/X1550 Series] it worked with
kernel-PAE-2.6.29-0.258.2.3.rc8.git2.fc11.i686
The problem was introduced with
kernel-PAE-2.6.29-16.fc11.i686
The problem remains with
kernel-PAE-2.6.29.1-37.rc1.fc11.i686

So I think the problem is in the kernel - but I am sure airlied can solve it no matter where it is ;-)

Can others try to boot an old kernel and confirm that it works there and thus help pointing out what introduced the problem?
Comment 17 Mads Kiilerich 2009-04-02 06:00:49 EDT
I also notice different behaviour depending on how the displays are (logically!) placed next to each other. With secondary-to-the-right-of-primary the secondary is black. With secondary-on-top-of-primary I get "something" on both displays, but both have some rendering problems.
Comment 18 Dave Airlie 2009-04-22 05:04:29 EDT
can we get a re-test with -103 kernel or higher? I've done a lot of fixes in this area.
Comment 19 Peter F. Patel-Schneider 2009-04-22 07:44:20 EDT
I'm actually running 102 on a ThinkPad T60p with a Mobility FireGL V5200 as my personal laptop.

Things are very much better and the remaining problems may not be due to the radeon driver at all but to other components.

I've noticed:
1/ Booting dual screen doesn't pick up the preferred resolution.
2/ Once when booting, and also in other circumstances, I've got the screens to partially overlap. I don't think this is a *problem* per se, but it does look weird, particularly as the gnome tool for moving screens around is so particular to prevent overlapping screens.
3/ When rotating a screen, the tool "greys" out the rotation button until you switch between screens or do some other actions.

I'll wait until 103 hits and then do a full test.
Comment 20 Michal Schmidt 2009-04-22 08:36:31 EDT
I'm running 2.6.29.1-104.fc11.x86_64 on my laptop with RS690M (Radeon X1200 Series).

It is definitely a big improvement. On the Radeon test day I got black areas on one of the monitors. Now I could change the relative positions of the monitors several times and it worked every time, no black areas, everything nice.

Some remaining problems (not likely to be related to this bug):
1) At one point after applying another monitors settings, my desktop session got stuck and one of the Gnome panels was redrawing rapidly. I had to use CTRL+ALT+BackSpace ;-)  This could be a bug in Gnome - it could have been confused about where to put the panel after the monitor reconfiguration.

2) I tried rotation too. It worked, but drawing on the rotated monitor was very slow, probably completely unaccelerated. Is acceleration supposed to work with rotation?
Comment 21 Malcolm Caldwell 2009-04-22 23:30:43 EDT
I can confirm that multihead now works for me.  I am using 102.

I had a "funny" issue though.

In the past I had used gnome-display-properties to disable my laptop screen, leaving only my external LCD.  This was to get around the multihead issues.

When I upgraded to >70, upon login BOTH displays were BLACK.  This made it hard to do anything.  I tried to login via ssh and shutdown the machine, but the machine would not shutdown (I think there is another bug about failing to shutdown).

I fixed this issue by booting with .70, using gnome-display-properties to select mirror and then rebooted into 103 where I could now login and even select dual monitors!

Could this be a problem for others upgrading to F11?  Should I log another bug?
Comment 22 Mads Kiilerich 2009-05-16 19:19:11 EDT
Isn't this issue solved in rawhide and ready to be closed as such?

Other issues should be filed separately.
Comment 23 Peter F. Patel-Schneider 2009-05-18 19:47:42 EDT
I concur.  Things have been great in this area for a few rawhides now.
Comment 24 Matěj Cepl 2009-05-19 05:31:27 EDT
Reporter, could you please confirm, that this has been fixed in the last updates?

Thank you
Comment 25 Bill McGonigle 2009-05-22 21:11:49 EDT
I reported a duplicate bug and everything is working for me on current rawhide.

2.6.29.3-155.fc11.i586
Comment 26 Matěj Cepl 2009-05-25 12:10:40 EDT
Thanks for letting us know, but I would prefer to hear it from the original reporter of this bug.
Comment 27 b. nutzer 2009-05-26 05:19:35 EDT
sorry, but i can't test it because i don't have fedora on my laptop. i've tested it with the radeon test day livecd and i've tried to test it with preview release livecd but it can't boot because of bug #499149.
Comment 28 Bill McGonigle 2009-05-26 05:51:36 EDT
(In reply to comment #26)
> Thanks for letting us know, but I would prefer to hear it from the original
> reporter of this bug.  

I was the original reporter of the duplicate bug... isn't the point of closing bugs as duplicate to achieve input from multiple testers on an issue?
Comment 29 Matěj Cepl 2009-05-26 06:54:26 EDT
(In reply to comment #28)
> I was the original reporter of the duplicate bug... isn't the point of closing
> bugs as duplicate to achieve input from multiple testers on an issue?  

Truth to be told, it isn't ... the main point of deduplication is to help us to survive sheer number of bugs we have to deal with, but yes, I am not closing this bug, because original reporter has better things to do with his life than to slave on Fedora bug testing ;-).
Comment 30 Bug Zapper 2009-06-09 08:57:08 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 31 b. nutzer 2009-06-09 13:24:50 EDT
i've tried the fedora 11 livecd and it works perfectly.

thanks and keep up the great work
Comment 32 François Cami 2009-06-09 13:37:07 EDT
Thank you very much for testing again.
Switching status to CLOSED/CURRENTRELEASE.

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.