Bug 493361 - TypeError: unsupported operand type(s) for &: 'NoneType' and 'int'
TypeError: unsupported operand type(s) for &: 'NoneType' and 'int'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:7939048e9356865ef...
:
: 493393 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 10:54 EDT by Michal Nowak
Modified: 2013-03-07 21:05 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-17 15:41:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (146.92 KB, text/plain)
2009-04-01 10:55 EDT, Michal Nowak
no flags Details
Attached traceback automatically from anaconda. (210.53 KB, text/plain)
2009-04-05 11:07 EDT, AL
no flags Details
Attached traceback automatically from anaconda. (335.87 KB, text/plain)
2009-04-12 03:40 EDT, Morgan Olausson
no flags Details

  None (edit)
Description Michal Nowak 2009-04-01 10:54:58 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.38 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devices.py", line 979, in isExtended
    return self.partType & parted.PARTITION_EXTENDED
  File "/usr/lib/anaconda/storage/devices.py", line 1040, in dependsOn
    if isinstance(dep, PartitionDevice) and dep.isExtended and self.isLogical:
  File "/usr/lib/anaconda/storage/devicetree.py", line 600, in cmpActions
    elif a1.device.dependsOn(a2.device):
  File "/usr/lib/anaconda/storage/devicetree.py", line 647, in processActions
    self._actions.sort(cmp=cmpActions)
  File "/usr/lib/anaconda/storage/__init__.py", line 210, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 115, in turnOnFilesystems
    anaconda.id.storage.doIt()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
TypeError: unsupported operand type(s) for &: 'NoneType' and 'int'
Comment 1 Michal Nowak 2009-04-01 10:55:05 EDT
Created attachment 337553 [details]
Attached traceback automatically from anaconda.
Comment 2 Michal Nowak 2009-04-01 11:00:51 EDT
Killed the LVM setup, which was present there and added 

/ 94 GB btrfs
/boot 100 MB ext3
    swap 1-2 GB

hit Next -> question about formatting partition -> "OK" -> BT.
Comment 3 Chris Lumens 2009-04-01 12:42:38 EDT
*** Bug 493393 has been marked as a duplicate of this bug. ***
Comment 4 AL 2009-04-05 11:07:44 EDT
Created attachment 338239 [details]
Attached traceback automatically from anaconda.
Comment 5 AL 2009-04-05 11:11:04 EDT
phooey, I really wanted to try fedora 11 and ext4 dang nabbit.
Comment 6 David Lehman 2009-04-07 15:38:50 EDT
It would be of great value if one or both of you could explain what you did leading up to the failure. The more detail, the better. Especially interesting is what your initial layout looked like and what options you chose on each screen.
Comment 7 AL 2009-04-07 21:55:42 EDT
Here was my Situation:
I Installed windows 7 Build 7048 on this test rig. Well I couldn't find applicable video drivers for my geforce 4 MX 4000 and It was really bothering me that the video was really slow, Everything else worked great but the video was slow because of the whole using VGA.sys and stuff so, I figured I would try Fedora 11 because I liked 9 and it worked on my Geforce 4 MX 440 w/AGP8X so I figured I would try the 11th version of Fedora but, I couldn't even get it installed. The steps to reproduce this bug are these:
1.Get a 320 GB HD
2. Install Windows 7 with these settings:
   A.Have one Partition with a size of 262200 MB(equals 256 GB).
   B.Have another equaling the remaining space.
   C.Windows sets up a 100MB partition.
   D. Install Windows 7 Build 7048 on the 40-something partition.
3.Get tired of all your videos and other things being slow because of lack of driver support.
4.Download the Fedora 11 x86 Live CD
5.Burn it to a DVD(I know I wasted about 3600 MB burning it to a DVD)using Windows 7 cool integrated ISO burner.
6.Boot from the newly burnt CD.
7.Choose to verify it's contents.
8.Choose to install. 
9.Select Custom Partition Setup.
10.make it so your System Partition for windows 7 is ext3 and reduce its size by 4GB to allow for the swap partition
11.make your 256 GB partition ext4
12.setup a swap partition using the 4 GB You saved.
13.when it asks you if you want to go ahead with the changes click "OK"
14.when it crashes after trying to write to the table input your profile info.
15.Try the install again using only default options
16. FAIL miserably again.
17.Download Fedora 10 Live CD.
18. burn that to a CD
19.Install Fedora 10 using the Custom Partitions that you wanted for F11.
20. get mad that Fedora 10 doesn't have support for your geforce 4 either and because it does the same shit that windows 7 did because Fedora 10 uses a generic video driver as well.
21.download Ubuntu 9.04 Jaunty Jackalope.
22. waste 3600MB by burning that to a DVD.
23.Have an Excellent and fast setup time(it did what I wanted it to fast and efficient what a surprise for a OS to do that!).
24.Install the video drivers for your geForce 4 MX 4000 that are easy to get to and install.
25. Have fun using your PC with a actually competent OS and actually fast video and desktop effects.
Staying with Ubuntu 9.04,
AL
Comment 8 Michal Nowak 2009-04-08 04:24:55 EDT
I guess I can't provide more info than I wrote in Comment #2 previously. Sorry. It would be beneficial if Anaconda's backtrace catcher could save the partition setup also.
Comment 9 Jóhann B. Guðmundsson 2009-04-08 05:50:36 EDT
I had 3 previous existing installs totalling to 11 partitions ( 3 coexisting installations )did not seem to matter what I did in custom layout ( delete/reuse ) anaconda bactraced somewhere in the partition process. 

Anaconda also backtraced using remaining free space and did not warn me that it would erase/use all my linux partitions nor show me how it would partition the disk nor offer me to unselect some of the existing linux partitions when I checked the remove linux partitions. 
but that installation was successful both in installing and wiping all my other installation in that process as well.. 

Afaik the limitations to each disk is 15 partitions per disk so anaconda needs to be able to handle that.
Comment 10 Morgan Olausson 2009-04-12 03:40:29 EDT
Created attachment 339219 [details]
Attached traceback automatically from anaconda.
Comment 11 Morgan Olausson 2009-04-12 04:35:05 EDT
On my pentium3 260MB Ram system there are two harddiscs.
I have already before one installed Fedora10 system which uses partitions on both harddiscs.

I tried to add an installation of F11-live-snap1-gnome whith custom setup using both discs.
Created LVM, lvm_root and lvm_swap, and got message that also a bootpartitioning on a non lv or ext4 was needed. I created a bootpartition and then the setup were accepted and installation started. But the exception came almost immediately. 

This is the second time I try to install this F11-live-snap1-gnome on this machine. 
I came further last time, see bug 495319.
Comment 12 Morgan Olausson 2009-04-12 04:44:15 EDT
Comments #10 and #11 are also from me. Is it not strange that the automatic trace arrived here among the x86_64, since this is a 32bit system? Or perhaps that doesn't matter I don't know.
Comment 13 Morgan Olausson 2009-04-13 08:55:16 EDT
Just want to add here that my system (chip i810) apparently have a problem also with Ubuntu. I installed Ubuntu 8.10 from cd and it worked fine. Updated and rebooted.
After logging in X froze completely. What I mean is that this might be related to drivers or possibly an drm issue whith i810.
Comment 14 Morgan Olausson 2009-04-13 08:59:20 EDT
Sorry, comment #13 should be in bug 495319, I will add it there.
Comment 15 Chris Lumens 2009-04-15 15:51:53 EDT
We believe this to be fixed in anaconda 11.5.0.43, which is from after the latest dupe was attached to this report.  Please try again with a later rawhide and verify that this is correct.  If not, feel free to put this bug report back into ASSIGNED.  Thanks.
Comment 16 Chris Lumens 2009-06-08 09:44:53 EDT
*** Bug 504541 has been marked as a duplicate of this bug. ***
Comment 17 Bug Zapper 2009-06-09 08:57:40 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.