This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 493406 - ibus is turned on by default for all locales
ibus is turned on by default for all locales
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: imsettings (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
NEEDSRETESTING
:
: 493698 (view as bug list)
Depends On:
Blocks: F11Preview 481098
  Show dependency treegraph
 
Reported: 2009-04-01 12:45 EDT by Matthias Clasen
Modified: 2013-01-10 00:08 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-23 17:17:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2009-04-01 12:45:13 EDT
...which is not what people expect.

We used to have a solution that made scim enabled only in certain locales. I think we need something like that back.
Comment 1 Akira TAGOH 2009-04-02 01:46:50 EDT
No changes has been made around this. imsettings is responsible to enable/disable input method though it's supposed to work on certain locales. can you give us more info like which locales did you see ibus enabled?

I suspect this might be related to http://bugzilla.gnome.org/show_bug.cgi?id=567124 ?
Comment 2 Jens Petersen 2009-04-02 05:06:42 EDT
Even after turning off IM in im-chooser - input method is still enabled in next session.

I can reproduce easily in en_US.UTF-8 for F11Beta and current rawhide.

Moving to gtk2.
Comment 3 Peng Huang 2009-04-02 06:42:59 EDT
Hi Jens,
Please use `gnome-session-properties` check if you make ibus autostart during session startup?
Comment 4 Jens Petersen 2009-04-02 09:33:17 EDT
I only see imsettings-start and imsettings-applet (both on and I guess at least the former is needed).
Comment 5 Matthias Clasen 2009-04-04 23:57:44 EDT
If I log into a fresh account, in the en_US locale, I see none.conf being sourced, so the locale filtering in /etc/X11/xinit/xinitrc.d/50-xinput.sh seems to be working. But still, something sets the gconf key /desktop/gnome/interface/gtk-im-module to 'ibus', and the ibus statusicon is visible.

And we are still running 6 (!) processes in an en_US session for undesired IM support:

imsettings-applet
/usr/libexec/im-settings-daemon
/usr/bin/ibus-daemon --xim
/usr/libexec/gconf-im-settings-daemon
/usr/libexec/ibus-gconf
/usr/libexec/ibus-x11 --kill-daemon

No wonder our login time is never getting any better...

None of this is GTK+s fault.
Comment 6 Akira TAGOH 2009-04-05 23:07:52 EDT
Sorry, this was my fault since imsettings stops to bring IM process up in X session but in the desktop session. /etc/xdg/autostart/imsettings-start.desktop brings it up anyway because imsettings-start doesn't look at $IMSETTINGS_MODULE that is used to determine which IM would be preferred for current session.
Comment 7 Akira TAGOH 2009-04-06 03:37:55 EDT
*** Bug 493698 has been marked as a duplicate of this bug. ***
Comment 8 Akira TAGOH 2009-04-07 08:30:06 EDT
Fixed in imsettings-0.106.2-1.fc11.
Comment 9 Jesse Keating 2009-04-16 14:54:58 EDT
Putting this on the preview blocker and marking with needsretesting to make sure it's fixed.
Comment 10 Jens Petersen 2009-04-17 02:29:36 EDT
I can confirm that is this fixed in current rawhide but would also appreciate a final signoff by Fedora QA or releng.
Comment 11 Will Woods 2009-04-23 17:17:45 EDT
Confirmed - works as expected when switching between (e.g.) en_US and ja_JP.

Note You need to log in before you can comment on or make changes to this bug.