Bug 493412 - Radeon Test Day: 2nd rotate crashes X Server on Mobility Radeon X1300 [1002:7149]
Summary: Radeon Test Day: 2nd rotate crashes X Server on Mobility Radeon X1300 [1002:7...
Status: CLOSED DUPLICATE of bug 522181
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dave Airlie
QA Contact: Fedora Extras Quality Assurance
URL: http://www.smolts.org/client/show/pub...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-04-01 16:56 UTC by Stefan Becker
Modified: 2009-09-12 08:14 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2009-09-12 08:14:40 UTC


Attachments (Terms of Use)
X server logfile (65.02 KB, text/plain)
2009-04-01 16:56 UTC, Stefan Becker
no flags Details
Output of xrandr --query --verbose (3.31 KB, text/plain)
2009-04-01 16:57 UTC, Stefan Becker
no flags Details
mobility x1600 xrandr verbose query (4.10 KB, text/plain)
2009-04-01 23:10 UTC, Bill McGonigle
no flags Details

Description Stefan Becker 2009-04-01 16:56:53 UTC
Created attachment 337583 [details]
X server logfile

Description of problem:

First rotate of primary output worked OK, but second rotate, e.g. back to "normal", crashes X Server.

primary output: LVDS
secondary output: Samsung DLP TV via DVI

Version-Release number of selected component (if applicable):
kernel-2.6.29.1-35.rc1.fc11.i586
xorg-x11-drv-ati-6.12.1-2.fc11.i586
libdrm-2.4.5-3.fc11.i586
mesa-libGL-7.5-0.6.fc11.i586

How reproducible:
always

Additional info:
smolt profile attached as URL

Comment 1 Stefan Becker 2009-04-01 16:57:25 UTC
Created attachment 337584 [details]
Output of xrandr --query --verbose

Comment 2 Bill McGonigle 2009-04-01 23:09:12 UTC
Same on radeon mobility x1600

smolt: http://www.smolts.org/client/show/pub_84fdcccc-d29d-4a50-8032-3855cfb8ff32

Comment 3 Bill McGonigle 2009-04-01 23:10:29 UTC
Created attachment 337683 [details]
mobility x1600 xrandr verbose query

Comment 4 Bill McGonigle 2009-04-03 17:33:26 UTC
An easy test case is to request the rotation change, and just leave the confirmation dialog to timeout, it'll crash when it switches back to the previous mode.

Comment 5 Bug Zapper 2009-06-09 12:59:14 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 6 Stefan Becker 2009-09-12 08:14:40 UTC
The story continues into F12.

I doubt this will ever be fixed for F11, because it still uses the old radeon code base.

*** This bug has been marked as a duplicate of bug 522181 ***


Note You need to log in before you can comment on or make changes to this bug.