Bug 493461 - F11-beta install failure - can't mount partition to which live image has been copied
F11-beta install failure - can't mount partition to which live image has been...
Status: CLOSED DUPLICATE of bug 492727
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 16:12 EDT by Steven Usdansky
Modified: 2009-04-01 16:55 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-01 16:55:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Usdansky 2009-04-01 16:12:47 EDT
Description of problem:
F11 beta installer crashes after copying live image when trying to mount the partition into which the image was copied on Acer Aspire One

Version-Release number of selected component (if applicable):
anaconda-11.5.0.38-1.i586

How reproducible:
100%

Steps to Reproduce:
1. Create bootable USB stick with livecd-iso-to-disk
2. Boot.
3. Open terminal and as root rmmod acer_wmi to enable Network Manager
4. Connect to my wireless network
5. Begin install process
6. Select an existing (ext3) partition to receive the new image
7. Select ext3 as format for that partition
8. Select no installation of boot loader 
9. Process proceeds; progress bar gets about 95% drawn as live image is copied
  
Actual results:
Error dialog
Title: Unable to mount filesystem
Text: An error occurred mounting device /dev/sda10
      as /: mount failed: (2,None). This is a fatal error
      and the installer cannot continue.
      Press <Enter> to exit the installer.

Expected results:
A nice, new ext3 filesystem with a working F11 beta

Additional info:
Has happened four times. Re-imaged USB stick twice and verified the contents.

Probably not related, but I also tried to format the partition as ext4, but system wouldn't let me with no bootloader. I have /boot on a separate partition, and generally don't like grub messing with it; I update it manually.
Comment 1 hcoohb 2009-04-01 16:50:42 EDT
I had exactly the same error message when trying to install fedora11-beta x86_64 Live KDE iso.

1. burn the iso on a DVD
2. Boot.
3. Begin install process
4. Select an existing (ext4) partition to receive the new image
5. Select ext3 as format for that partition
6. Select /sda for bootloader
9. Process proceeds; progress bar gets about 95% drawn as live image is copied

Actual results:
Error dialog
Title: Unable to mount filesystem
Text: An error occurred mounting device /dev/sda8
      as /: mount failed: (2,None). This is a fatal error
      and the installer cannot continue.
      Press <Enter> to exit the installer.

And again, this is 100% reproducible. (I tried 3 times)
Too bad.... :-(
Comment 2 Chris Lumens 2009-04-01 16:55:21 EDT

*** This bug has been marked as a duplicate of bug 492727 ***

Note You need to log in before you can comment on or make changes to this bug.