This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 493492 - Radeon R200 based system doesn't work correctly with fast user switching
Radeon R200 based system doesn't work correctly with fast user switching
Status: CLOSED DUPLICATE of bug 512944
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 19:23 EDT by Andreas Thienemann
Modified: 2015-01-14 18:22 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-21 13:36:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg.0.log (79.89 KB, text/plain)
2009-04-02 03:52 EDT, David Tardon
no flags Details
Xorg.1.log (79.44 KB, text/plain)
2009-04-02 03:52 EDT, David Tardon
no flags Details
Xorg.2.log (56.97 KB, text/plain)
2009-04-02 03:52 EDT, David Tardon
no flags Details
/var/log/Xorg.0.log (92.80 KB, text/plain)
2009-09-09 10:28 EDT, David Tardon
no flags Details
/var/log/Xorg.5.log (69.67 KB, text/plain)
2009-09-09 10:29 EDT, David Tardon
no flags Details
/var/log/messages (7.97 MB, text/plain)
2009-09-09 10:29 EDT, David Tardon
no flags Details
/etc/X11/xorg.conf (844 bytes, text/plain)
2009-09-09 10:30 EDT, David Tardon
no flags Details

  None (edit)
Description Andreas Thienemann 2009-04-01 19:23:37 EDT
Running the "fastuserswitch" test case for Radeon test day
<https://fedoraproject.org/wiki/QA:Testcase_radeon_fastuserswitch>:
Latest Rawhide can only fastuserswitch once and back when using a R200
based 9100 IGP.

kernel-PAE-2.6.29-21.fc11.i686
xorg-x11-drv-ati-6.12.1-2.fc11.i586

The first switch from the current user to the second user succeeds.
Switching back to the first user works as well.

When switching again to the second user however, the third Xserver running the user chooser is successfully started, but the chooser window is never drawn. The mouse throbber is circling indefinitely and the gdm (?) chooser is stuck only showing the grey background.

Although switching between the three running XServers via CTRL-ALT-F1, F7 or F8 works, the gdm running on F8 is stuck.

Smolt Hardware Profile:
http://www.smolts.org/client/show/pub_84b54df8-37e5-40b8-9a7b-182e41e03b53

This problem is always repeatable so any requests for system logs can be fulfilled.
Comment 1 David Tardon 2009-04-02 03:51:42 EDT
The same problem here.
Comment 2 David Tardon 2009-04-02 03:52:07 EDT
Created attachment 337732 [details]
Xorg.0.log
Comment 3 David Tardon 2009-04-02 03:52:29 EDT
Created attachment 337733 [details]
Xorg.1.log
Comment 4 David Tardon 2009-04-02 03:52:58 EDT
Created attachment 337734 [details]
Xorg.2.log
Comment 5 David Tardon 2009-04-02 03:54:39 EDT
Graphic card:
ATI Technologies Inc RV380 [Radeon X600] [1002:5b72]

Driver version:
xorg-x11-drv-ati-6.12.1-2.fc11.x86_64
Comment 6 François Cami 2009-04-08 17:31:11 EDT
Andreas, David,

If you have rawhide installed, could you try the latest kernel and xorg-x11-drv-ati packages from koji ?
http://koji.fedoraproject.org/koji/buildinfo?buildID=96839
http://koji.fedoraproject.org/koji/buildinfo?buildID=96941
The VT switch should be repaired now. 

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Andreas Thienemann 2009-04-13 06:10:12 EDT
Indeed, with the current code this use case works as designed.

[andreas@workstation ~]$ uname -r; rpm -q xorg-x11-drv-ati
2.6.29.1-68.fc11.i586
xorg-x11-drv-ati-6.12.1-10.fc11.i586
[andreas@workstation ~]$
Comment 8 Andreas Thienemann 2009-04-13 06:20:50 EDT
[andreas@workstation ~]$ rpm -q libdrm
libdrm-2.4.6-4.fc11.i586
[andreas@workstation ~]$
Comment 9 François Cami 2009-04-13 06:43:27 EDT
Thank you Andreas, closing.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 David Tardon 2009-09-09 10:28:05 EDT
After 6 months the problem is back, with the difference that gdm
shows background, incomplete panel and a gray rectangle.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.13.0-0.3.20090908git651fe5a47.fc12.x86_64
xorg-x11-server-Xorg-1.6.99-41.20090825.fc12.x86_64
kernel-2.6.31-0.213.rc9.git1.fc12.x86_64

Additional info:
The xorg.conf is needed because of bug 516162.
Comment 11 David Tardon 2009-09-09 10:28:49 EDT
Created attachment 360235 [details]
/var/log/Xorg.0.log
Comment 12 David Tardon 2009-09-09 10:29:13 EDT
Created attachment 360236 [details]
/var/log/Xorg.5.log
Comment 13 David Tardon 2009-09-09 10:29:58 EDT
Created attachment 360237 [details]
/var/log/messages
Comment 14 David Tardon 2009-09-09 10:30:27 EDT
Created attachment 360238 [details]
/etc/X11/xorg.conf
Comment 15 Dave Airlie 2009-09-13 03:29:16 EDT
I've seen this on Intel and Ben has seen it on nouveau so I think its a gdm issue.

Re assigning to gdm.
Comment 16 David Tardon 2009-09-14 00:54:18 EDT
Version-Release number of selected component (if applicable):
gdm-2.27.90-1.fc12.x86_64
Comment 17 Adam Williamson 2009-10-21 13:36:42 EDT
we've been investigating this in the blocker bug review meeting this morning. it seems there are many reports of this type across multiple types of video hardware. closing all reports as dupes of 512944, which is the earliest report. 512944 will be marked as a release blocker.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 512944 ***

Note You need to log in before you can comment on or make changes to this bug.