Bug 493498 - Anaconda crash - partition ext HDD
Anaconda crash - partition ext HDD
Status: CLOSED DUPLICATE of bug 491348
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:5697313c157ce2af8...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 20:01 EDT by Andrew Ross
Modified: 2013-10-20 18:05 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-02 09:58:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (96.13 KB, text/plain)
2009-04-01 20:01 EDT, Andrew Ross
no flags Details
Attached traceback automatically from anaconda. (83.96 KB, text/plain)
2009-04-02 16:23 EDT, Antonio Hernandez
no flags Details
Attached traceback automatically from anaconda. (99.15 KB, text/plain)
2009-04-02 22:03 EDT, Igor Miletic
no flags Details
Attached traceback automatically from anaconda. (96.54 KB, text/plain)
2009-04-03 08:08 EDT, A. Brown
no flags Details
Attached traceback automatically from anaconda. (77.77 KB, text/plain)
2009-04-07 18:18 EDT, ryck
no flags Details
Attached traceback automatically from anaconda. (74.71 KB, text/plain)
2009-04-08 05:50 EDT, Ben Lambrechts
no flags Details
Attached traceback automatically from anaconda. (95.49 KB, text/plain)
2009-04-08 06:01 EDT, Ben Lambrechts
no flags Details

  None (edit)
Description Andrew Ross 2009-04-01 20:01:21 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.37 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/site-packages/parted/disk.py", line 181, in addPartition
    constraint.getPedConstraint()):
  File "/usr/lib/anaconda/storage/partitioning.py", line 754, in allocatePartitions
    constraint=constraint)
  File "/usr/lib/anaconda/storage/partitioning.py", line 553, in doPartitioning
    allocatePartitions(disks, partitions)
  File "/usr/lib/anaconda/storage/partitioning.py", line 191, in doAutoPartition
    exclusiveDisks=anaconda.id.storage.clearPartDisks)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
PartitionException: Unable to satisfy all constraints on the partition.
Comment 1 Andrew Ross 2009-04-01 20:01:27 EDT
Created attachment 337693 [details]
Attached traceback automatically from anaconda.
Comment 2 Andrew Ross 2009-04-01 20:13:09 EDT
Some further details.

Hardware:
 - External USB HDD (WD 300G Passport)

Partition Options:
 - Use free space to install
 - Install grub onto HDD
 - Customize layout

Tried again choosing overwrite existing Linux partition and got further. Crashed during editing LVM.
Comment 3 Chris Lumens 2009-04-02 09:58:30 EDT

*** This bug has been marked as a duplicate of bug 491348 ***
Comment 4 Antonio Hernandez 2009-04-02 16:23:45 EDT
Created attachment 337907 [details]
Attached traceback automatically from anaconda.
Comment 5 Antonio Hernandez 2009-04-02 16:27:12 EDT
Comment on attachment 337907 [details]
Attached traceback automatically from anaconda.

Is a Partition whit EXT4.
Comment 6 Igor Miletic 2009-04-02 22:03:32 EDT
Created attachment 337961 [details]
Attached traceback automatically from anaconda.
Comment 7 A. Brown 2009-04-03 08:08:17 EDT
Created attachment 338026 [details]
Attached traceback automatically from anaconda.
Comment 8 ryck 2009-04-07 18:18:34 EDT
Created attachment 338620 [details]
Attached traceback automatically from anaconda.
Comment 9 Ben Lambrechts 2009-04-08 05:50:40 EDT
Created attachment 338680 [details]
Attached traceback automatically from anaconda.
Comment 10 Ben Lambrechts 2009-04-08 05:55:52 EDT
I had following partitioning

200 MB NTFS system partition for Windows
15  GB NTFS Windows 2008 R2 beta
30  GB NTFS Windows 2008 R2 beta
30  GB free

I wanted to use the 30 GB of free space for F11 beta
Comment 11 Ben Lambrechts 2009-04-08 06:01:42 EDT
Created attachment 338682 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.