Bug 493523 - Traceback on "write changes" when creating encrypted disk during install - install fails.
Traceback on "write changes" when creating encrypted disk during install - in...
Status: CLOSED DUPLICATE of bug 492354
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:d41a6aea73372d473...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-02 00:53 EDT by Mike Wolf
Modified: 2009-04-27 14:24 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: ======= During install, select "Encrypt System", then press "Next". Consequence: ============ Anaconda indicates file system is being created, then crashes, and install fails. Fix: ==== Result: =======
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-06 13:01:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (168.89 KB, text/plain)
2009-04-02 00:53 EDT, Mike Wolf
no flags Details
Attached traceback automatically from anaconda. (147.70 KB, text/plain)
2009-04-02 03:15 EDT, Ben Lambrechts
no flags Details
Attached traceback automatically from anaconda. (233.25 KB, text/plain)
2009-04-02 16:31 EDT, Flóki Pálsson
no flags Details
Attached traceback automatically from anaconda. (143.13 KB, text/plain)
2009-04-03 15:04 EDT, Brian C. Lane
no flags Details
Attached traceback automatically from anaconda. (206.86 KB, text/plain)
2009-04-05 11:08 EDT, Bob Cochran
no flags Details
Attached traceback automatically from anaconda. (112.71 KB, text/plain)
2009-04-05 22:58 EDT, Joseph Mulloy
no flags Details
Attached traceback automatically from anaconda. (106.09 KB, text/plain)
2009-04-05 23:30 EDT, Joseph Mulloy
no flags Details
Attached traceback automatically from anaconda. (170.91 KB, text/plain)
2009-04-09 07:40 EDT, Frank Murphy
no flags Details
Attached traceback automatically from anaconda. (363.93 KB, text/plain)
2009-04-10 14:05 EDT, Daniel Scott
no flags Details
Attached traceback automatically from anaconda. (156.69 KB, text/plain)
2009-04-16 02:40 EDT, TK009
no flags Details
Attached traceback automatically from anaconda. (237.49 KB, text/plain)
2009-04-16 21:27 EDT, Jeffrey C. Ollie
no flags Details
Attached traceback automatically from anaconda. (120.69 KB, text/plain)
2009-04-19 10:14 EDT, eric@christensenplace.us
no flags Details
Attached traceback automatically from anaconda. (137.97 KB, text/plain)
2009-04-23 22:43 EDT, ConlinDoctrine
no flags Details
Attached traceback automatically from anaconda. (72.18 KB, text/plain)
2009-04-27 14:24 EDT, Joseph Mulloy
no flags Details

  None (edit)
Description Mike Wolf 2009-04-02 00:53:46 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.38 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicelibs/lvm.py", line 371, in lvcreate
    raise LVMError("lvcreate failed for %s/%s" % (vg_name, lv_name))
  File "/usr/lib/anaconda/storage/devices.py", line 1959, in create
    lvm.lvcreate(self.vg.name, self._name, self.size)
  File "/usr/lib/anaconda/storage/deviceaction.py", line 206, in execute
    self.device.create(intf=intf)
  File "/usr/lib/anaconda/storage/devicetree.py", line 659, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 210, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 115, in turnOnFilesystems
    anaconda.id.storage.doIt()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
LVMError: lvcreate failed for VolGroup/lv_swap
Comment 1 Mike Wolf 2009-04-02 00:53:53 EDT
Created attachment 337718 [details]
Attached traceback automatically from anaconda.
Comment 2 Ben Lambrechts 2009-04-02 03:15:19 EDT
Created attachment 337728 [details]
Attached traceback automatically from anaconda.
Comment 3 Flóki Pálsson 2009-04-02 16:31:43 EDT
Created attachment 337916 [details]
Attached traceback automatically from anaconda.
Comment 4 Brian C. Lane 2009-04-03 15:04:50 EDT
Created attachment 338107 [details]
Attached traceback automatically from anaconda.
Comment 5 Bob Cochran 2009-04-05 11:08:43 EDT
Created attachment 338240 [details]
Attached traceback automatically from anaconda.
Comment 6 Bob Cochran 2009-04-05 11:25:34 EDT
The automatic addition in Comment #5 is actually for an x86_64 installation attempt. I attempted the install twice, first as a "replace existing  system" installation using the medialess installation method listed in the Fedora 11 Installation Guide. With the first attempt, I had edited the volume group and logical volume names so they are unique, and I specified encryption for every volume. The blue bar indicating the filesystem is being created went back and forth wildly for a long time, then an exception window opened. My second attempt at installing was a DVD-based install. Again this is for x86_64 and I wanted to encrypt the partitions. For this second installation I accepted the default volume group and logical volume names that were offered. The same behavior as before occured. The system I'm using is a Dell Latitude E6400 notebook with 4 Gb of RAM. I use Fedora 10 on it most of the time.
Comment 7 Mike Wolf 2009-04-05 11:55:04 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
Cause:
=======
During install, select "Encrypt System", then press "Next".

Consequence:
============
Anaconda indicates file system is being created, then crashes, and install fails.

Fix:
====


Result:
=======
Comment 8 Mike Wolf 2009-04-05 12:06:33 EDT
Traceback from comment #1 was i386 install from DVD on Dell Dimension 4700 w/512MB RAM.  I changed the platform indicator above to "ALL" since we have i386 and x86_64.
Comment 9 Brian C. Lane 2009-04-05 12:47:18 EDT
I should also note that the encryption step does appear to succeed, at least on some level. On subsequent attempts to install I was prompted to entry my passphrase before Anaconda would edit the filesystem.
Comment 10 Bob Cochran 2009-04-05 14:31:57 EDT
I agree with Brian in his Comment #9, the encryption step does appear to succeed, in my case with x86_64 install attempts. The existing Linux system I was replacing was also encrypted. It was a Fedora 10 x86_64 system with virtualization features installed and the filesystem was formatted as ext3. I had used the same passphrase for the Fedora 11 system as was on the old system.
Comment 11 Joseph Mulloy 2009-04-05 22:58:59 EDT
Created attachment 338275 [details]
Attached traceback automatically from anaconda.
Comment 12 Joseph Mulloy 2009-04-05 23:30:54 EDT
Created attachment 338277 [details]
Attached traceback automatically from anaconda.
Comment 13 Chris Lumens 2009-04-06 13:01:25 EDT

*** This bug has been marked as a duplicate of bug 492354 ***
Comment 14 Frank Murphy 2009-04-09 07:40:15 EDT
Created attachment 338890 [details]
Attached traceback automatically from anaconda.
Comment 15 Daniel Scott 2009-04-10 14:05:19 EDT
Created attachment 339117 [details]
Attached traceback automatically from anaconda.
Comment 16 Mike Wolf 2009-04-10 18:31:28 EDT
For anyone who ends up on this bug and sees that it is closed, there is a workaround located in the comments of Bug 493575.  This bug was (indirectly) marked as a duplicate of that bug.
Comment 17 TK009 2009-04-16 02:40:49 EDT
Created attachment 339795 [details]
Attached traceback automatically from anaconda.
Comment 18 Jeffrey C. Ollie 2009-04-16 21:27:11 EDT
Created attachment 339954 [details]
Attached traceback automatically from anaconda.
Comment 19 eric@christensenplace.us 2009-04-19 10:14:13 EDT
Created attachment 340234 [details]
Attached traceback automatically from anaconda.
Comment 20 ConlinDoctrine 2009-04-23 22:43:24 EDT
Created attachment 341048 [details]
Attached traceback automatically from anaconda.
Comment 21 Joseph Mulloy 2009-04-27 14:24:42 EDT
Created attachment 341468 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.