Bug 493685 - xenfs mount in fstab causes preupgrade failure in anaconda
xenfs mount in fstab causes preupgrade failure in anaconda
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
anaconda_trace_hash:a405b995736503229...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-02 12:47 EDT by Pasi Karkkainen
Modified: 2009-12-02 01:43 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 494992 (view as bug list)
Environment:
Last Closed: 2009-04-06 11:07:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (114.92 KB, text/plain)
2009-04-02 12:47 EDT, Pasi Karkkainen
no flags Details
Attached traceback automatically from anaconda. (181.63 KB, text/plain)
2009-04-04 20:10 EDT, Callum Lerwick
no flags Details
Attached traceback automatically from anaconda. (142.08 KB, text/plain)
2009-04-08 18:42 EDT, Callum Lerwick
no flags Details
Attached traceback automatically from anaconda. (93.45 KB, text/plain)
2009-07-23 08:28 EDT, Andre Koonings
no flags Details
Attached traceback automatically from anaconda. (102.28 KB, text/plain)
2009-07-25 07:50 EDT, pimduin
no flags Details
Attached traceback automatically from anaconda. (174.84 KB, text/plain)
2009-07-26 03:59 EDT, Aurelian Lavric
no flags Details
Attached traceback automatically from anaconda. (119.81 KB, text/plain)
2009-07-26 10:36 EDT, zymzymzymzym
no flags Details
Attached traceback automatically from anaconda. (105.23 KB, text/plain)
2009-07-27 03:57 EDT, Tchimiche
no flags Details
Attached traceback automatically from anaconda. (110.28 KB, text/plain)
2009-07-29 20:38 EDT, systemssoftware
no flags Details
Attached traceback automatically from anaconda. (100.55 KB, text/plain)
2009-08-02 22:50 EDT, generalmills3808
no flags Details
Attached traceback automatically from anaconda. (158.74 KB, text/plain)
2009-08-05 13:55 EDT, Alan Bird
no flags Details
Attached traceback automatically from anaconda. (158.74 KB, text/plain)
2009-08-06 00:19 EDT, Alan Bird
no flags Details
Attached traceback automatically from anaconda. (164.91 KB, text/plain)
2009-10-04 17:55 EDT, Lee Smith
no flags Details
Attached traceback automatically from anaconda. (164.65 KB, text/plain)
2009-10-12 17:04 EDT, chris suttles
no flags Details
Attached traceback automatically from anaconda. (164.89 KB, text/plain)
2009-10-24 16:27 EDT, Lee Smith
no flags Details
Attached traceback automatically from anaconda. (173.67 KB, text/plain)
2009-12-02 01:43 EST, Vinny Bobarino
no flags Details

  None (edit)
Description Pasi Karkkainen 2009-04-02 12:47:47 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.38 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/__init__.py", line 1346, in parseFSTab
    raise Exception("fstab entry %s is malformed: %s" % (devspec, e))
  File "/usr/lib/anaconda/storage/__init__.py", line 958, in mountExistingSystem
    fsset.parseFSTab(chroot=rootPath)
  File "/usr/lib/anaconda/upgrade.py", line 236, in upgradeMountFilesystems
    allowDirty = 0)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 227, in currentStep
    self.gotoNext()
  File "/usr/lib/anaconda/gui.py", line 1350, in setScreen
    (step, anaconda) = self.anaconda.dispatch.currentStep()
  File "/usr/lib/anaconda/gui.py", line 1513, in setup_window
    self.setScreen()
  File "/usr/lib/anaconda/gui.py", line 1523, in run
    self.setup_window(runres)
  File "/usr/lib/anaconda/gui.py", line 1270, in run
    self.icw.run (self.runres)
  File "/usr/bin/anaconda", line 1029, in <module>
    anaconda.intf.run(anaconda)
Exception: fstab entry none is malformed: 'Device' object has no attribute 'path'
Comment 1 Pasi Karkkainen 2009-04-02 12:47:55 EDT
Created attachment 337848 [details]
Attached traceback automatically from anaconda.
Comment 2 David Lehman 2009-04-02 23:11:55 EDT
This should be fixed in anaconda-11.5.0.40-1.
Comment 3 Callum Lerwick 2009-04-04 20:10:38 EDT
Created attachment 338185 [details]
Attached traceback automatically from anaconda.
Comment 4 Callum Lerwick 2009-04-05 13:19:41 EDT
Mine appears to be from anaconda 11.5.0.40 so no, it's not fixed.
Comment 5 David Lehman 2009-04-06 11:07:49 EDT
This is a completely different failure, and has nothing to do with xenfs. Please open a separate bug.
Comment 6 Callum Lerwick 2009-04-08 18:42:11 EDT
Created attachment 338819 [details]
Attached traceback automatically from anaconda.
Comment 7 Callum Lerwick 2009-04-08 19:34:06 EDT
Well the auto submit thingy is sure insistent on putting it here.
Comment 8 Callum Lerwick 2009-04-08 19:47:03 EDT
Cloned as bug #494992
Comment 9 Andre Koonings 2009-07-23 08:28:55 EDT
Created attachment 354846 [details]
Attached traceback automatically from anaconda.
Comment 10 pimduin 2009-07-25 07:50:05 EDT
Created attachment 355141 [details]
Attached traceback automatically from anaconda.
Comment 11 Aurelian Lavric 2009-07-26 03:59:29 EDT
Created attachment 355182 [details]
Attached traceback automatically from anaconda.
Comment 12 Aurelian Lavric 2009-07-26 04:10:15 EDT
(In reply to comment #11)
> Created an attachment (id=355182) [details]
> Attached traceback automatically from anaconda.  

This was added by the automatic report of anaconda. The problem seems to be treated in Bug#496406 with a fix available in anaconda-12.0-1
Comment 13 zymzymzymzym 2009-07-26 10:36:05 EDT
Created attachment 355197 [details]
Attached traceback automatically from anaconda.
Comment 14 zymzymzymzym 2009-07-26 10:41:25 EDT
(In reply to comment #13)
> Created an attachment (id=355197) [details]
> Attached traceback automatically from anaconda.  

This system is a VMWare guest. I don't know if that has anything to do with it.
Comment 15 pimduin 2009-07-26 17:46:51 EDT
(In reply to comment #10)
> Created an attachment (id=355141) [details]
> Attached traceback automatically from anaconda.  

Like last comment this system also is virtual. Running in VirtualBox 3.0.2.
Comment 16 Tchimiche 2009-07-27 03:57:34 EDT
Created attachment 355240 [details]
Attached traceback automatically from anaconda.
Comment 17 systemssoftware 2009-07-29 20:38:10 EDT
Created attachment 355624 [details]
Attached traceback automatically from anaconda.
Comment 18 generalmills3808 2009-08-02 22:50:13 EDT
Created attachment 355949 [details]
Attached traceback automatically from anaconda.
Comment 19 Alan Bird 2009-08-05 13:55:14 EDT
Created attachment 356392 [details]
Attached traceback automatically from anaconda.
Comment 20 Alan Bird 2009-08-06 00:19:23 EDT
Created attachment 356457 [details]
Attached traceback automatically from anaconda.
Comment 21 Lee Smith 2009-10-04 17:55:28 EDT
Created attachment 363619 [details]
Attached traceback automatically from anaconda.
Comment 22 Lee Smith 2009-10-04 18:02:52 EDT
Comment on attachment 363619 [details]
Attached traceback automatically from anaconda.

I am running Fedora under VMware 6.5.3 build 185404
Comment 23 chris suttles 2009-10-12 17:04:11 EDT
Created attachment 364520 [details]
Attached traceback automatically from anaconda.
Comment 24 Lee Smith 2009-10-24 16:27:51 EDT
Created attachment 365984 [details]
Attached traceback automatically from anaconda.
Comment 25 Vinny Bobarino 2009-12-02 01:43:20 EST
Created attachment 375349 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.