Bug 493722 - Traceback at finding storage devices
Traceback at finding storage devices
Status: CLOSED DUPLICATE of bug 493699
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:79d52cee77fae0804...
:
: 494027 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-02 16:01 EDT by James Twyford
Modified: 2009-05-01 02:27 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-06 11:17:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (79.38 KB, text/plain)
2009-04-02 16:01 EDT, James Twyford
no flags Details
Attached traceback automatically from anaconda. (21.24 KB, text/plain)
2009-04-24 14:13 EDT, Jorge Doutor
no flags Details

  None (edit)
Description James Twyford 2009-04-02 16:01:26 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.38 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/site-packages/block/__init__.py", line 35, in dm_log
    raise Exception, message
  File "/usr/lib64/python2.6/site-packages/block/device.py", line 717, in get_map
    self._RaidSet__map = _dm.map(name=self.name, table=self.rs.dmTable)
  File "/usr/lib64/python2.6/site-packages/block/device.py", line 820, in activate
    self.map.dev.mknod(self.prefix+self.name)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1257, in addUdevDevice
    rs.activate(mknod=True)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1486, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 265, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 90, in storageInitialize
    storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
Exception: device-mapper: reload ioctl failed: Invalid argument
Comment 1 James Twyford 2009-04-02 16:01:35 EDT
Created attachment 337894 [details]
Attached traceback automatically from anaconda.
Comment 2 James Twyford 2009-04-02 16:15:47 EDT
This is probably fallout from <https://bugzilla.redhat.com/show_bug.cgi?id=364901>. At some point I need to wipe the metadata from the drives and start fresh. Anaconda looks like it's seeing both the fakeraid and the mdraid metadata near the end, which is what I'm assuming is breaking Anaconda.
Comment 3 Chris Lumens 2009-04-03 15:15:55 EDT
*** Bug 494027 has been marked as a duplicate of this bug. ***
Comment 4 Chris Lumens 2009-04-06 11:17:29 EDT

*** This bug has been marked as a duplicate of bug 493699 ***
Comment 5 Jorge Doutor 2009-04-24 14:13:51 EDT
Created attachment 341234 [details]
Attached traceback automatically from anaconda.
Comment 6 Jorge Doutor 2009-04-24 16:58:13 EDT
I have a RAID 5 (using motherboard chipset, Intel Matrix, with 3 drives SATA) configuration plus a PATA drive on another motherboard chipset controller, JMicron. The motherboard is an ASUS P5B Plus Vista edition.

From the Asus specs:
Southbridge
6 xSATA 3 Gb/s ports Intel Matrix Storage Technology Support RAID 0,1,5,10
JMicron® JMB363 PATA and SATA controller
1 xUltraDMA 133/100/66 for up to 2 PATA devices
1 xInternal SATA 3.0 Gb/s port
1 xExternal SATA 3.0 Gb/s port (SATA On-the-Go)
Support RAID 0,1,JBOD
(by 1x External SATA & 1x Internal SATA) 


I don't mind that Anaconda doesn't recognize the RAID 5 (this is a dual boot system and in there I have Windows Vista), but I need to install Linux on the PATA drive. I had no problems with previous versions of Fedora (that didn't recognize RAID 5 but installed ok).
Comment 7 Jorge Doutor 2009-05-01 02:27:19 EDT
I solved my problem disabling the RAID 5 controller in the BIOS options and installing again. Of course this way the RAID 5 cannot be seen by Linux, but it couldn't recognize it anyway.

If the controller is disabled, the Fedora 11 system boots and runs well.
If I enable the controller, the system boots, the init 5 login screen appears, but the system hangs at that point.

Note You need to log in before you can comment on or make changes to this bug.