Bug 493869 - S-c-tools cleanup: should offer to install separate docs package if missing
S-c-tools cleanup: should offer to install separate docs package if missing
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: system-config-samba (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
: FutureFeature
: 526643 (view as bug list)
Depends On:
Blocks: 493610
  Show dependency treegraph
 
Reported: 2009-04-03 06:05 EDT by Roman Rakus
Modified: 2016-08-10 10:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-10 10:38:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roman Rakus 2009-04-03 06:05:52 EDT
Description of problem:
Every tool should have help in docbook format. And should be accessible via menu -> help.

How reproducible:
missing help

Steps to Reproduce:
Actual results:
Missing help and/or not docbook format help.

Expected results:
Additional info:
Comment 1 Nils Philippsen 2009-04-08 09:55:53 EDT
Online help is in the separate package system-config-samba-docs which should be installed automatically via comps:

--- 8< --- comps-f11.xml.in ---
  <group>
    <id>online-docs</id>
    <_name>Online Help and Documentation</_name>
    <_description/>
    <default>true</default>
    <uservisible>false</uservisible>
    <packagelist>
      <packagereq type="conditional" requires="system-config-date">system-config-date-docs</packagereq>
      <packagereq type="conditional" requires="system-config-nfs">system-config-nfs-docs</packagereq>
      <packagereq type="conditional" requires="system-config-samba">system-config-samba-docs</packagereq>
      <packagereq type="conditional" requires="system-config-services">system-config-services-docs</packagereq>
      <packagereq type="conditional" requires="system-config-users">system-config-users-docs</packagereq>
    </packagelist>
  </group>
--- >8 -----------------------

I'm not sure if PackageKit honors comps, though.
Comment 2 Nils Philippsen 2009-04-08 09:56:58 EDT
NB: The tool should give better information if the docs package isn't installed, perhaps interact with PackageKit to install the missing package before displaying help.
Comment 3 Roman Rakus 2009-04-08 11:21:56 EDT
It's ok when I install system-config-samba-docs by hand.
Comment 4 Jaroslav Reznik 2009-04-08 11:29:38 EDT
(In reply to comment #1)
> Online help is in the separate package system-config-samba-docs which should be
> installed automatically via comps.
> 
> I'm not sure if PackageKit honors comps, though.  

No, PackageKit doesn't honour comps...

Dependencies Resolved      ============================================================================================
Package Arch Version Repository Size
============================================================================================
      Installing:
      system-config-samba noarch 1.2.71-1.fc11 rawhide 250 k
      Installing for dependencies:
      samba i586 3.3.2-0.33.fc11 rawhide 4.4 M
      Transaction Summary      ============================================================================================
      Install 2 Package(s)

(In reply to comment #2)
> NB: The tool should give better information if the docs package isn't
> installed, perhaps interact with PackageKit to install the missing package
> before displaying help.  

PackageKit integration seems for me like a best solution.
Comment 5 Nils Philippsen 2009-12-30 12:01:25 EST
*** Bug 526643 has been marked as a duplicate of this bug. ***
Comment 7 Nils Philippsen 2016-08-10 10:38:09 EDT
Thanks for taking the time to submit this request for enhancement.
Unfortunately, I haven't gotten around to implement this feature, sorry for
that.

Because I don't actively develop system-config-samba anymore, I won't likely
find the time to work on this ticket, so I'll close this bug now.

Note You need to log in before you can comment on or make changes to this bug.