Bug 493947 - created ext3 fs is in fact ext4
created ext3 fs is in fact ext4
Status: CLOSED DUPLICATE of bug 493206
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-03 08:23 EDT by Michal Hlavinka
Modified: 2009-04-06 10:31 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-06 10:31:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Hlavinka 2009-04-03 08:23:30 EDT
Description of problem:
during installation I used 'create custom layout' with /dev/sda6 for / and "format as: ext3"

installation fails (see bug # )

After this /dev/sda6 can't be mounted using

mount -t ext3 /dev/sda6 /media

(mount: wrong fs type, bad option, bad superblock on /dev/sda6, ...)
but only with:

mount -t ext4 /dev/sda6 /media

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.install system
2.use create custom layout
3.format partition as ext3
  
Actual results:
partition is ext4

Expected results:
partition is ext3

Additional info:

in log:

EXT3-fs: sda6: couldn't mount because of unsupported optional features (240).
EXT3-fs: sda6: couldn't mount because of unsupported optional features (240).
EXT4-fs: barriers enabled
kjournald2 starting: pid 11783, dev sda6:8, commit interval 5 seconds
EXT4 FS on sda6, internal journal on sda6:8
EXT4-fs: delayed allocation enabled
EXT4-fs: file extents enabled
EXT4-fs: mballoc enabled
EXT4-fs: mounted filesystem sda6 with ordered data mode
SELinux: initialized (dev sda6, type ext4), uses xattr
Comment 1 Chris Lumens 2009-04-03 09:53:00 EDT
Was this a livecd install?
Comment 2 Zach Carter 2009-04-04 15:17:03 EDT
I reproduced this bug this morning, similar scenario.

This was a livecd install of the 64 bit F11 beta.

I chose "create custom layout", created / as ext3, did not create a /boot partition, and chose not to install a boot loader.

The install failed at the end trying to mount the / partition.

On a related note, I didn't actually want to choose ext3, but the installer insisted that I could not create / as ext4, since it refused to make ext4 a bootable partition.  That makes sense, however this was a custom layout and I did not want / to be bootable.  Later on I was planning to uncheck the bootloader in the installer, since I wanted to leave my /boot partition alone.
Comment 3 Michal Hlavinka 2009-04-06 04:11:33 EDT
(In reply to comment #1)
> Was this a livecd install?  

yes, F11 KDE Live cd 64 bit
Comment 4 Chris Lumens 2009-04-06 10:31:15 EDT
Yeah, this was a problem with the livecd that we ran into shortly after the beta was released.  Jeremy fixed it up the other day, but unfortunately you will have to wait for another livecd to be produced in order to see the fix.

*** This bug has been marked as a duplicate of bug 493206 ***

Note You need to log in before you can comment on or make changes to this bug.