Bug 493963 - RFE: kerneloops should record the URL to the oops it submits in the logs
RFE: kerneloops should record the URL to the oops it submits in the logs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kerneloops (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 479437 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-03 10:01 EDT by Mike Gahagan
Modified: 2011-12-13 17:28 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-05 20:21:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike Gahagan 2009-04-03 10:01:01 EDT
Description of problem:
Currently the only way to get the URL to a kernel oops submitted by kerneloops is to click on the link in the pop-up window before it goes away. Kerneloops should also record the URL in the system logs by default which would make  bug reporting much easier.

Version-Release number of selected component (if applicable):
F11 Beta
kerneloops-0.12-4.fc11.i586

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chuck Ebbert 2009-04-07 22:33:46 EDT
It's not easy to log all of the submissions because they can be sent in batches, but I added logging of the most recent URL in 0.12-5, which should be good enough since most oopses are sent one at a time.
Comment 2 Chuck Ebbert 2009-04-08 10:52:01 EDT
*** Bug 479437 has been marked as a duplicate of this bug. ***
Comment 3 Chuck Ebbert 2009-05-05 20:21:38 EDT
This seems to be working for me...
Comment 4 Bruce Brackbill 2009-05-26 19:30:12 EDT
Doesn't work for me.

>Currently the only way to get the URL to a kernel oops submitted by kerneloops
>is to click on the link in the pop-up window before it goes away.

This only gives me the http://www.kerneloops.org home page

>It's not easy to log all of the submissions because they can be sent in
>batches, but I added logging of the most recent URL in 0.12-5, which should be
>good enough since most oopses are sent one at a time.  

I see no logging of the url anywhere.  /var/log/messages only shows:
localhost kerneloops: Submitted 1 kernel oopses to www.kerneloops.org

kerneloops-0.12-5.fc11.i586
Comment 5 Kevin R. Page 2009-06-14 08:22:50 EDT
kerneloops-0.12-5.fc11.i586

I'm also not getting a log of the specific URL on submission, either in the logs or from the desktop notification - just a generic mention of kerneloops.org :

kerneloops: Submitted 1 kernel oopses to www.kerneloops.org

(I came to this because I've had some oops go past and wanted to link the relevant kerneloops.org page in the bug report - that'd be useful, wouldn't it?)

Please re-open.

Note You need to log in before you can comment on or make changes to this bug.