Bug 494029 - Fedora11: anaconda exception during partitioning
Fedora11: anaconda exception during partitioning
Status: CLOSED DUPLICATE of bug 491348
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
ppc64 All
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-03 15:11 EDT by IBM Bug Proxy
Modified: 2009-04-03 16:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-03 16:31:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2009-04-03 15:11:25 EDT
=Comment: #0=================================================
Pavan Naregundi <pavan.naregundi@in.ibm.com> - 
During the installation of f11 beta, anaconda gave a exception during partitioning.

Partitioning option selected: "Use entire disk"

===========================
              ┌──────────────┤ Exception Occurred ├──────────────┐
              │                                                  │
              │ anaconda 11.5.0.38 exception report                      ↑ │
              │ Traceback (most recent call first):                        ▮ │
              │   File                                                                       ▒ │
              │ "/usr/lib/python2.6/site-packages/parted/disk  ▒ │
              │ .py", line 181, in addPartition                ▒ │
              │     constraint.getPedConstraint()):            ▒ │
              │   File                                         ▒ │
              │ "/usr/lib/anaconda/storage/partitioning.py",   ▒ │
              │ line 754, in allocatePartitions                ▒ │
              │     constraint=constraint)                     ▒ │
              │   File                                         ▒ │
              │ "/usr/lib/anaconda/storage/partitioning.py",   ↓ │
              │ line 553, in doPartitioning                    ↑ │
              │     allocatePartitions(disks, partitions)      ▒ │
              │   File                                         ▒ │
              │ "/usr/lib/anaconda/storage/partitioning.py",   ▒ │
              │ line 191, in doAutoPartition                   ▒ │
              │                                                ▮ │
              │ exclusiveDisks=anaconda.id.storage.clearPartD  ▒ │
              │ isks)                                          ▒ │
              │   File "/usr/lib/anaconda/dispatch.py", line   ▒ │
              │ 205, in moveStep                               ▒ │
              │     rc = stepFunc(self.anaconda)               ▒ │
              │   File "/usr/lib/anaconda/dispatch.py", line   ↓ │
              │ 128, in gotoNext                               ↑ │
              │     self.moveStep()                            ▒ │
              │   File "/usr/lib/anaconda/text.py", line       ▒ │
              │ 697, in run                                    ▒ │
              │     anaconda.dispatch.gotoNext()               ▒ │
              │   File "/usr/bin/anaconda", line 1029, in      ▒ │
              │ <module>                                       ▒ │
              │     anaconda.intf.run(anaconda)                ▒ │
              │ PartitionException: Unable to satisfy all      ▒ │
              │ constraints on the partition.                  ▒ │
              │                                                ▮ │
              │                                                ↓ │
              
              
Entering debugger...
> /usr/lib/python2.6/site-packages/parted/disk.py(181)addPartition()
-> constraint.getPedConstraint()):
(Pdb) bt
  /usr/bin/anaconda(1033)<module>()
-> handleException(anaconda, sys.exc_info())
  /usr/lib/anaconda/text.py(697)run()
-> anaconda.dispatch.gotoNext()
  /usr/lib/anaconda/dispatch.py(128)gotoNext()
-> self.moveStep()
  /usr/lib/anaconda/dispatch.py(205)moveStep()
-> rc = stepFunc(self.anaconda)
  /usr/lib/anaconda/storage/partitioning.py(214)doAutoPartition()
-> sys.exit(0)
  /usr/lib/anaconda/storage/partitioning.py(553)doPartitioning()
-> allocatePartitions(disks, partitions)
  /usr/lib/anaconda/storage/partitioning.py(754)allocatePartitions()
-> constraint=constraint)
> /usr/lib/python2.6/site-packages/parted/disk.py(181)addPartition()
-> constraint.getPedConstraint()):
(Pdb) l
176             return self.__disk.type.check_feature(feature)
177     
178         def addPartition(self, partition=None, constraint=None):
179             """Add a new Partition to this Disk with the given Constraint."""
180             if self.__disk.add_partition(partition.getPedPartition(),
181  ->                                      constraint.getPedConstraint()):
182                 partition.geometry = parted.Geometry(PedGeometry=partition.getPedPartition().geom)
183                 self.partitions.invalidate()
184                 return True
185             else:
186                 return False
(Pdb) 

======================

Machine: js22 blade
CPU type: power6

=================================================
Hello Red Hat,

could you please help us with this anaconda issue?

It seems there are several RH bugs reporting this "PartitionException: Unable to satisfy all
constraints on the partition" error message, which might have the same root cause of this issue
here. These bugs were all marked as dup of:

https://bugzilla.redhat.com/show_bug.cgi?id=491348

Please let us know in case you need any additional information.

Thanks for your support.
Comment 1 Chris Lumens 2009-04-03 16:31:40 EDT

*** This bug has been marked as a duplicate of bug 491348 ***

Note You need to log in before you can comment on or make changes to this bug.