Bug 494084 - LyX spellcheck does not work
LyX spellcheck does not work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: aspell (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
http://www.lyx.org/trac/ticket/4628
:
: 507228 (view as bug list)
Depends On:
Blocks: 587248 593891
  Show dependency treegraph
 
Reported: 2009-04-03 22:56 EDT by Hezekiah M. Carty
Modified: 2010-05-19 20:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 587248 (view as bug list)
Environment:
Last Closed: 2009-04-16 12:33:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hezekiah M. Carty 2009-04-03 22:56:46 EDT
Description of problem:
LyX spell check does not work on Fedora rawhide (F11 development)

Version-Release number of selected component (if applicable):
lyx-1.6.2-2.fc11.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Start LyX
2. Type something
3. Run spell check and see the resulting error
  
Actual results:
Spell check doesn't work - the error is:
---
The spellchecker could not be started
No word lists can be found for the language "en_US".

Expected results:
Spell check works
Comment 1 Hezekiah M. Carty 2009-04-04 11:14:00 EDT
My apologies, I just needed the aspell-en package.  I did not think this would be necessary though, given http://fedoraproject.org/wiki/Releases/FeatureDictionary

Is this information advertised somewhere?  If so, then I think this bug could be safely closed.  It might be useful to be more explicit somewhere about this in the packaging itself though.
Comment 2 Rex Dieter 2009-04-13 11:51:14 EDT
lyx indeed doesn't support hunspell, only aspell, but aspell *used* to 
Requires: aspell-en

but this dependency was dropped.  not sure why... pinging aspell maintainer...

aspell's changelog says

* Thu Feb 12 2009 ... 12:0.60.6-4
- remove aspell-en require

but doesn't include the reasoning.  It would appear, as is the case here, that aspell-based apps don't work out-of-the-box without it.  Care to explain, please?
Comment 3 Ivana Varekova 2009-04-15 05:16:12 EDT
aspell-en is not necessary dependency for aspell - so it should not be there (because of non-en people).
Comment 4 Rex Dieter 2009-04-15 09:00:28 EDT
Doesn't the precence of this bug invalidate that assertion (aspell-en being not necessary)?

What is the expected behavior of aspell-using apps in the absence of any installed dictionaries?
Comment 5 Ivana Varekova 2009-04-16 07:09:33 EDT
For me it seems it leaves to user the right to chose which dictionary he or she wants and does not implicitly install English dictionary to people who does not use it.
Comment 6 Rex Dieter 2009-04-16 08:43:43 EDT
Consider this, most(all?) aspell dictionaries are referenced in comps' language support groups (good), except aspell-en (bad).  How is aspell-en ever going to get installed, except via manual intervention?

OK, looking closer in comps, I see in the hunspell case, in @base group:

<packagereq type="conditional" requires="hunspell">hunspell-en</packagereq>

perhaps aspell could be treated similarly.  That would only help in initial install, mind you, not afterward, but at least it's a step in the right direction.  Would you have any objection to my requesting the addition of:
<packagereq type="conditional" requires="aspell">aspell-en</packagereq>
?
Comment 7 Rex Dieter 2009-04-16 08:45:13 EDT
reassigning, pending comps feedback.
Comment 8 Rex Dieter 2009-04-16 12:33:54 EDT
discussed with some rel-eng folk on irc, and seems comps is agreeable.  Added 
conditional requires to @base group in comps.
Comment 9 Ivana Varekova 2009-06-26 03:26:19 EDT
*** Bug 507228 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.