Bug 494138 - anaconda crash when editing existing NTFS partition
anaconda crash when editing existing NTFS partition
Status: CLOSED DUPLICATE of bug 495288
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
anaconda_trace_hash:37d0bc958937d5fcd...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-04 19:27 EDT by Phil
Modified: 2009-04-17 13:04 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-13 21:26:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (131.26 KB, text/plain)
2009-04-04 19:27 EDT, Phil
no flags Details
Attached traceback automatically from anaconda. (94.94 KB, text/plain)
2009-04-04 22:37 EDT, Igor Miletic
no flags Details
Attached traceback automatically from anaconda. (102.72 KB, text/plain)
2009-04-17 13:04 EDT, Brian C. Lane
no flags Details

  None (edit)
Description Phil 2009-04-04 19:27:21 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.40 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/partition_ui_helpers_gui.py", line 335, in createPreExistFSOptionSection
    if not formatcb.get_active() and not origfs.migrate:
  File "/usr/lib/anaconda/iw/partition_dialog_gui.py", line 415, in __init__
    (row, self.fsoptionsDict) = createPreExistFSOptionSection(self.origrequest, maintable, row, self.mountCombo, self.storage, luksdev=luksdev)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1110, in editPartition
    restrictfs = restrictfs)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1074, in editCB
    self.editPartition(device)
AttributeError: 'NoneType' object has no attribute 'get_active'
Comment 1 Phil 2009-04-04 19:27:29 EDT
Created attachment 338183 [details]
Attached traceback automatically from anaconda.
Comment 2 Phil 2009-04-04 19:41:32 EDT
Steps to reproduce:

1. use a disk that has an existing NTFS formatted partition and chose "create custom layout"
2. select the NTFS formatted partition and click "edit".

this happens on my raid0 array that is using nvidia 680i fakeraid, my system also has 2 other disks in jbod.
Comment 3 Igor Miletic 2009-04-04 22:37:04 EDT
Created attachment 338194 [details]
Attached traceback automatically from anaconda.
Comment 4 Igor Miletic 2009-04-04 22:46:36 EDT
Just to add that in my case partition was ext2. I simply tried to label it as /boot when trying to install F11-rawhide from boot.iso (todays rawhide).

However, I did have two other partitions that where NTFS on the same disk.
Comment 5 David Cantrell 2009-04-13 21:26:08 EDT

*** This bug has been marked as a duplicate of bug 495288 ***
Comment 6 Brian C. Lane 2009-04-17 13:04:16 EDT
Created attachment 340046 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.