Bug 495288 - AttributeError: 'NoneType' object has no attribute 'get_active'
AttributeError: 'NoneType' object has no attribute 'get_active'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
: 494138 495202 495404 495584 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-11 04:04 EDT by Joachim Frieben
Modified: 2009-05-03 10:54 EDT (History)
8 users (show)

See Also:
Fixed In Version: anaconda-11.5.0.48-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-03 10:54:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Anaconda exception report (56.69 KB, text/plain)
2009-04-11 04:04 EDT, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2009-04-11 04:04:31 EDT
Created attachment 339156 [details]
Anaconda exception report

Description of problem:
After booting F11-Snap1-Live-i686 on a standard Intel P4 system with a single attached IDE disk, liveinst crashes when a volume of the existing custom disk layout is edited.

Version-Release number of selected component (if applicable):
anaconda-11.5.0.42-1.i586

How reproducible:
Always.

Steps to Reproduce:
1. Start liveinst on F11-Snap1-Live-i686.
2. Edit existing LVM disk layout.
  
Actual results:
Installer aborts with an exception when editing the first volume in order to set file system type and mount point.

Expected results:
Existing disk layout can be edited for further use.

Additional info:
- There was a similar bug which affected F11-rawhide maybe 2 months ago, but
  it did not occur for the later F11-Nouveau-Test-Day release. So, I guess
  it's a new bug.
- Custom disk layout was chosen. Only file system type and mount point of the
  existing volumes were intended to be customized.
Comment 1 James Laska 2009-04-13 10:16:04 EDT
Expanding traceback from comment#0 

anaconda None exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/partition_ui_helpers_gui.py", line 334, in createPreExistFSOptionSection
    if not formatcb.get_active() and not origfs.migrate:
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 491, in editLogicalVolume
    (row, self.fsoptionsDict) = createPreExistFSOptionSection(reallv, maintable, row, mountCombo, self.storage, ignorefs = ["mdmember", "lvmpv", "vfat"], luksdev=templuks)
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 716, in editCurrentLogicalVolume
    self.editLogicalVolume(lv)
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 747, in editLogicalVolumeCB
    self.editCurrentLogicalVolume()
AttributeError: 'NoneType' object has no attribute 'get_active'
Comment 2 Chris Lumens 2009-04-13 10:23:54 EDT
*** Bug 495202 has been marked as a duplicate of this bug. ***
Comment 3 Chris Lumens 2009-04-13 17:00:52 EDT
*** Bug 495584 has been marked as a duplicate of this bug. ***
Comment 4 David Cantrell 2009-04-13 21:26:08 EDT
*** Bug 494138 has been marked as a duplicate of this bug. ***
Comment 5 David Cantrell 2009-04-13 23:43:19 EDT
Fixed in anaconda-11.5.0.44-1
Comment 6 MartinG 2009-04-14 06:07:17 EDT
I just tried the Fedora-11-Snap1-x86_64-Live-KDE CD again, downloaded and installed anaconda-11.5.0.44-1 from koji and then ran install to disk. Resulted in new crash, see bug 495665.
Comment 7 Chris Lumens 2009-04-14 09:33:35 EDT
*** Bug 495404 has been marked as a duplicate of this bug. ***
Comment 8 Bruno Wolff III 2009-04-19 14:57:44 EDT
I am still seeing something that might be related to this. I got a message about a failure to destroy sdb and then another traceback when I tried to directly file a bug from anaconda. Using dd to wipe the partition info allowed me to get past that issue. This was with 11.5.0.46-1.
Comment 9 Bruno Wolff III 2009-04-26 18:16:01 EDT
With 11.5.0.47-1 I was able to complete an encrypted raid install.
Comment 10 Joachim Frieben 2009-05-03 10:54:12 EDT
I haven't seen this issue with recent versions of anaconda.

Note You need to log in before you can comment on or make changes to this bug.