Bug 494163 - Resume failure with nouveau [NEEDINFO]
Resume failure with nouveau
Status: CLOSED DUPLICATE of bug 459323
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-05 04:53 EDT by David Woodhouse
Modified: 2009-04-05 23:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-05 23:43:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sgireeshmail: needinfo? (dwmw2)


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2009-04-05 04:53:03 EDT
My MacBookPro4,1 resumes OK when I'm using the nv driver. With nouveau, it the screen doesn't come back (although now I look at the logs I think the machine was alive)

Apr  5 06:02:28 macbook kernel: PM: Syncing filesystems ... done.
Apr  5 06:02:28 macbook kernel: Freezing user space processes ... (elapsed 0.00 seconds) done.
Apr  5 06:02:28 macbook kernel: Freezing remaining freezable tasks ... (elapsed 0.00 seconds) done.
Apr  5 06:02:28 macbook kernel: Suspending console(s) (use no_console_suspend to debug)
Apr  5 06:02:28 macbook kernel: btusb_bulk_complete: hci0 urb ffff880131fa4300 failed to resubmit (1)
Apr  5 06:02:28 macbook kernel: btusb_bulk_complete: hci0 urb ffff880131fa43c0 failed to resubmit (1)
Apr  5 06:02:28 macbook kernel: btusb_intr_complete: hci0 urb ffff880131fa4480 failed to resubmit (1)
Apr  5 06:02:28 macbook kernel: sd 2:0:0:0: [sda] Synchronizing SCSI cache
Apr  5 06:02:28 macbook kernel: sd 2:0:0:0: [sda] Stopping disk
Apr  5 06:02:28 macbook kernel: sky2 0000:0c:00.0: PME# disabled
Apr  5 06:02:28 macbook kernel: nouveau 0000:01:00.0: PCI INT A disabled
Apr  5 06:02:28 macbook kernel: pci 0000:00:1f.3: PCI INT C disabled
Apr  5 06:02:28 macbook kernel: ata_piix 0000:00:1f.2: PCI INT B disabled
Apr  5 06:02:28 macbook kernel: ata_piix 0000:00:1f.1: PCI INT A disabled
Apr  5 06:02:28 macbook kernel: ata_piix 0000:00:1f.1: power state changed by ACPI to D3
Apr  5 06:02:28 macbook kernel: ehci_hcd 0000:00:1d.7: PCI INT D disabled
Apr  5 06:02:28 macbook kernel: ehci_hcd 0000:00:1d.7: PME# disabled
Apr  5 06:02:28 macbook kernel: uhci_hcd 0000:00:1d.2: PCI INT C disabled
Apr  5 06:02:28 macbook kernel: uhci_hcd 0000:00:1d.1: PCI INT B disabled
Apr  5 06:02:28 macbook kernel: uhci_hcd 0000:00:1d.0: PCI INT A disabled
Apr  5 06:02:28 macbook kernel: pciehp 0000:00:1c.5:pcie02: pciehp_suspend ENTRY
Apr  5 06:02:28 macbook kernel: pciehp 0000:00:1c.4:pcie02: pciehp_suspend ENTRY
Apr  5 06:02:28 macbook kernel: pciehp 0000:00:1c.2:pcie02: pciehp_suspend ENTRY
Apr  5 06:02:28 macbook kernel: pciehp 0000:00:1c.0:pcie02: pciehp_suspend ENTRY
Apr  5 06:02:28 macbook kernel: HDA Intel 0000:00:1b.0: PCI INT A disabled
Apr  5 06:02:28 macbook kernel: ehci_hcd 0000:00:1a.7: PCI INT C disabled
Apr  5 06:02:28 macbook kernel: ehci_hcd 0000:00:1a.7: PME# disabled
Apr  5 06:02:28 macbook kernel: uhci_hcd 0000:00:1a.1: PCI INT B disabled
Apr  5 06:02:28 macbook kernel: uhci_hcd 0000:00:1a.0: PCI INT A disabled
Apr  5 06:02:28 macbook kernel: pciehp 0000:00:01.0:pcie02: pciehp_suspend ENTRY
Apr  5 06:02:28 macbook kernel: ACPI: Preparing to enter system sleep state S3
Apr  5 06:02:28 macbook kernel: Disabling non-boot CPUs ...
Apr  5 06:02:28 macbook kernel: Broke affinity for irq 9
Apr  5 06:02:28 macbook kernel: Broke affinity for irq 16
Apr  5 06:02:28 macbook kernel: Broke affinity for irq 21
Apr  5 06:02:28 macbook kernel: kvm: disabling virtualization on CPU1
Apr  5 06:02:28 macbook kernel: CPU 1 is now offline
Apr  5 06:02:28 macbook kernel: SMP alternatives: switching to UP code
Apr  5 06:02:28 macbook kernel: CPU1 is down
Apr  5 06:02:28 macbook kernel: Extended CMOS year: 2000
Apr  5 06:02:28 macbook kernel: x86 PAT enabled: cpu 0, old 0x7040600070406, new 0x7010600070106
Apr  5 06:02:28 macbook kernel: CPU0: Thermal monitoring enabled (TM2)
Apr  5 06:02:28 macbook kernel: Extended CMOS year: 2000
Apr  5 06:02:28 macbook kernel: pciehp 0000:00:01.0:pcie02: Card present on Slot(1)
Apr  5 06:02:28 macbook kernel: pciehp 0000:00:1c.4:pcie02: Card present on Slot(4)
Apr  5 06:02:28 macbook kernel: pciehp 0000:00:1c.5:pcie02: Card present on Slot(5)
Apr  5 06:02:28 macbook kernel: Enabling non-boot CPUs ...
Apr  5 06:02:28 macbook kernel: Broke affinity for irq 9
Apr  5 06:02:28 macbook kernel: Broke affinity for irq 16
Apr  5 06:02:28 macbook kernel: Broke affinity for irq 21
Apr  5 06:02:28 macbook kernel: kvm: disabling virtualization on CPU1
Apr  5 06:02:28 macbook kernel: CPU 1 is now offline
Apr  5 06:02:28 macbook kernel: SMP alternatives: switching to UP code
Apr  5 06:02:28 macbook kernel: CPU1 is down
Apr  5 06:02:28 macbook kernel: Extended CMOS year: 2000
Apr  5 06:02:28 macbook kernel: x86 PAT enabled: cpu 0, old 0x7040600070406, new 0x7010600070106
Apr  5 06:02:28 macbook kernel: CPU0: Thermal monitoring enabled (TM2)
Apr  5 06:02:28 macbook kernel: Extended CMOS year: 2000
Apr  5 06:02:28 macbook kernel: pciehp 0000:00:01.0:pcie02: Card present on Slot(1)
Apr  5 06:02:28 macbook kernel: pciehp 0000:00:1c.4:pcie02: Card present on Slot(4)
Apr  5 06:02:28 macbook kernel: pciehp 0000:00:1c.5:pcie02: Card present on Slot(5)
Apr  5 06:02:28 macbook kernel: Enabling non-boot CPUs ...
Apr  5 06:02:28 macbook kernel: SMP alternatives: switching to SMP code
Apr  5 06:02:28 macbook kernel: pciehp 0000:00:1c.4:pcie02: Device 0000:0b:00.0 already exists at 0000:0b:00
, cannot hot-add
Apr  5 06:02:28 macbook kernel: pciehp 0000:00:1c.4:pcie02: Cannot add device at 0000:0b:00
Apr  5 06:02:28 macbook kernel: Booting processor 1 APIC 0x1 ip 0x6000
Apr  5 06:02:28 macbook kernel: Initializing CPU#1
Apr  5 06:02:28 macbook kernel: Calibrating delay using timer specific routine.. 4987.14 BogoMIPS (lpj=24935
74)
Apr  5 06:02:28 macbook kernel: CPU: L1 I cache: 32K, L1 D cache: 32K
Apr  5 06:02:28 macbook kernel: CPU: L2 cache: 6144K
Apr  5 06:02:28 macbook kernel: [ds] using Core 2/Atom configuration
Apr  5 06:02:28 macbook kernel: CPU 1/0x1 -> Node 0
Apr  5 06:02:28 macbook kernel: CPU: Physical Processor ID: 0
Apr  5 06:02:28 macbook kernel: CPU: Processor Core ID: 1
Apr  5 06:02:28 macbook kernel: CPU1: Thermal monitoring enabled (TM2)
Apr  5 06:02:28 macbook kernel: x86 PAT enabled: cpu 1, old 0x7040600070406, new 0x7010600070106
Apr  5 06:02:28 macbook kernel: CPU1: Intel(R) Core(TM)2 Duo CPU     T9300  @ 2.50GHz stepping 06
Apr  5 06:02:28 macbook kernel: kvm: enabling virtualization on CPU1
Apr  5 06:02:28 macbook kernel: CPU1 is up
Apr  5 06:02:28 macbook kernel: ACPI: Waking up from system sleep state S3
Apr  5 06:02:28 macbook kernel: pciehp 0000:00:1c.5:pcie02: Device 0000:0c:00.0 already exists at 0000:0c:00
, cannot hot-add
Apr  5 06:02:28 macbook kernel: pciehp 0000:00:1c.5:pcie02: Cannot add device at 0000:0c:00
Apr  5 06:02:28 macbook kernel: ACPI: EC: non-query interrupt received, switching to interrupt mode
Apr  5 06:02:28 macbook kernel: pciehp 0000:00:01.0:pcie02: pciehp_resume ENTRY
Apr  5 06:02:28 macbook kernel: uhci_hcd 0000:00:1a.0: PCI INT A -> GSI 20 (level, low) -> IRQ 20
Apr  5 06:02:28 macbook kernel: usb usb3: root hub lost power or was reset
Apr  5 06:02:28 macbook kernel: uhci_hcd 0000:00:1a.1: PCI INT B -> GSI 16 (level, low) -> IRQ 16
Apr  5 06:02:28 macbook kernel: usb usb4: root hub lost power or was reset
Apr  5 06:02:28 macbook kernel: ehci_hcd 0000:00:1a.7: PME# disabled
Apr  5 06:02:28 macbook kernel: ehci_hcd 0000:00:1a.7: PCI INT C -> GSI 21 (level, low) -> IRQ 21
Apr  5 06:02:28 macbook kernel: ehci_hcd 0000:00:1a.7: PME# disabled
Apr  5 06:02:28 macbook kernel: HDA Intel 0000:00:1b.0: PCI INT A -> GSI 20 (level, low) -> IRQ 20
Apr  5 06:02:28 macbook kernel: pciehp 0000:00:1c.0:pcie02: pciehp_resume ENTRY
Apr  5 06:02:28 macbook kernel: pciehp 0000:00:1c.2:pcie02: pciehp_resume ENTRY
Apr  5 06:02:28 macbook kernel: pciehp 0000:00:1c.4:pcie02: pciehp_resume ENTRY
Apr  5 06:02:28 macbook kernel: pciehp 0000:00:1c.5:pcie02: pciehp_resume ENTRY
Apr  5 06:02:28 macbook kernel: uhci_hcd 0000:00:1d.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
Apr  5 06:02:28 macbook kernel: usb usb5: root hub lost power or was reset
Apr  5 06:02:28 macbook kernel: uhci_hcd 0000:00:1d.1: PCI INT B -> GSI 18 (level, low) -> IRQ 18
Apr  5 06:02:28 macbook kernel: usb usb6: root hub lost power or was reset
Apr  5 06:02:28 macbook kernel: uhci_hcd 0000:00:1d.2: PCI INT C -> GSI 21 (level, low) -> IRQ 21
Apr  5 06:02:28 macbook kernel: usb usb7: root hub lost power or was reset
Apr  5 06:02:28 macbook kernel: ehci_hcd 0000:00:1d.7: PME# disabled
Apr  5 06:02:28 macbook kernel: ehci_hcd 0000:00:1d.7: PCI INT D -> GSI 20 (level, low) -> IRQ 20
Apr  5 06:02:28 macbook kernel: ehci_hcd 0000:00:1d.7: PME# disabled
Apr  5 06:02:28 macbook kernel: pci 0000:00:1e.0: power state changed by ACPI to D0
Apr  5 06:02:28 macbook kernel: ata_piix 0000:00:1f.1: power state changed by ACPI to D0
Apr  5 06:02:28 macbook kernel: ata_piix 0000:00:1f.1: power state changed by ACPI to D0
Apr  5 06:02:28 macbook kernel: ata_piix 0000:00:1f.1: PCI INT A -> GSI 21 (level, low) -> IRQ 21
Apr  5 06:02:28 macbook kernel: ata_piix 0000:00:1f.2: PCI INT B -> GSI 18 (level, low) -> IRQ 18
Apr  5 06:02:28 macbook kernel: pci 0000:00:1f.3: PCI INT C -> GSI 20 (level, low) -> IRQ 20
Apr  5 06:02:28 macbook kernel: nouveau 0000:01:00.0: PME# disabled
Apr  5 06:02:28 macbook kernel: nouveau 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
Apr  5 06:02:28 macbook kernel: sky2 0000:0c:00.0: PME# disabled
Apr  5 06:02:28 macbook kernel: firewire_core: skipped bus generations, destroying all nodes
Apr  5 06:02:28 macbook kernel: sd 2:0:0:0: [sda] Starting disk
Apr  5 06:02:28 macbook kernel: ata1.01: ACPI cmd ef/03:01:00:00:00:b0 filtered out
Apr  5 06:02:28 macbook kernel: ata1.01: ACPI cmd ef/03:ff:00:00:00:b0 filtered out
Apr  5 06:02:28 macbook kernel: ata1.01: configured for UDMA/66
Apr  5 06:02:28 macbook kernel: firewire_core: rediscovered device fw0
Apr  5 06:02:28 macbook kernel: ata3.00: ACPI cmd ef/03:0c:00:00:00:a0 filtered out
Apr  5 06:02:28 macbook kernel: ata3.00: ACPI cmd ef/03:45:00:00:00:a0 filtered out
Apr  5 06:02:28 macbook kernel: ata3.00: configured for UDMA/133
Apr  5 06:02:28 macbook kernel: sd 2:0:0:0: [sda] 488397168 512-byte hardware sectors: (250 GB/232 GiB)
Apr  5 06:02:28 macbook kernel: sd 2:0:0:0: [sda] Write Protect is off
Apr  5 06:02:28 macbook kernel: sd 2:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support
 DPO or FUA
Apr  5 06:02:28 macbook kernel: usb 1-3: reset high speed USB device using ehci_hcd and address 3
Apr  5 06:02:28 macbook kernel: usb 3-1: reset full speed USB device using uhci_hcd and address 2
Apr  5 06:02:28 macbook kernel: usb 7-1: reset low speed USB device using uhci_hcd and address 2
Apr  5 06:02:28 macbook kernel: usb 7-2: reset full speed USB device using uhci_hcd and address 3
Apr  5 06:02:28 macbook kernel: usb 3-1.1: reset full speed USB device using uhci_hcd and address 3
Apr  5 06:02:28 macbook kernel: btusb 3-1.1:1.0: no reset_resume for driver btusb?
Apr  5 06:02:28 macbook kernel: btusb 3-1.1:1.1: no reset_resume for driver btusb?
Apr  5 06:02:28 macbook bluetoothd[2645]: Stopping security manager 0
Apr  5 06:02:28 macbook bluetoothd[2645]: HCI dev 0 down
Apr  5 06:02:28 macbook bluetoothd[2645]: Adapter /org/bluez/2645/hci0 has been disabled
Apr  5 06:02:28 macbook bluetoothd[2645]: HCI dev 0 unregistered
Apr  5 06:02:28 macbook bluetoothd[2645]: Unregister path: /org/bluez/2645/hci0
Apr  5 06:02:28 macbook bluetoothd[2645]: HCI dev 0 registered
Apr  5 06:02:28 macbook kernel: Restarting tasks ... done.
Apr  5 06:02:28 macbook bluetoothd[2645]: HCI dev 0 up
Apr  5 06:02:28 macbook bluetoothd[2645]: Starting security manager 0
Apr  5 06:02:28 macbook bluetoothd[4224]: Bluetooth daemon 4.34
Apr  5 06:02:28 macbook bluetoothd[4224]: Unable to get on D-Bus
Apr  5 06:02:28 macbook bluetoothd[2645]: rfcomm_bind: Address already in use (98)
Apr  5 06:02:28 macbook bluetoothd[2645]: audio-headset: Operation not permitted (1)
Apr  5 06:02:28 macbook bluetoothd[2645]: l2cap_bind: Address already in use (98)
Apr  5 06:02:28 macbook bluetoothd[2645]: audio-a2dp: Operation not permitted (1)
Apr  5 06:02:28 macbook bluetoothd[2645]: probe failed with driver input-headset for device /org/bluez/2645/
hci0/dev_00_1D_E9_13_F6_C4
Apr  5 06:02:28 macbook bluetoothd[2645]: probe failed with driver input-headset for device /org/bluez/2645/
hci0/dev_00_0D_93_05_4A_3E
Apr  5 06:02:28 macbook bluetoothd[2645]: probe failed with driver input-headset for device /org/bluez/2645/
hci0/dev_00_1C_62_F8_28_2F
Apr  5 06:02:28 macbook bluetoothd[2645]: probe failed with driver input-headset for device /org/bluez/2645/
hci0/dev_00_11_24_66_3E_E2
Apr  5 06:02:28 macbook bluetoothd[2645]: probe failed with driver input-headset for device /org/bluez/2645/
hci0/dev_00_24_7D_E7_02_73
Apr  5 06:02:28 macbook bluetoothd[2645]: Adapter /org/bluez/2645/hci0 has been enabled


After this, I power cycled it. I'll try to get an Xorg log too.
Comment 1 Gireesh Sreekantan 2009-04-05 23:43:26 EDT
We already have a bug open for the same issue - https://bugzilla.redhat.com/show_bug.cgi?id=459323.

I am marking this bug out as duplicate and closing it.


Thank you for taking the time to report this bug. 

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 459323 ***

Note You need to log in before you can comment on or make changes to this bug.