Bug 459323 - nvidia video card: X does not resume after suspend
nvidia video card: X does not resume after suspend
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
11
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs
: 494163 510126 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-16 10:11 EDT by Cristian Ciupitu
Modified: 2009-09-27 04:20 EDT (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-27 04:20:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from the lshal command (142.68 KB, text/plain)
2008-08-16 10:11 EDT, Cristian Ciupitu
no flags Details
xorg.conf (806 bytes, text/plain)
2008-08-16 10:15 EDT, Cristian Ciupitu
no flags Details
Xorg.0.log for the previous xorg.conf (354.33 KB, text/plain)
2008-09-15 16:40 EDT, Cristian Ciupitu
no flags Details
dmesg for the previous xorg.conf (44.20 KB, text/plain)
2008-09-15 16:46 EDT, Cristian Ciupitu
no flags Details

  None (edit)
Description Cristian Ciupitu 2008-08-16 10:11:44 EDT
Created attachment 314428 [details]
output from the lshal command

Description of problem:
Systems using the nouveau X11 driver for Nvidia graphics cards will not reactivate their display upon resume from hibernate.

Version-Release number of selected component (if applicable):
xorg-x11-drv-nouveau-0.0.10-2.20080408git0991281.fc9.i386

How reproducible:
Every time.

Steps to Reproduce:
1. Activate the nouveau driver
2. Hibernate (from the GNOME menu) the system
3. Wake the system up from hibernation

Actual results:
Text-mode display with console login, but the keyboard does not seem to work.
Only then Ctrl-Alt-Del combination works, but the system gets stuck when
stopping (or after, I don't remember exactly) the lm_sensors service.

Expected results:
Regular X display.

Additional info:
The binary driver from NVidia works fine.
I have a NVidia 7600 GS card installed on an Intel P965LT motherboard and I'm running kernel-2.6.25.14-108.fc9.i686.
Comment 1 Cristian Ciupitu 2008-08-16 10:15:50 EDT
Created attachment 314429 [details]
xorg.conf
Comment 2 Matěj Cepl 2008-09-11 17:12:03 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachment using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Cristian Ciupitu 2008-09-15 16:40:53 EDT
Created attachment 316781 [details]
Xorg.0.log for the previous xorg.conf
Comment 4 Cristian Ciupitu 2008-09-15 16:46:10 EDT
Created attachment 316782 [details]
dmesg for the previous xorg.conf

The X server crashed when powering up after hibernation. The relevant information should be at the end of the file (I've attached the whole file, just in case).
Comment 5 Cristian Ciupitu 2008-09-15 16:49:57 EDT
Without the "/etc/X11/xorg.conf" file the nv driver was used, instead of nouveau and this bug is about nouveau.
Comment 6 Cristian Ciupitu 2008-09-16 06:26:33 EDT
Hibernate works fine with the nv driver, if I don't have the "/etc/X11/xorg.conf" file.
Comment 7 Cristian Ciupitu 2008-12-08 15:23:40 EST
I'm having the same problem with Fedora 10, so maybe the bug should be changed to Fedora 10.

Now, I'm getting something along:
[drm: nouveau_ramht_remove] *ERROR* RAMHT entry not found ch=1, handle=0x80000001
... (same lines as above)
... freeing fifo0
Comment 9 Gideon Mayhak 2009-02-17 21:51:42 EST
I experience this on my laptop, as well.  Resume from suspend does not work.  Screen backlight stays off and the keyboard appears to be unresponsive.  Pressing the power button does result in some hard drive activity, so I'm guessing it's not completely locked up.  Here is a relevant bit from lspci -vv:

00:05.0 VGA compatible controller: nVidia Corporation MCP51 PCI-X GeForce Go 6100 (rev a2) (prog-if 00 [VGA controller])
	Subsystem: Hewlett-Packard Company Device 30b7
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin A routed to IRQ 17
	Region 0: Memory at b2000000 (32-bit, non-prefetchable) [size=16M]
	Region 1: Memory at c0000000 (64-bit, prefetchable) [size=256M]
	Region 3: Memory at b1000000 (64-bit, non-prefetchable) [size=16M]
	[virtual] Expansion ROM at 88000000 [disabled] [size=128K]
	Capabilities: [48] Power Management version 2
		Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 PME-Enable- DSel=0 DScale=0 PME-
	Capabilities: [50] MSI: Mask- 64bit+ Count=1/1 Enable-
		Address: 0000000000000000  Data: 0000
	Kernel modules: nvidiafb

Let me know what else you need from me to help resume from suspend work!
Comment 10 Gideon Mayhak 2009-02-17 21:53:33 EST
By the way, I'm currently running a fully updated rawhide install, but this has always been true with nouveau.
Comment 11 Gireesh Sreekantan 2009-04-05 23:43:26 EDT
*** Bug 494163 has been marked as a duplicate of this bug. ***
Comment 12 Phil Anderson 2009-04-13 07:18:52 EDT
Same problem on my NVIDIA FX 5700.  Suspend works fine with the nv driver.
Comment 13 Gideon Mayhak 2009-04-22 22:43:50 EDT
What kind of thoughts are there on resume from suspend right now?  How far are we from having functional resume in the nouveau driver?  Is there any particular information I/we can provide to help?  It seems my laptop suspends just fine, but the display fails to come back up and the keyboard is dead upon resume.
Comment 14 Sean E. Millichamp 2009-05-10 21:37:40 EDT
I am also having this problem and am unable to resume from suspend with the nouveau driver.  My keyboard also seems unresponsive upon a resume.
Comment 15 Sean E. Millichamp 2009-05-10 21:38:46 EDT
Sorry, I forgot to mention the version I am running F11 Preview and using:

xorg-x11-drv-nouveau-0.0.11-1.20090106git133c1a5.fc10.x86_64
Comment 16 Steven W. Carter 2009-05-10 21:45:55 EDT
Have all of you checked to see if your video-card hardware has been tested over at this link: https://fedoraproject.org/wiki/Test_Day:2009-03-26_Nouveau

If not, please consider providing the results of those tests as described on the page.  There may be pertinent information that is helpful in solving this and other issues.
Comment 17 Sean E. Millichamp 2009-05-10 22:10:43 EDT
(In reply to comment #15)
> Sorry, I forgot to mention the version I am running F11 Preview and using:
> 
> xorg-x11-drv-nouveau-0.0.11-1.20090106git133c1a5.fc10.x86_64  

Crud.  I ran the rpm -q over SSH on a F10 box by mistake.  The real version is:

xorg-x11-drv-nouveau-0.0.12-34.20090507git1072103.fc11.i586

And my hardware is listed as supported from the Nouveau test day.

NVIDIA GeForce G72M GeForce Go 7400 [10de:01d8]
Comment 18 Christoph Wickert 2009-05-11 05:52:11 EDT
(In reply to comment #16)
> Have all of you checked to see if your video-card hardware has been tested over
> at this link: https://fedoraproject.org/wiki/Test_Day:2009-03-26_Nouveau

Correct me if I'm wrong, but resume after suspend wasn't tested at all.

> If not, please consider providing the results of those tests as described on
> the page.  There may be pertinent information that is helpful in solving this
> and other issues.  

OK, I will do this later today.
Comment 19 Gireesh Sreekantan 2009-06-03 00:24:03 EDT
> Have all of you checked to see if your video-card hardware has been tested over
> at this link: https://fedoraproject.org/wiki/Test_Day:2009-03-26_Nouveau

Yes mine was tested and my results are posted under my name on the test page. Suspend/Resume still fails with nouveau on a fully updated Rawhide. 

My card is nVidia C51 [Geforce 6150 Go] [10de:0244] (rev a2)
Comment 20 Niels Haase 2009-06-03 17:27:46 EDT
Same problem here, resume from suspend nor hibernate works.

nVidia Corporation Quadro NVS 160M [10de:06eb] (rev a1)

xorg-x11-drv-nouveau-0.0.12-37.20090514git9656762.fc11.x86_64
2.6.29.4-167.fc11.x86_64


I think the problem is also present in rawhide for the above reported problems. Therefore I changed the release version from F10 to rawhide. 

There is also the CommonBugs keyword set, witch means that this bug is known at a common bugs in Fedora 11.

Please find more information at:

https://fedoraproject.org/wiki/Common_F11_bugs#Resume_from_suspend_fails_with_NVIDIA_graphics_adapters

If you also affected by this problem, please provide an additional comment to this bug and give us your pci id of the NVIDIA graphic card (lspci -nn | grep VGA)

Thank you.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 21 Adam Williamson 2009-06-03 17:46:27 EDT
we don't actually need the PCI ID. We actually know that this just doesn't work on any hardware at present, and the developers know more or less what needs to be done to fix it, there just hasn't been time yet (it's a big area of work). So specific information about affected hardware isn't needed at this point in time.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 22 Bug Zapper 2009-06-09 05:40:29 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 23 Bas Mevissen 2009-06-09 18:36:03 EDT
Strange thing is that this used to work on my Dell Precision M6300 on Fedora 11 Preview. I'm not sure what change broke the hibernate on my notebook.
Comment 24 Adam Williamson 2009-06-09 19:03:20 EDT
that is strange, afaik Ben doesn't expect suspend to work on any hardware at present. are you sure you weren't using the proprietary driver or anything?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 25 Nick 2009-06-10 19:41:11 EDT
I'm seeing this on F11 with a Thinkpad T61P, and livna/rpmfusion doesn't currently have "nvidia-kmod", so I'm SOL. Thanks!
Comment 26 Nick 2009-06-10 19:43:45 EDT
Er, kmod-nvidia. You know what I mean.
Comment 27 Adam Williamson 2009-06-10 19:48:49 EDT
Use the akmod. But Bugzilla isn't a discussion forum.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 28 Nick 2009-06-10 20:15:44 EDT
Ended up downloading and running the install package directly from nvidia, worked fine (after installing kernel-dev).

Just keepin' the wheel squeaky.
Comment 29 Josh Moline 2009-06-24 15:29:29 EDT
I use the proprietary nvidia driver from rpmfusion.  Suspend/Resume worked perfectly with Fedora 10.  After upgrading to Fedora 11, my Dell XPS Gen 2 notebook no longer resumes from suspend the second time.  The first suspend/resume cycle after boot works fine.
Comment 30 Josh Moline 2009-06-24 15:35:18 EDT
I forgot to mention that, since I use the proprietary driver (which I confirmed in my xorg log), the information at https://fedoraproject.org/wiki/Common_F11_bugs#Resume_from_suspend_fails_with_NVIDIA_graphics_adapters is misleading.
Comment 31 Cristian Ciupitu 2009-06-24 16:07:55 EDT
@Josh Moline: this bug is about the nouveau driver, not the proprietary driver. The drivers are not related. You should report your issue on the rpmfusion bug tracker https://bugzilla.rpmfusion.org.
Speaking of the proprietary driver, both suspend and hibernate work fine with it on my Gigabyte NVidia 7600GS video card (+Intel DP965DP MB).
Comment 32 Josh Moline 2009-06-24 21:02:54 EDT
@Cristian: Thanks.  I was aware of that.  I do appreciate your positive, helpful response.
I felt that the issue may be kernel related and not driver related.  I will follow up with rpmfusion.org.  Thanks.
I got an oops report when I rebooted.  It is resume related, and I found it interesting.
http://www.kerneloops.org/submitresult.php?number=483682
Comment 33 Adam Williamson 2009-06-25 13:08:12 EDT
josh: this report is definitely known to be of an issue in the open source driver itself, not a kernel issue; the issue is well known by the maintainer. So it's definitely not a kernel issue which is shared with the nvidia driver, you're definitely suffering from something different.
Comment 34 Josh Moline 2009-06-25 21:58:23 EDT
Adam: Understood.  Thanks for the reply.  I'm pursuing my issue at rpmfusion.org
Comment 35 Adam Williamson 2009-07-20 20:49:47 EDT
*** Bug 510126 has been marked as a duplicate of this bug. ***
Comment 36 Ben Skeggs 2009-08-23 21:21:57 EDT
Just an update, this is expected to work in rawhide.  It's currently known to work fine on a good number of G80 and higher series chips, but has a couple of unresolved issues on earlier chips (it may or may not work) that are being worked on.  This will not be backported to F11, the changes are rather invasive.
Comment 37 Gideon Mayhak 2009-08-26 21:37:01 EDT
For me, the situation seems to have worsened in current rawhide.  I used to be able to suspend, but my laptop would resume with the screen off.  Now, the system locks up when I try to suspend (the display switches to Plymouth, and that's it).  So basically, no less functionality than before, but perhaps a step backward.  But like you said, "a couple of unresolved issues on earlier chips," and mine's a bit older!  I'll watch the changelogs and try again when there's another update.
Comment 38 Gideon Mayhak 2009-09-26 17:47:30 EDT
Ben: you da man.  Suspend and resume are now working great on my laptop as of today's updates in rawhide.  I was able to suspend and resume 3 times without issue (make that 4 times; I just did it again while typing this)!  I'll let others chime in, but I'm going to take myself off of this bug.
Comment 39 Ben Skeggs 2009-09-27 04:20:23 EDT
OK.  The general issues with suspend/resume in nouveau are now fixed in rawhide.  I'm going to close this bug as CANTFIX for F11.

Anyone who's having issues with suspend/resume using the latest rawhide/F12 packages, please open new *separate* bugs for each issue, they're likely all chipset-specific issues from this point on.

Note You need to log in before you can comment on or make changes to this bug.