Bug 494259 - anaconda RPM db error
anaconda RPM db error
Status: CLOSED DUPLICATE of bug 471717
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:4dad3b60e71aed365...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-05 23:49 EDT by Tom Gutwin
Modified: 2010-06-04 08:28 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-06 10:15:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (152.97 KB, text/plain)
2009-04-05 23:49 EDT, Tom Gutwin
no flags Details
Attached traceback automatically from anaconda. (232.57 KB, text/plain)
2009-06-04 06:01 EDT, Ramakrishna Reddy
no flags Details
Attached traceback automatically from anaconda. (279.71 KB, text/plain)
2009-06-12 06:01 EDT, Derek Cramer
no flags Details
Attached traceback automatically from anaconda. (248.12 KB, text/plain)
2009-06-20 14:50 EDT, Robert Case (Arlyle Consulting)
no flags Details
Attached traceback automatically from anaconda. (256.68 KB, text/plain)
2009-06-23 05:12 EDT, Michal Novotny
no flags Details
Attached traceback automatically from anaconda. (165.67 KB, text/plain)
2009-07-04 20:34 EDT, Lacrocivious Acrophosist
no flags Details
Attached traceback automatically from anaconda. (152.64 KB, text/plain)
2009-07-10 16:31 EDT, Sascha Zorn
no flags Details
Attached traceback automatically from anaconda. (152.20 KB, text/plain)
2009-07-29 03:10 EDT, Martin Stransky
no flags Details
Attached traceback automatically from anaconda. (827.85 KB, text/plain)
2009-09-21 10:53 EDT, Edward
no flags Details
Attached traceback automatically from anaconda. (208.87 KB, text/plain)
2009-09-26 15:50 EDT, ken
no flags Details
Attached traceback automatically from anaconda. (209.96 KB, text/plain)
2009-09-26 16:02 EDT, ken
no flags Details
Attached traceback automatically from anaconda. (169.71 KB, text/plain)
2009-10-11 02:25 EDT, Pascal Montaigne
no flags Details
Attached traceback automatically from anaconda. (109.47 KB, text/plain)
2009-10-20 01:04 EDT, Jon Jahren
no flags Details
Attached traceback automatically from anaconda. (121.83 KB, text/plain)
2010-06-04 08:28 EDT, sem
no flags Details

  None (edit)
Description Tom Gutwin 2009-04-05 23:49:20 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.38 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/yum/config.py", line 864, in _getsysver
    idx = ts.dbMatch('provides', distroverpkg)
  File "/usr/lib/python2.6/site-packages/yum/config.py", line 794, in readMainConfig
    yumvars['releasever'] = _getsysver(startupconf.installroot, startupconf.distroverpkg)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 239, in _getConfig
    self._conf = config.readMainConfig(startupconf)
  File "/usr/lib/anaconda/yuminstall.py", line 588, in doConfigSetup
    YumSorter._getConfig(self)
  File "/usr/lib/anaconda/yuminstall.py", line 300, in __init__
    self.doConfigSetup(root=anaconda.rootPath)
  File "/usr/lib/anaconda/yuminstall.py", line 1012, in doBackendSetup
    self.ayum = AnacondaYum(anaconda)
  File "/usr/lib/anaconda/backend.py", line 270, in doBackendSetup
    if anaconda.backend.doBackendSetup(anaconda) == DISPATCH_BACK:
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
TypeError: rpmdb open failed
Comment 1 Tom Gutwin 2009-04-05 23:49:27 EDT
Created attachment 338282 [details]
Attached traceback automatically from anaconda.
Comment 2 Tom Gutwin 2009-04-06 00:31:00 EDT
I was installing the Beta F11.
I had just clicked next on the boot loader screen.

What is strange is that I had gotten past this point in a previous attempt to install but had to reinstall because the bootloader did not install properly.

I was trying to narrow down the cause of that.
Comment 3 Chris Lumens 2009-04-06 10:15:54 EDT

*** This bug has been marked as a duplicate of bug 471717 ***
Comment 4 Ramakrishna Reddy 2009-06-04 06:01:40 EDT
Created attachment 346511 [details]
Attached traceback automatically from anaconda.
Comment 5 Derek Cramer 2009-06-12 06:01:00 EDT
Created attachment 347529 [details]
Attached traceback automatically from anaconda.
Comment 6 Robert Case (Arlyle Consulting) 2009-06-20 14:50:52 EDT
Created attachment 348756 [details]
Attached traceback automatically from anaconda.
Comment 7 Michal Novotny 2009-06-23 05:12:48 EDT
Created attachment 349068 [details]
Attached traceback automatically from anaconda.
Comment 8 Lacrocivious Acrophosist 2009-07-04 20:34:38 EDT
Created attachment 350519 [details]
Attached traceback automatically from anaconda.
Comment 9 Sascha Zorn 2009-07-10 16:31:14 EDT
Created attachment 351302 [details]
Attached traceback automatically from anaconda.
Comment 10 Martin Stransky 2009-07-29 03:10:44 EDT
Created attachment 355498 [details]
Attached traceback automatically from anaconda.
Comment 11 Edward 2009-09-21 10:53:38 EDT
Created attachment 361956 [details]
Attached traceback automatically from anaconda.
Comment 12 ken 2009-09-26 15:50:59 EDT
Created attachment 362775 [details]
Attached traceback automatically from anaconda.
Comment 13 ken 2009-09-26 16:02:23 EDT
Created attachment 362777 [details]
Attached traceback automatically from anaconda.
Comment 14 Pascal Montaigne 2009-10-11 02:25:49 EDT
Created attachment 364362 [details]
Attached traceback automatically from anaconda.
Comment 15 Jon Jahren 2009-10-20 01:04:51 EDT
Created attachment 365307 [details]
Attached traceback automatically from anaconda.
Comment 16 sem 2010-06-04 08:28:21 EDT
Created attachment 421219 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.