Bug 471717 - rpmdb open failed
rpmdb open failed
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:69fa8b45224ea29b4...
:
: 475812 487983 493334 494259 524236 574049 601023 626260 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-14 22:11 EST by Aravind Seshadri
Modified: 2011-09-20 08:21 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-13 15:22:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (119.84 KB, text/plain)
2008-11-14 22:11 EST, Aravind Seshadri
no flags Details
Attached traceback automatically from anaconda. (64.74 KB, text/plain)
2008-11-25 09:19 EST, Maciek
no flags Details
Attached traceback automatically from anaconda. (69.09 KB, text/plain)
2008-11-26 08:46 EST, Maciek
no flags Details
Attached traceback automatically from anaconda. (142.93 KB, text/plain)
2009-05-23 16:05 EDT, Marc Stammbach
no flags Details

  None (edit)
Description Aravind Seshadri 2008-11-14 22:11:04 EST
This bug was filed automatically by anaconda.
Comment 1 Aravind Seshadri 2008-11-14 22:11:08 EST
Created attachment 323682 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2008-11-17 11:35:40 EST
What kind of installation were you doing?  It sort of looks like an upgrade, but at the same time there's log messages about formatting /boot and swap but not /.  Any extra information you can provide about what you did would be helpful.
Comment 3 Aravind Seshadri 2008-11-17 13:37:33 EST
I had an existing Fedora 9 installation with encrypted partitions (/ /home /boot and swap). I formatted everything except /home and encrypted them as usual. This is how I typically upgrade from one stable release to another. I guess the formatting went on without a problem and as soon as the installation started, the error occurred.

Hope this helps. Let me know if you need any other information.
Comment 4 Maciek 2008-11-25 09:19:48 EST
Created attachment 324617 [details]
Attached traceback automatically from anaconda.
Comment 5 Bug Zapper 2008-11-26 00:25:26 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Maciek 2008-11-26 08:46:49 EST
Created attachment 324714 [details]
Attached traceback automatically from anaconda.
Comment 7 Chris Lumens 2009-04-01 10:19:28 EDT
*** Bug 475812 has been marked as a duplicate of this bug. ***
Comment 8 Chris Lumens 2009-04-01 10:20:48 EDT
*** Bug 493334 has been marked as a duplicate of this bug. ***
Comment 9 Chris Lumens 2009-04-06 10:15:54 EDT
*** Bug 494259 has been marked as a duplicate of this bug. ***
Comment 10 Chris Lumens 2009-04-15 17:12:12 EDT
*** Bug 494295 has been marked as a duplicate of this bug. ***
Comment 11 Chris Lumens 2009-04-28 13:39:31 EDT
To anyone who is able to reproduce this problem - when you hit the exception, can you press ctrl-alt-f2 and paste the output of mount into this bug report?  It's almost like we're trying to read the __db* files from a previously installed system but I don't see how that should be happening here.
Comment 12 Herbert Gasiorowski 2009-05-05 09:22:49 EDT
I is probably not the same issue - but the rpmdb will not open too:
with fedora/test/11-Preview at the end of an automatical kickstart install:

%post
rpm -q glibc >/tmp/x.x 2>&1
%end

the following output appears:

error: cannot open Packages index using db3 - No such file or directory (2)
error: cannot open Packages database in /var/lib/rpm
error: cannot open Packages database in /var/lib/rpm
package glibc is not installed

After reboot there are no problems to connect to the rpm db!
Comment 13 Marc Stammbach 2009-05-23 16:05:45 EDT
Created attachment 345207 [details]
Attached traceback automatically from anaconda.
Comment 14 Chris Lumens 2009-08-13 15:22:25 EDT
Given that we've been unable to ever reproduce this problem and can't get a reliable reproducer from a reporter, I'm going to have to close this as CANTFIX.  If someone can reliably reproduce it AND explain their setup in detail, feel free to reopen this bug.  Thanks.
Comment 15 altgrendel 2009-08-17 10:46:49 EDT
The issue seem to be that you are not re-formating /var and anaconda is having a problem with an rpmdb file that still exists in /var/lib (I think). If you get this error and type ctl-alt-f1, you'll see that anaconda as kicked up an error about this file.

I would think that if you did an F10 install, updated all the F10 rpms, then tried to do an update to F11 without formating /var, you'd get the same error.

I can't duplicate this at this time, but I can tell you that I ran into this error 3 times trying different DVDs in case there was an error on the DVD. Yes, I know about the DVD verification and such. When I told the F11 update to format /var, the problem went away.


Hope this helps.
Comment 16 Chris Lumens 2009-09-18 13:27:54 EDT
*** Bug 524236 has been marked as a duplicate of this bug. ***
Comment 17 Chris Lumens 2009-10-13 09:55:24 EDT
*** Bug 487983 has been marked as a duplicate of this bug. ***
Comment 18 Chris Lumens 2010-03-16 10:19:33 EDT
*** Bug 574049 has been marked as a duplicate of this bug. ***
Comment 19 Chris Lumens 2010-06-07 15:22:36 EDT
*** Bug 601023 has been marked as a duplicate of this bug. ***
Comment 20 robert.l.scott 2010-06-12 17:07:23 EDT
I also get this same error when trying to upgrade/reinstall a F13 installation (same hardware as before).  The only thing unique/different about the hardware in this system is 3 pata drives and 2 sata drives.  installation is going to the first pata drive.

output from alt-f1:

Running anaconda 13.42, the Fedora system installer - please wait.
20:57:27 Starting graphical installation.
rpmdb: Thread/process 424/3079304896 failed. Thread died in Berkley DB library
error: db3 error(-30974) from devenv-failchk: DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages index using db3 - (-30974)
error: cannot open Packages databae in /mnt/sysimage/var/lib/rpm

why is a bug like this "unfixable"?
Comment 21 robert.l.scott 2010-06-12 17:56:03 EDT
I also get this same error when trying to upgrade/reinstall a F13 installation (same hardware as before).  The only thing unique/different about the hardware in this system is 3 pata drives and 2 sata drives.  installation is going to the first pata drive.

output from alt-f1:

Running anaconda 13.42, the Fedora system installer - please wait.
20:57:27 Starting graphical installation.
rpmdb: Thread/process 424/3079304896 failed. Thread died in Berkley DB library
error: db3 error(-30974) from devenv-failchk: DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages index using db3 - (-30974)
error: cannot open Packages databae in /mnt/sysimage/var/lib/rpm

why is a bug like this "unfixable"?
Comment 22 robert.l.scott 2010-06-12 18:20:00 EDT
When i removed the extra drives (LVM storage not part of hte linux installation/upgrade - leaving just 2 pata drives), the installation and upgrade process when through without a problem.  Previously, i had 2 additional sata and 1 additional pata drive active in the system.

hope this helps ...
Comment 23 Chris Lumens 2010-08-24 10:22:29 EDT
*** Bug 626260 has been marked as a duplicate of this bug. ***
Comment 24 Arand Nash 2011-09-20 08:21:21 EDT
I experienced this error repeatedly when trying to install the f16 alpha on a system wth an existing LVM (debian+fedora) where I tried replacing the fedora instance.

With the installer from f16 Beta RC1 this now seems to work fine.

Note You need to log in before you can comment on or make changes to this bug.