Bug 494433 - Dependency Resolution Failure - Wrong Kernel Version
Dependency Resolution Failure - Wrong Kernel Version
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 494564 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-06 16:39 EDT by Kirk Ziegler
Modified: 2014-01-21 18:08 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-06 20:01:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kirk Ziegler 2009-04-06 16:39:32 EDT
Description of problem:  Won't update, needs kernel 2.6.29.1-52.fc11


Version-Release number of selected component (if applicable): 2.6.29.1-46.fc11.i586


How reproducible: System > Administration > Update System


Steps to Reproduce:
1.
2.
3.
  
Actual results: Won't update


Expected results: Install updates


Additional info:  kernel >= 2.6.29.1-52.fc11 is needed by package libdrm-2.4.5-4.fc11.i586 (rawhide)
kernel >= 2.6.29.1-52.fc11 is needed by package xorg-x11-drv-ati-6.12.1-5.fc11.i586 (rawhide) : Success - empty transaction
Comment 1 Chris Lumens 2009-04-06 16:52:44 EDT
Not sure what this has to do with anaconda-yum-plugins.  That package just provides two plugins to process some extra metadata out of the repos.  This really just looks like a packaging problem to me, or perhaps your repos are not configured correctly.  The yum guys are really good at figuring out where to assign these sorts of bugs, so I'll assign it to them for now.
Comment 2 seth vidal 2009-04-06 17:01:54 EDT
We're going to need a lot more information on what happens and under what situations it occurs..

Please at least include the complete output when you experience this error.
Comment 3 Alwin Laureijs 2009-04-06 18:36:27 EDT
The only repos enabled are fedora and fedora-updates:

[root@fedora11 yum.repos.d]# yum update -v
Not loading "blacklist" plugin, as it is disabled
Loading "fastestmirror" plugin
Loading "refresh-packagekit" plugin
Not loading "whiteout" plugin, as it is disabled
Config time: 0.154
Yum Version: 3.2.22
Setting up Package Sacks
Loading mirror speeds from cached hostfile
 * fedora: mirrors.nl.eu.kernel.org
 * updates: mirrors.nl.eu.kernel.org
pkgsack time: 0.053
rpmdb time: 0.000
Setting up Update Process
Updating Everything
Building updates object
up:Obs Init time: 0.267
up:simple updates time: 0.404
up:obs time: 0.006
up:condense time: 0.000
updates time: 4.165
Resolving Dependencies
--> Running transaction check
Checking deps for libdrm.i586 0-2.4.5-0.fc11 - None
---> Package libdrm.i586 0:2.4.5-4.fc11 set to be updated
Checking deps for libdrm.i586 0-2.4.5-4.fc11 - u
looking for (u'kernel', u'GE', (u'0', u'2.6.29.1', u'52.fc11')) as a requirement of libdrm.i586 0-2.4.5-4.fc11 - u
libdrm-2.4.5-4.fc11.i586 requires: kernel >= 2.6.29.1-52.fc11
--> Processing Dependency: kernel >= 2.6.29.1-52.fc11 for package: libdrm
Searching pkgSack for dep: kernel
Potential match for kernel from kernel-2.6.29.1-46.fc11.i586
Potential match for kernel from kernel-PAEdebug-2.6.29.1-46.fc11.i686
Potential match for kernel from kernel-PAE-2.6.29.1-46.fc11.i686
Potential match for kernel from kernel-2.6.29.1-46.fc11.i586
Potential match for kernel from kernel-PAEdebug-2.6.29.1-46.fc11.i686
Potential match for kernel from kernel-PAE-2.6.29.1-46.fc11.i686
Checking deps for mesa-dri-drivers.i586 0-7.3-12.fc11 - None
---> Package mesa-dri-drivers.i586 0:7.5-0.6.fc11 set to be updated
Checking deps for mesa-dri-drivers.i586 0-7.5-0.6.fc11 - u
looking for (u'libc.so.6(GLIBC_2.1)', None, (None, None, None)) as a requirement of mesa-dri-drivers.i586 0-7.5-0.6.fc11 - u
Checking deps for mesa-libGL.i586 0-7.3-12.fc11 - None
---> Package mesa-libGL.i586 0:7.5-0.6.fc11 set to be updated
Checking deps for mesa-libGL.i586 0-7.5-0.6.fc11 - u
looking for (u'mesa-dri-drivers(x86-32)', u'EQ', (u'0', u'7.5', u'0.6.fc11')) as a requirement of mesa-libGL.i586 0-7.5-0.6.fc11 - u
looking for (u'libdrm', u'GE', (u'0', u'2.4.5', u'1')) as a requirement of mesa-libGL.i586 0-7.5-0.6.fc11 - u
---> Package xorg-x11-drv-ati.i586 0:6.12.1-5.fc11 set to be updated
Checking deps for xorg-x11-drv-ati.i586 0-6.12.1-5.fc11 - u
looking for (u'kernel', u'GE', (u'0', u'2.6.29.1', u'52.fc11')) as a requirement of xorg-x11-drv-ati.i586 0-6.12.1-5.fc11 - u
xorg-x11-drv-ati-6.12.1-5.fc11.i586 requires: kernel >= 2.6.29.1-52.fc11
--> Processing Dependency: kernel >= 2.6.29.1-52.fc11 for package: xorg-x11-drv-ati
Searching pkgSack for dep: kernel
Potential match for kernel from kernel-2.6.29.1-46.fc11.i586
Potential match for kernel from kernel-PAEdebug-2.6.29.1-46.fc11.i686
Potential match for kernel from kernel-PAE-2.6.29.1-46.fc11.i686
Potential match for kernel from kernel-2.6.29.1-46.fc11.i586
Potential match for kernel from kernel-PAEdebug-2.6.29.1-46.fc11.i686
Potential match for kernel from kernel-PAE-2.6.29.1-46.fc11.i686
Checking deps for xorg-x11-drv-ati.i586 0-6.11.0-10.fc11 - None
--> Finished Dependency Resolution
Dependency Process ending
libdrm-2.4.5-4.fc11.i586 from fedora has depsolving problems
  --> Missing Dependency: kernel >= 2.6.29.1-52.fc11 is needed by package libdrm-2.4.5-4.fc11.i586 (fedora)
xorg-x11-drv-ati-6.12.1-5.fc11.i586 from fedora has depsolving problems
  --> Missing Dependency: kernel >= 2.6.29.1-52.fc11 is needed by package xorg-x11-drv-ati-6.12.1-5.fc11.i586 (fedora)
Depsolve time: 2.724
Error: Missing Dependency: kernel >= 2.6.29.1-52.fc11 is needed by package libdrm-2.4.5-4.fc11.i586 (fedora)
Error: Missing Dependency: kernel >= 2.6.29.1-52.fc11 is needed by package xorg-x11-drv-ati-6.12.1-5.fc11.i586 (fedora)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
[root@fedora11 yum.repos.d]#
Comment 4 Kirk Ziegler 2009-04-06 18:48:45 EDT
Here's the info from System > Administration > Update System:

kernel >= 2.6.29.1-52.fc11 is needed by package libdrm-2.4.5-4.fc11.i586
(rawhide)
kernel >= 2.6.29.1-52.fc11 is needed by package
xorg-x11-drv-ati-6.12.1-5.fc11.i586 (rawhide) : Success - empty
transaction

This is from the command line:

[root@localhost Kirk]# yum upgrade
Loaded plugins: dellsysidplugin2, refresh-packagekit
Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
---> Package libdrm.i586 0:2.4.5-4.fc11 set to be updated
--> Processing Dependency: kernel >= 2.6.29.1-52.fc11 for package:
libdrm
---> Package xorg-x11-drv-ati.i586 0:6.12.1-5.fc11 set to be updated
--> Processing Dependency: kernel >= 2.6.29.1-52.fc11 for package:
xorg-x11-drv-ati
--> Finished Dependency Resolution
libdrm-2.4.5-4.fc11.i586 from rawhide has depsolving problems
  --> Missing Dependency: kernel >= 2.6.29.1-52.fc11 is needed by
package libdrm-2.4.5-4.fc11.i586 (rawhide)
xorg-x11-drv-ati-6.12.1-5.fc11.i586 from rawhide has depsolving problems
  --> Missing Dependency: kernel >= 2.6.29.1-52.fc11 is needed by
package xorg-x11-drv-ati-6.12.1-5.fc11.i586 (rawhide)
Error: Missing Dependency: kernel >= 2.6.29.1-52.fc11 is needed by
package libdrm-2.4.5-4.fc11.i586 (rawhide)
Error: Missing Dependency: kernel >= 2.6.29.1-52.fc11 is needed by
package xorg-x11-drv-ati-6.12.1-5.fc11.i586 (rawhide)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
Comment 5 James Antill 2009-04-06 20:01:51 EDT
So it's kind of a packaging problem, in that Requires/Conflicts don't work well on the kernel package because it's "special". However given it's rawhide I'm not sure they'll want to fix it, just update your kernel, reboot and then remove the older kernels.

You can open new bugs against xorg-x11-drv-ati and libdrm that they should "work" with older kernels, but again they might disagree.
Comment 6 James Antill 2009-04-07 09:46:54 EDT
*** Bug 494564 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.