Bug 494596 - Kernel hangs / crashes on HP 2140 Netbook (Intel Atom)
Kernel hangs / crashes on HP 2140 Netbook (Intel Atom)
Status: CLOSED DUPLICATE of bug 499803
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
i686 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-07 11:33 EDT by Maxwell Spangler
Modified: 2009-05-20 21:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-20 21:09:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maxwell Spangler 2009-04-07 11:33:00 EDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.8) Gecko/2009032713 Fedora/3.0.8-1.fc10 Firefox/3.0.8

Attempts to boot Fedora 10 on an HP 2140 model business class netbook produce kernel hangs and occasional kernel crashes at boot time.

I believe this is a timing issue because adding the kernel parameter 'boot_delay=5' appears to resolve this.

Also, given 10 attempts to cold start the system without this parameter, 1 attempt or less will be a successful boot, 1 attempt will produce a kernel crash with the tail end of the crash output visible on the screen and 8 attempts will leave the kernel hung with the last line of output:

Freeing unused kernel memory: XXX free

The same results occur with the default Fedora 10 install kernel and at least two other kernels provided in March/April 2009 fedora updates.  No change between kernels.

I'm reporting this via bugzilla because this hardware platform (Intel Atom cpu, Intel 950GSE chipset) seems similar enough to other netbooks that an investigation might benefit more than just HP 2140 owners.

Reproducible: Always

Steps to Reproduce:
1.Boot HP 2140 netbook with fedora 10 installed 
2.At grub prompt, remove 'quiet' so kernel output is displayed.
3.
Actual Results:  
System will hang 80% or more of the time at exactly the same point.   Occasional kernel crash and occasional clean boot through to a normal, functional operating Fedora 10 environment.

Expected Results:  
Consistent clean boots without crashes or hangs

Boot parameter 'boot_delay=5' appears to slow something down and resolve this issue.
Comment 1 Chuck Ebbert 2009-04-08 17:28:35 EDT
This should be fixed in the 2.6.29 kernel but the fix somehow didn't get backported to 2.6.27...
Comment 2 Chuck Ebbert 2009-04-15 16:18:58 EDT
2.6.29.1-30 is available in the updates-testing repository.
Comment 3 Chuck Ebbert 2009-05-09 19:07:13 EDT
This is a processor bug and should be fixed by a BIOS update.
Comment 4 Chuck Ebbert 2009-05-20 21:09:30 EDT

*** This bug has been marked as a duplicate of bug 499803 ***

Note You need to log in before you can comment on or make changes to this bug.