Bug 49466 - trying "migrate partition to ext3" makes the box vanish
Summary: trying "migrate partition to ext3" makes the box vanish
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 52512 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-19 19:29 UTC by Inger Karin Haarbye
Modified: 2007-04-18 16:34 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-24 18:34:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Inger Karin Haarbye 2001-07-19 19:29:40 UTC
Fairfax beta2:
Installation using disk-druid, trying to check the "migrate partition to 
ext3" in the "edit"-box - makes it vanish without the possibility to 
press "OK".
The migration to ext3 still seems to work OK if mountpoint is set.

Comment 1 Glen Foster 2001-07-19 21:18:58 UTC
This defect considered MUST-FIX for Fairfax.

Comment 2 Michael Fulbright 2001-07-20 00:15:17 UTC
Fixed.

Comment 3 Inger Karin Haarbye 2001-08-19 11:38:10 UTC
This bug was fixed in beta3, but is back in rc1.
In beta3 and rc1 the conversion from ext2 -> ext3 doesn't work, but the updates
(to ext3) is written to /etc/fstab. Result: the (not) converted disks is not
mounted because of wrong fs-type.

Comment 4 Matt Wilson 2001-08-21 14:41:58 UTC
exactly how did you reproduce this on rc1?


Comment 5 Inger Karin Haarbye 2001-08-21 15:12:05 UTC
custom install -> disk-druid -> format the root partition to ext3
 - then I want to migrate my other partitions from ext2 to ext3. When I check 
the "migrate partition to ext3" in the "edit"-box - it vanish without the 
possibility to press "OK".

With beta2 the migration from ext2 to ext3 was working, but not in rc1.

When starting my new system the root-partition is mounted ok, but none of my 
data-partitions.

From /var/log/messages:
Aug 19 13:28:55 opuntia kernel: EXT3 FS 2.4-0.9.6, 11 Aug 2001 on ide0(3,3), 
internal journal
Aug 19 13:28:55 opuntia kernel: ext3: No journal on filesystem on ide0(3,9)
Aug 19 13:28:55 opuntia kernel: kjournald starting.  Commit interval 5 seconds
Aug 19 13:28:55 opuntia kernel: EXT3 FS 2.4-0.9.6, 11 Aug 2001 on ide0(3,12), 
internal journal
Aug 19 13:28:55 opuntia kernel: EXT3-fs: mounted filesystem with ordered data 
mode.
Aug 19 13:28:55 opuntia kernel: ext3: No journal on filesystem on ide0(3,65)

and:
Aug 19 13:28:55 opuntia kernel: ext3: No journal on filesystem on ide0(3,9)
aug 19 13:28:55 opuntia mount: mount: wrong fs type, bad option, bad 
superblock on /dev/hda9,
aug 19 13:28:55 opuntia mount:        or too many mounted file systems
Aug 19 13:28:55 opuntia kernel: ext3: No journal on filesystem on ide0(3,65)
aug 19 13:28:55 opuntia mount: mount: wrong fs type, bad option, bad 
superblock on /dev/hdb1,
aug 19 13:28:55 opuntia mount:        or too many mounted file systems

Same happens to the other 3 partitions I tried to migrate.
If I edit /etc/fstab and use ext2 instead of ext3 on this partitions, 
roswell(2) will be able to mount them.



Comment 6 Matt Wilson 2001-08-24 18:34:16 UTC
*** Bug 52512 has been marked as a duplicate of this bug. ***

Comment 7 Jeremy Katz 2001-08-24 21:43:14 UTC
Fixed in CVS (both parts)


Note You need to log in before you can comment on or make changes to this bug.