This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 494729 - Loud clicks from speakers (snd_hda_intel)
Loud clicks from speakers (snd_hda_intel)
Status: CLOSED DUPLICATE of bug 493972
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-07 18:09 EDT by Hezekiah M. Carty
Modified: 2009-04-08 15:35 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 450395
Environment:
Last Closed: 2009-04-08 00:27:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hezekiah M. Carty 2009-04-07 18:09:32 EDT
+++ This bug was initially created as a clone of Bug #450395 +++

Using Fedora 11/rawhide with all updates as of today I have the same problem as the cloned bug (listed below with a few updates).

Description of problem:
I'm hearing really loud clicks on speakers when event some sound starts. If it
is a short sound I just hear the click and not the sound. For example when
clicking in gnome applications menu to start some application.
If I start some video file I first hear that loud click and then audio starts to
play.

I also hear a click 2-3 seconds after the last sound is player.

So I hear these clicks when audio is "starting up" and when it is "shutting down"
it that is what I can call it.

Version-Release number of selected component (if applicable):
Latest Fedora 11/rawhide with all updates as of today
kernel-2.6.29.1-52.fc11.x86_64

audio card is (from lspci):
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)

module that is used: snd_hda_intel

laptop is: Thinkpad R61

How reproducible:
every time.

Steps to Reproduce:
1. Play audio
  
Actual results:
"Pop" before audio starts and a few seconds after the audio finishes

Expected results:
No popping sound

Additional info:

I have left all of the cloned bugs comments below in case they are useful in diagnosing/fixing this.

--- Additional comment from naveed@cs.columbia.edu on 2008-06-10 01:07:02 EDT ---

I am still using Fedora 8 and just upgraded from kernel-2.6.24.3-50 to
kernel-2.6.25.4-10 and now have really horrible sound problems which are most
likely pulseaudio / GROUP_SCHED related.

Nothing else on my system was upgraded except the kernel and now the audio
clicks on any new sound that is played after even the shortest silence. It also
skips and pops during any type of media playback. My system is also using the
snd_intel_8x0 module for audio and pulseaudio-0.9.8-5 has been installed all along.

Do you have any audio quality issues when playing music and movies in various
applications? I haven't been able to find one good working combination so far.


--- Additional comment from naveed@cs.columbia.edu on 2008-06-10 01:07:27 EDT ---

https://bugzilla.redhat.com/show_bug.cgi?id=446192 is probably related.


--- Additional comment from valent.turkovic@gmail.com on 2008-06-12 04:36:27 EDT ---

Lennart is there some log that we can give you that would help track down this
issue?

--- Additional comment from valent.turkovic@gmail.com on 2008-06-12 04:38:20 EDT ---

@Naveed I'm not hearing any skipping once audio starts. It just click when sound
card starts to play and 2 seconds after it stops playing.

--- Additional comment from naveed@cs.columbia.edu on 2008-06-13 01:59:18 EDT ---

(In reply to comment #1)
> Do you have any audio quality issues when playing music and movies in various
> applications? I haven't been able to find one good working combination so far.

I have since upgraded to Fedora 9 and now have no skipping in the audio streams
I play, but now some apps have audio speed issues where the audio stream is
running too fast (by about 7% based on some testing.) swfdec is an example of
where this is happening - every youtube.com video I watch there has the A/V out
of sync.

The loud and annoying clicks are still present.


--- Additional comment from valent.turkovic@gmail.com on 2008-06-14 02:37:28 EDT ---

After the latest kernel and other updates I still hear the same bug...

--- Additional comment from naveed@cs.columbia.edu on 2008-06-16 13:47:31 EDT ---

With kernel-2.6.25.6-55.fc9 and everything else up to date, the noise on new
sounds after a silence period remain. One other thing I've noticed in many
different media players is that if I change the volume (within the media player)
while a stream is running, the sound cuts out completely. It only returns if I
pause and resume the stream.


--- Additional comment from lpoetter@redhat.com on 2008-06-17 13:37:25 EDT ---

PA closes the audio device 2s after becoming idle. I think you sound driver just
produces those popping noises everytime the audio device is opened/closed.
According to Takashi this shouldn't happen anymore these days.

I am now reassigning this to the kernel, since according to Takashi this can be
worked around in the kernel.

--- Additional comment from valent.turkovic@gmail.com on 2008-06-18 05:15:13 EDT ---

Takashi if you need some feedback and/or some logs just tell me and I'll provide
you all the info.

--- Additional comment from valent.turkovic@gmail.com on 2008-06-20 18:45:02 EDT ---

I have the latest kernel 2.6.25.6-55.fc9.i686 and I still hear clicks.

--- Additional comment from naveed@cs.columbia.edu on 2008-07-02 16:54:25 EDT ---

kernel-2.6.25.9-76.fc9.x86_64 continues to exhibit the reported bug.


--- Additional comment from theholyettlz@googlemail.com on 2008-07-10 04:29:56 EDT ---

I've been seeing this for a long time on an Intel 8x0-based notebook. I get the
click whenever the driver loads (i.e., at the udev stage during boot), or the
device is opened/closed (including at shutdown), or I pull mains power and the
8x0 power saving mode starts. [I've also noticed it at boot on an ATI IXP-based
notebook, but that's likely unrelated.] I think the card seems to assume more of
a DC bias under Linux as well.

--- Additional comment from adam@spicenitz.org on 2008-07-11 09:55:11 EDT ---

This happens on a Dell laptop I have, but not IBM Thinkpad. It is definitely the
sound of some internal chip powering up after having gone idle. The power
wasting solution would be to just power the chip at all times, but there must be
a better way to avoid the click.

--- Additional comment from theholyettlz@googlemail.com on 2008-07-11 15:08:41 EDT ---

Hmm... what *codec* chip do you all have? Mine is a Realtek, don't know exactly
which one at the moment...

--- Additional comment from valent.turkovic@gmail.com on 2008-07-14 03:44:06 EDT ---

here are some interesting links:
http://blogs.gnome.org/hughsie/2008/03/28/clicking-of-snd_hda_intel/

http://thread.gmane.org/gmane.linux.redhat.fedora.devel/88396

--- Additional comment from naveed@cs.columbia.edu on 2008-07-22 04:49:10 EDT ---

kernel-2.6.25.10-86.fc9 continues to exhibit the reported bug.


--- Additional comment from naveed@cs.columbia.edu on 2008-07-22 13:39:06 EDT ---

Adding

options snd-ac97-codec power_save=0

to /etc/modprobe.conf makes this problem go away on my desktop system. Clearly,
this is a suboptimal solution but since my machine does not run on a battery,
it's not that bad. I still don't understand what changed between Fedora 8 and 9
to cause this aggressive powersaving related clicking to start.


--- Additional comment from cebbert@redhat.com on 2008-07-25 19:22:58 EDT ---

Default set to 0 in 2.6.25.12-63.fc8  and  2.6.25.12-101.fc9

--- Additional comment from updates@fedoraproject.org on 2008-08-04 09:43:43 EDT ---

kernel-2.6.25.14-107.fc9 has been submitted as an update for Fedora 9

--- Additional comment from updates@fedoraproject.org on 2008-08-06 08:17:57 EDT ---

kernel-2.6.25.14-108.fc9 has been submitted as an update for Fedora 9

--- Additional comment from updates@fedoraproject.org on 2008-08-07 19:52:48 EDT ---

kernel-2.6.25.14-108.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7043

--- Additional comment from valent.turkovic@gmail.com on 2008-08-09 10:27:31 EDT ---

it works for me. I installed testing kernel 2.6.25.14-108.fc9.i686 and removed modprobe.conf option that fixed it before this kernel.

I hear no clicks.

Thank you very much!

--- Additional comment from updates@fedoraproject.org on 2008-08-12 14:19:49 EDT ---

kernel-2.6.25.14-108.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 1 Chuck Ebbert 2009-04-08 00:27:28 EDT

*** This bug has been marked as a duplicate of bug 493972 ***

Note You need to log in before you can comment on or make changes to this bug.