Bug 493972 - Pops with powersave on in snd_hda_intel with some hardware
Pops with powersave on in snd_hda_intel with some hardware
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 494729 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-03 10:53 EDT by Eric Sandeen
Modified: 2009-04-17 10:55 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-13 14:50:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
alsa-info.txt (31.72 KB, text/plain)
2009-04-04 23:55 EDT, Mace Moneta
no flags Details
alsa-info.txt from alsa-info.sh (Thinkpad R61) (23.45 KB, text/plain)
2009-04-07 18:25 EDT, Hezekiah M. Carty
no flags Details

  None (edit)
Description Eric Sandeen 2009-04-03 10:53:51 EDT
Bug 433495 has some information about the power_save feature of this driver causing pops when the device comes out of powersave mode.  Powersave was originally disabled for this reason, but after reports that it had been fixed, it was re-enabled in the rawhide kernels.  However, reports have resurfaced.

It appears that maybe only some hardware has this problem, so I'm reluctant to throw out all power saving for an odd piece of hardware or two.

If you're experiencing this problem on this driver, -and- if you're not, it'd be great if you could attach the relevant device info (from alsa-info.sh, and/or lspsi) to the bug and let us know which hardware is affected.  It may be possible to disable powersave for just the problematic hardware.

If you are experiencing pops now, please test with the power_save=0 option to the module, and see if the problem goes away.

Thanks,
-Eric
Comment 1 Kevin DeKorte 2009-04-03 11:15:09 EDT
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
	Subsystem: ASUSTeK Computer Inc. Device 829f
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 32 bytes
	Interrupt: pin A routed to IRQ 22
	Region 0: Memory at fe8f8000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: HDA Intel
	Kernel modules: snd-hda-intel


Has the pops with power_save != 0
Comment 2 Allen Kistler 2009-04-03 15:02:14 EDT
I have a slightly different problem with the same solution.  I've got an HP Elitebook 6930p, which has the ICH9 chipset.  The audio doesn't pop.  It doesn't do anything because it's always power-saving.  The panel has a combo IR-switch/status-LED for mute/power-saving of the audio device.

I enable Gnome sounds.  On power-up, the mute LED says sound isn't muted.  When I log in, the LED changes to say it *is* muted, and I hear nothing.  If I'm fast enough, I can unmute and hear the end of the login sound.  For a few seconds, sound works.  Then it mutes again automatically.  (Lather, rinse, repeat for any other audio, too.)  The LED usually changes status the next time a sound *would* play (if audio wasn't muted/power-saving).

If I feed the module the power_save=0 option, the problem does not occur.  Or rather, it occurs only once a few seconds after the first login (after the first sound?), then never again.

kernel-2.6.29.1-46.fc11.i686.PAE

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio
         Controller (rev 03)
        Subsystem: Hewlett-Packard Company Device 30dc
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
         ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort-
         <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 17
        Region 0: Memory at d0420000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA
                         PME(D0+,D1-,D2-,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [60] MSI: Mask- 64bit+ Count=1/1 Enable-
                Address: 0000000000000000  Data: 0000
        Capabilities: [70] Express (v1) Root Complex Integrated Endpoint, MSI 00
                DevCap:	MaxPayload 128 bytes, PhantFunc 0, Latency L0s <64ns,
                         L1 <1us
                        ExtTag- RBE- FLReset+
                DevCtl:	Report errors: Correctable- Non-Fatal- Fatal-
                         Unsupported-
                        RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop+
                        MaxPayload 128 bytes, MaxReadReq 128 bytes
                DevSta:	CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr+
                         TransPend-
                LnkCap:	Port #0, Speed unknown, Width x0, ASPM unknown,
                         Latency L0 <64ns, L1 <1us
                        ClockPM- Surprise- LLActRep- BwNot-
                LnkCtl:	ASPM Disabled; Disabled- Retrain- CommClk-
                        ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
                LnkSta:	Speed unknown, Width x0, TrErr- Train- SlotClk-
                         DLActive- BWMgmt- ABWMgmt-
        Capabilities: [100] Virtual Channel <?>
        Capabilities: [130] Root Complex Link <?>
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel
Comment 3 Jiri Cerny 2009-04-04 05:58:30 EDT
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
        Subsystem: Lenovo ThinkPad T61
        Flags: bus master, fast devsel, latency 0, IRQ 17
        Memory at fe220000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
        Capabilities: [60] MSI: Mask- 64bit+ Count=1/1 Enable-
        Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
        Capabilities: [100] Virtual Channel <?>
        Capabilities: [130] Root Complex Link <?>
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel

Has the pops with power_save != 0
Comment 4 Mace Moneta 2009-04-04 23:55:11 EDT
Created attachment 338196 [details]
alsa-info.txt

I get the pops.

lspci:

00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller
        Subsystem: Super Micro Computer Inc Device b880
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 32 bytes
        Interrupt: pin A routed to IRQ 22
        Region 0: Memory at fe8f4000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [60] MSI: Mask- 64bit+ Count=1/1 Enable-
                Address: 0000000000000000  Data: 0000
        Capabilities: [70] Express (v1) Root Complex Integrated Endpoint, MSI 00
                DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <64ns, L1 <1us
                        ExtTag- RBE- FLReset+
                DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
                        RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop+
                        MaxPayload 128 bytes, MaxReadReq 128 bytes
                DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr+ TransPend-
                LnkCap: Port #0, Speed unknown, Width x0, ASPM unknown, Latency L0 <64ns, L1 <1us
                        ClockPM- Surprise- LLActRep- BwNot-
                LnkCtl: ASPM Disabled; Disabled- Retrain- CommClk-
                        ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
                LnkSta: Speed unknown, Width x0, TrErr- Train- SlotClk- DLActive- BWMgmt- ABWMgmt-
        Capabilities: [100] Virtual Channel <?>
        Capabilities: [130] Root Complex Link <?>
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel
Comment 5 Hezekiah M. Carty 2009-04-07 18:25:42 EDT
Created attachment 338621 [details]
alsa-info.txt from alsa-info.sh (Thinkpad R61)

I have the pops as well - Thinkpad R61.

lspci:

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller
 (rev 03)
        Subsystem: Lenovo ThinkPad T61
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Step
ping- SERR+ FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- 
<MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin B routed to IRQ 17
        Region 0: Memory at fe020000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0+,D1-,D2-,D3ho
t+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [60] MSI: Mask- 64bit+ Count=1/1 Enable-
                Address: 0000000000000000  Data: 0000
        Capabilities: [70] Express (v1) Root Complex Integrated Endpoint, MSI 00
                DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <64ns, L1
 <1us
                        ExtTag- RBE- FLReset-
                DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupporte
d-
                        RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop+
                        MaxPayload 128 bytes, MaxReadReq 128 bytes
                DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr+ TransPe
nd-
                LnkCap: Port #0, Speed unknown, Width x0, ASPM unknown, Latency 
L0 <64ns, L1 <1us
                        ClockPM- Surprise- LLActRep- BwNot-
                LnkCtl: ASPM Disabled; Disabled- Retrain- CommClk-
                        ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
                LnkSta: Speed unknown, Width x0, TrErr- Train- SlotClk- DLActive
- BWMgmt- ABWMgmt-
        Capabilities: [100] Virtual Channel <?>
        Capabilities: [130] Root Complex Link <?>
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel
Comment 6 Chuck Ebbert 2009-04-08 00:27:28 EDT
*** Bug 494729 has been marked as a duplicate of this bug. ***
Comment 7 MartinG 2009-04-12 18:29:58 EDT
I had pops with snd_hda_intel, but setting power_save=0 solved the problem.
Asus P5E-VM HDMI, Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02). Fedora Rawhide, kernel-2.6.29.1-68.fc11.x86_64.

alsa-info: 
http://www.alsa-project.org/db/?f=ae1da1ccfdbb9b7998e9c303a1eeaadb725de2e8
Comment 8 Eric Sandeen 2009-04-12 20:39:12 EDT
Thanks everyone; looks like nothing but trouble, so we'll probably just disable this by default again before F11 is done.

-Eric
Comment 9 Eric Sandeen 2009-04-13 14:50:36 EDT
Turned this back off again in the F11 branch.
Comment 10 Tomasz Torcz 2009-04-17 10:55:54 EDT
Thinkpad T400,

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
	Subsystem: Lenovo Device 20f2
	Flags: bus master, fast devsel, latency 0, IRQ 17
	Memory at fc020000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: HDA Intel
	Kernel modules: snd-hda-intel

card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]

I have NO pops with powersaving enabled.

Note You need to log in before you can comment on or make changes to this bug.