Bug 494801 - TigerVNC server can not be started because of missing "fixed" font.
TigerVNC server can not be started because of missing "fixed" font.
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: tigervnc (Show other bugs)
rawhide
All Linux
low Severity urgent
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-08 03:33 EDT by Ivo Sarak
Modified: 2013-04-30 19:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-29 08:04:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ivo Sarak 2009-04-08 03:33:16 EDT
Description of problem:
TigerVNC server can not be started because of missing "fixed" font.

Version-Release number of selected component (if applicable):
tigervnc-server-0.0.90-0.3.1.20090403svn3751.fc11.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install F11 alpha;
2. Update it from Rawhide;
3. Install tigervnc-server;
4. Try to start it;
  
Actual results:
[ivo@ragana ~]$ vncserver 

You will require a password to access your desktops.

Password:
Verify:

WARNING: The first attempt to start Xvnc failed, possibly because the vncserver
script was not able to figure out an appropriate X11 font path for this system
or because the font path you specified with the -fp argument was not valid.
Attempting to restart Xvnc using the X Font Server (xfs) ...
Could not start Xvnc.


Xvnc TigerVNC 0.0.90 - built Apr  3 2009 13:15:26
Copyright (C) 2002-2005 RealVNC Ltd.
Copyright (C) 2000-2006 Constantin Kaplinsky
Copyright (C) 2004-2009 Peter Astrand for Cendio AB
See http://www.tigervnc.org for information on TigerVNC.
Underlying X server release 10600000, 


Wed Apr  8 10:22:52 2009
 vncext:      VNC extension running!
 vncext:      Listening for VNC connections on port 5901
 vncext:      created VNC server for screen 0

Fatal server error:
could not open default font 'fixed'

Xvnc TigerVNC 0.0.90 - built Apr  3 2009 13:15:26
Copyright (C) 2002-2005 RealVNC Ltd.
Copyright (C) 2000-2006 Constantin Kaplinsky
Copyright (C) 2004-2009 Peter Astrand for Cendio AB
See http://www.tigervnc.org for information on TigerVNC.
Underlying X server release 10600000, 


Wed Apr  8 10:22:55 2009
 vncext:      VNC extension running!
 vncext:      Listening for VNC connections on port 5901
 vncext:      created VNC server for screen 0
[dix] Could not init font path element unix/:7100, removing from list!

Fatal server error:
could not open default font 'fixed'

[ivo@ragana ~]$ 


Expected results:
All needed fonts being found and VNC server happily running.

Additional info:
I tried to find a config file where that font is being set, but I failed.
Comment 1 Adam Tkac 2009-04-08 10:18:31 EDT
Fixed in 0.0.90-0.5.20090403svn3751. Thanks for report
Comment 2 Paul W. Frields 2009-04-29 08:03:05 EDT
Problem is now recurring for me in 0.0.90-0.6.20090427svn3789.
Comment 3 Paul W. Frields 2009-04-29 08:04:51 EDT
Aha, Adam reports it's due to missing Requires. See bug 498184 for details; closing this bug again, sorry for noise.

Note You need to log in before you can comment on or make changes to this bug.