Bug 494807 - F11-beta Anaconda crashes when trying to create LVM partition or replace existing installation.
F11-beta Anaconda crashes when trying to create LVM partition or replace exis...
Status: CLOSED DUPLICATE of bug 491348
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-08 03:48 EDT by Steven Bakker
Modified: 2009-04-08 10:19 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-08 10:19:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
F11-beta Anaconda crash report (107.89 KB, text/plain)
2009-04-08 03:48 EDT, Steven Bakker
no flags Details

  None (edit)
Description Steven Bakker 2009-04-08 03:48:07 EDT
Created attachment 338661 [details]
F11-beta Anaconda crash report

Description of problem:

Hardware: Dell Latitude E6500

When trying to create a custom layout (in order to keep my system dual-boot), I managed to create an ext3 "/boot" in the extended partition, but when I then attempted to use the rest of the free space for an LVM PV, anaconda reported an exception. This happened twice; the second time I managed to save the exception report.

Perhaps related (or not), after installing F10 on the laptop, I then attempted an install/upgrade using F11-beta again. I selected, "replace existing Linux system" and, once again, anaconda crashed. I don't have the crash report of that one, but it should be easy enough to reproduce.

It almost looks as if anaconda doesn't like LVM. *Sigh* just when I was getting used to the idea of LVM... :-(

Version-Release number of selected component (if applicable):

11.5.0.38 (from F11-beta x86_64 DVD)

How reproducible:

Always.

Steps to Reproduce:
1. Boot system with F11-beta DVD
2. Select Install/Upgrade
3. At the disk partitioning step, select "custom layout"
4. Create an ext3 /boot partition (125M)
5. Create a new LVM PV using the remaining space.
  
Actual results:

Anaconda crashes.

Expected results:

Either a diagnostic messages as to why the operation failed, or a proper (re-)partitioning of the disk.

Additional info:

Anaconda also fails to re-use an existing layout when selecting "replace existing Linux installation".
Comment 1 Chris Lumens 2009-04-08 10:19:59 EDT

*** This bug has been marked as a duplicate of bug 491348 ***

Note You need to log in before you can comment on or make changes to this bug.