Bug 494815 - kernels > 2.6.29.1-37.rc1..fc11.i686.PAE HANG on iwl3945
kernels > 2.6.29.1-37.rc1..fc11.i686.PAE HANG on iwl3945
Status: CLOSED DUPLICATE of bug 495003
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-08 04:30 EDT by Nigel Jones
Modified: 2009-04-13 10:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-13 10:11:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nigel Jones 2009-04-08 04:30:50 EDT
Description of problem:

I have "ONBOOT=true" set in the scripts in /etc/sysconfig/networking for all my network devices, even though I use NetworkManager to manage connections.

I'd been happily tracking rawhide until I applied the 2.6.29.1-54 kernel.

Bootup would freeze just as the networking scripts were trying to activate/get an address on iwl3945. This occured time after time.

Any one of The following 3 actions avoided the problem
a) Backing off to 2.6.29.1-46
b) DISABLING the integrated wireless (iwl3945 mini-pcix in T60p) in BIOS
c) Changing to "ONBOOT=false"

The system would come up fine, and in the case of a & c the iwl3945 would work just fine.

I suspect this is something that whilst is easily avoided, could be indicative of another issue and could catch some people out, since it should absolutely not cause a hang.

I've not got any specific logs to share -- nothing in kernel syslogs presumably as the boot was relatively early on, but can repo as required.


Version-Release number of selected component (if applicable):

2.6.29.1-52 was the first (recent) kernel that caused this issue.
I *think* I saw it a long time ago (ie many weeks) but don't have details.


How reproducible:
Every time

Steps to Reproduce:
1.ensure ONBOOT=yes for iwl3945 managed device in networking scripts
2.boot with -52 or -54 kernel
3.enjoy the hang.
  
Actual results:
hang

Expected results:
no hang

Additional info:
Comment 1 Nigel Jones 2009-04-13 05:12:24 EDT
I think there's more to this than described above.

Unsure what changed on my system, but I've just hit a problem whereby the system would hang just as NetworkManager authenticated with a WPA2-PSK network when using the iwl3945.

The crash occurs regardless of whether hw scan was enabled or disabled.

Using a Zydas wifi usb adapter everything worked fine

To debug I tried kernels as follows -- with no other change

2.6.29.1-37.rc1 WORKS
2.6.29.1-46 HANG
2.6.29.1-52 HANG
2.6.29.1-54 HANG
2.6.29.1-68 HANG

when the hang occurs I don't get any kernel panic displayed, nor is there anything in my kernel log files (sadly)

To test I simply used "chkconfig NetworkManager off" and started manually instead
 - to try the zydas instead I used "/sbin/rmmod iwl3945" to avoid the hang

Now I did previously have -52 and -54 active, so there's obviously another subtle change that causes this -- but fundamentally it appears there are iwl3945 issues in these recent kernels since -37
Comment 2 Nigel Jones 2009-04-13 05:12:55 EDT
Changing abstract accordingly
Comment 3 Nigel Jones 2009-04-13 06:06:24 EDT
I have 3 APs at home.
It appears this hang occurs when the iwl3945 connects to this AP (but only with the later kernels):

wlan0     Scan completed :
          Cell 01 - Address: 00:18:84:27:5D:33
                    ESSID:"planetf1c"
                    Mode:Master
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=45/100  Signal level:-82 dBm  Noise level=-127 dBm
                    Encryption key:on
                    IE: Unknown: 0009706C616E6574663163
                    IE: Unknown: 010882848B960C121824
                    IE: Unknown: 030101
                    IE: Unknown: 050400010000
                    IE: Unknown: 07064E4149010B1B
                    IE: Unknown: 200100
                    IE: Unknown: 2A0100
                    IE: Unknown: 32043048606C
                    IE: Unknown: DD180050F2020101880002A3400027A4000042435E0062322F00
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD0900037F01010020FF7F
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:tsf=000000278b2ff181
                    Extra: Last beacon: 4530ms ago


but NOT when connecting here:
wlan0     Scan completed :
          Cell 01 - Address: 00:18:84:2A:74:67
                    ESSID:"planetf1f"
                    Mode:Master
                    Channel:11
                    Frequency:2.462 GHz (Channel 11)
                    Quality=76/100  Signal level:-58 dBm  Noise level=-127 dBm
                    Encryption key:on
                    IE: Unknown: 0009706C616E6574663166
                    IE: Unknown: 010882848B0C12961824
                    IE: Unknown: 03010B
                    IE: Unknown: 07064E4149010B1B
                    IE: Unknown: 200100
                    IE: Unknown: 2A0100
                    IE: Unknown: 32043048606C
                    IE: Unknown: DD180050F2020101870002A4400027A4000042435E0062322F00
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD0900037F01010020FF7F
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:tsf=0000001088b3e181
                    Extra: Last beacon: 46ms ago


The main difference is that this one "bad" AP is running both WPA1 and WPA2, and supports AES and TKIP

My other 2 APs are AES/WPA2 only.

Note also that 2 aps (one good one bad) are running multi SSID configurations (additional unencrypted "guest" network)
Comment 4 John W. Linville 2009-04-13 10:11:04 EDT
Bug 495003 is later, but I saw that one first... :-)

*** This bug has been marked as a duplicate of bug 495003 ***

Note You need to log in before you can comment on or make changes to this bug.