Bug 495003 - kernels after 2.6.29.1-37.rc1 cause lockup with intel wireless
kernels after 2.6.29.1-37.rc1 cause lockup with intel wireless
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
: 494815 495223 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-08 22:14 EDT by Kevin Fenzi
Modified: 2009-05-12 14:20 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-12 14:20:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2009-04-08 22:14:18 EDT
kernel 2.6.29.1-37.rc1 boots and runs normally here. 

kernel-2.6.29.1-46.fc11.x86_64
kernel-2.6.29.1-52.fc11.x86_64
kernel-2.6.29.1-54.fc11.x86_64

All fail in this same way: 

Boot up is normal. X comes up fine. I login. 
Everything starts loading. 
NetworkManager loads and starts trying to connect to my wireless network. 
Machine hard locks. No answer from any keys. ;( 

I do have an intel 3945 wireless here, so I wonder if: 

* Thu Apr 02 2009 John W. Linville <linville@redhat.com>
- iwl3945: rely on priv->lock to protect priv access

* Thu Apr 02 2009 John W. Linville <linville@redhat.com>
- back-port iwlwifi rfkill while device down patches

Could be causing it? 

Happy to provide more info or try any tests.
Comment 1 John W. Linville 2009-04-09 11:10:14 EDT
Just to be sure, could you try each of the following kernels?

   http://koji.fedoraproject.org/koji/buildinfo?buildID=96417

   http://koji.fedoraproject.org/koji/buildinfo?buildID=96424

Do both of them fail similarly to -46.fc11 and after?  Or perhaps just the second one?
Comment 2 Kevin Fenzi 2009-04-09 11:17:54 EDT
The first of those seems to be a canceled task?

I can try the second one later this morning.
Comment 3 John W. Linville 2009-04-09 11:24:17 EDT
Ah yes, sorry...I forgot that I cancelled that build when I added the priv->lock patch...
Comment 4 Kevin Fenzi 2009-04-09 13:45:23 EDT
ok, the kernel-2.6.29.1-42.rc1.fc11.x86_64 kernel also locks up here. 

It locked up in a slightly different way. The others totally locked, this one I could still watch my gkrellm update and see that something was taking 100% cpu, but couldn't use the mouse/keyboard at all. 

Happy to try further testing.
Comment 5 John W. Linville 2009-04-09 14:07:28 EDT
Cool, thanks...first let's try dropping both of those patches:

   http://koji.fedoraproject.org/koji/taskinfo?taskID=1287731

Please give those kernels a try when the build completes...thanks!
Comment 6 Kevin Fenzi 2009-04-09 15:34:19 EDT
2.6.29.1-64.bz495003.1.fc11.x86_64 boots and runs normally. 
wireless comes up, no lockup.
Comment 7 John W. Linville 2009-04-13 10:11:04 EDT
*** Bug 494815 has been marked as a duplicate of this bug. ***
Comment 8 John W. Linville 2009-04-13 10:16:35 EDT
Looks like lots of people are hitting this on iwl3945.  Not sure if that is
what you have, but on a hunch I did a version that only removes the iwl3945
priv->lock patch.  Would you mind trying this version (when the build
completes)?

   http://koji.fedoraproject.org/koji/taskinfo?taskID=1294096
Comment 9 John W. Linville 2009-04-13 10:50:18 EDT
*** Bug 495223 has been marked as a duplicate of this bug. ***
Comment 10 Kevin Fenzi 2009-04-13 12:26:13 EDT
The kernel from comment #8 works fine here so far. ;)
Comment 11 John W. Linville 2009-04-13 13:13:31 EDT
Cool, thanks!
Comment 12 Nigel Jones 2009-04-13 16:45:46 EDT
Special kernel seems to work fine here too after reverting to the "bad" AP configuration... great.
Comment 13 Nigel Jones 2009-04-16 01:55:52 EDT
Appeared to get hang with -70 kernel. Didn't debug but downloaded -85 from koji which works fine with the "bad" AP.

Possibly unrelated, but latest kernel seems good for this problem. Thx.

Note You need to log in before you can comment on or make changes to this bug.