Bug 494869 - Played with repositories for Fedora to install with, at last only checked installation repo, checked none of the predefined groups and checked customize later
Played with repositories for Fedora to install with, at last only checked ins...
Status: CLOSED DUPLICATE of bug 457583
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:d8e79851939148013...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-08 09:33 EDT by Ben Lambrechts
Modified: 2009-06-08 15:13 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-08 15:13:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (182.98 KB, text/plain)
2009-04-08 09:33 EDT, Ben Lambrechts
no flags Details

  None (edit)
Description Ben Lambrechts 2009-04-08 09:33:16 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.38 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/yum/sqlitesack.py", line 121, in _sql_MD
    cache = getattr(self.sack, MD + 'db')[self.repo]
  File "/usr/lib/python2.6/site-packages/yum/sqlitesack.py", line 44, in newFunc
    return func(*args, **kwargs)
  File "/usr/lib/python2.6/site-packages/yum/sqlitesack.py", line 250, in returnPrco
    cur = self._sql_MD('primary', sql, (self.pkgKey,))
  File "/usr/lib/python2.6/site-packages/yum/packages.py", line 433, in returnPrcoNames
    lists = self.returnPrco(prcotype)
  File "/usr/lib/python2.6/site-packages/yum/packages.py", line 455, in <lambda>
    provides_names = property(fget=lambda self: self.returnPrcoNames('provides'))
  File "/usr/lib/python2.6/site-packages/yum/transactioninfo.py", line 173, in _allowedMultipleInstalls
    provides = po.provides_names
  File "/usr/lib/python2.6/site-packages/yum/transactioninfo.py", line 315, in addInstall
    if self._allowedMultipleInstalls(po):
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 2616, in install
    txmbr = self.tsInfo.addInstall(po)
  File "/usr/lib/python2.6/site-packages/yum/transactioninfo.py", line 205, in add
    for condtxmbr in self.install_method(po=pkg):
  File "/usr/lib/python2.6/site-packages/yum/transactioninfo.py", line 510, in add
    TransactionData.add(self, txmember)
  File "/usr/lib/anaconda/sortedtransaction.py", line 71, in add
    SortableTransactionData.add(self, txmember)
  File "/usr/lib/python2.6/site-packages/yum/transactioninfo.py", line 324, in addInstall
    self.add(txmbr)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 585, in _requiringFromTransaction
    txmbr = self.tsInfo.addInstall(best)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 280, in _processReq
    CheckDeps, missingdep = self._requiringFromTransaction(po, requirement, errormsgs)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 792, in _resolveRequires
    (checkdep, missing, errormsgs) = self._processReq(po, dep)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 699, in resolveDeps
    CheckDeps, checkinstalls, checkremoves, missing = self._resolveRequires(errors)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 703, in buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/anaconda/yuminstall.py", line 1305, in doPostSelection
    (code, msgs) = self.ayum.buildTransaction()
  File "/usr/lib/anaconda/backend.py", line 278, in doPostSelection
    return anaconda.backend.doPostSelection(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
KeyError: <yuminstall.AnacondaYumRepo object at 0x7f03d5926c90>
Comment 1 Ben Lambrechts 2009-04-08 09:33:27 EDT
Created attachment 338709 [details]
Attached traceback automatically from anaconda.
Comment 2 Andy Lindeberg 2009-06-08 15:13:08 EDT

*** This bug has been marked as a duplicate of bug 457583 ***

Note You need to log in before you can comment on or make changes to this bug.