Bug 494896 - system-config-samba needs a way acquire authorization to configure samba when launched through SSH
system-config-samba needs a way acquire authorization to configure samba when...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-samba (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-08 11:12 EDT by Scott Tsai
Modified: 2009-04-14 05:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 495659 (view as bug list)
Environment:
Last Closed: 2009-04-14 05:32:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Tsai 2009-04-08 11:12:19 EDT
Description of problem:
Currently when system-config-samba is launched through an remote SSH session with X11 forwarding, we get a backtrace: 
https://bugzilla.redhat.com/show_bug.cgi?id=490050#c6

"When logged in through SSH, you don't have a ConsoleKit session and therefore
aren't allowed to even acquire the authorization needed for configuring Samba.
I'm not sure if/how you can tweak the PolicyKit policy to be able to do that
over SSH. I agree that the tool should display a dialog indicating the problem,
though -- I've put a hold on about anything PolicyKit related because upstream
is revamping the whole thing and I don't want to make efforts now and have to
do them again later." See https://bugzilla.redhat.com/show_bug.cgi?id=490050#c8

As a user, I'd like system-config-samba to prompt me to ask for elevated privileges instead of display an error message.

Version-Release number of selected component (if applicable):
system-config-samba-1.2.72-1.fc11.noarch

How reproducible:
Always

Steps to Reproduce:
1. ssh REMOTE-HOST system-config-samba
  
Actual results:
Traceback (most recent call last):
  File "/usr/bin/system-config-samba", line 49, in <module>
    mainWindow.MainWindow (debug_flag = debug_flag, use_dbus = use_dbus)
  File "/usr/share/system-config-samba/mainWindow.py", line 104, in __init__
    self.samba_data = sambaConfig.SambaConfig (self.samba_backend)
  File "/usr/lib/python2.6/site-packages/scsamba/core/sambaConfig.py", line 29,
in __init__
    self.parseFile ()
  File "/usr/lib/python2.6/site-packages/scsamba/core/sambaConfig.py", line 32,
in parseFile
    return self.parse (self.backend.readSmbConf ())
  File "/usr/lib/python2.6/site-packages/slip/dbus/polkit.py", line 48, in
enable_proxy_wrapper
    return func (*p, **k)
  File "/usr/lib/python2.6/site-packages/scsamba/dbus/proxy/sambaBackend.py",
line 48, in readSmbConf
    return self.dbus_interface.readSmbConf ()
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in
__call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in
call_blocking
    message, timeout)
dbus.exceptions.DBusException:
org.fedoraproject.slip.dbus.service.PolKit.NotAuthorizedException.org.fedoraproject.config.samba.configure:


Expected results:
Pretty GUI.

Additional info:
Comment 1 Nils Philippsen 2009-04-14 05:32:56 EDT
I've changed the PolicyKit configuration files in system-config-samba-1.2.75 to allow this regardless of ConsoleKit session status, as you're required to supply the root password anyway, prohibiting this seems pointless.

Note You need to log in before you can comment on or make changes to this bug.