Bug 495019 - GUI dialogs with xdriver=vesa exceed the screen size
GUI dialogs with xdriver=vesa exceed the screen size
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-vesa (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-09 01:38 EDT by Allen Kistler
Modified: 2009-05-08 13:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-08 13:39:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.xlog with xdriver=vesa (32.81 KB, text/plain)
2009-04-10 16:44 EDT, Allen Kistler
no flags Details
xorg.conf with intel driver (1.91 KB, text/plain)
2009-04-10 21:34 EDT, Allen Kistler
no flags Details
Xorg.0.log with intel driver (73.49 KB, text/plain)
2009-04-10 21:35 EDT, Allen Kistler
no flags Details
xorg.conf forcing the vesa driver (1.93 KB, text/plain)
2009-04-10 22:37 EDT, Allen Kistler
no flags Details
Xorg.0.log with the forced vesa driver (32.87 KB, text/plain)
2009-04-10 22:37 EDT, Allen Kistler
no flags Details

  None (edit)
Description Allen Kistler 2009-04-09 01:38:40 EDT
Description of problem:
When booting anaconda with the "Install system with basic video driver" option, all the GUI dialogs are larger than the desktop, making it virtually impossible to navigate.  The display reports however that the video adapter is in 640x480 mode.  Also the desktop is not larger than the screen.  The mouse stops at the edges of the screen.

Version-Release number of selected component (if applicable):
11.5.0.38 (on the Beta DVD)

How reproducible:
Always

Steps to Reproduce:
1. Choose "Install system with basic video driver"
2. Observe the GUI dialogs run beyond the desktop
  
Actual results:
The dialogs exceed the screen size

Expected results:
The dialogs should fit on the screen

Additional info:
00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)
Comment 1 Allen Kistler 2009-04-09 04:34:09 EDT
I eventually had success using keyboard shortcuts for items that were off the screen.  If it helps, part way through boot to runlevel 3, the machine switched to 1600x1200 vga text mode spontaneously.  (1600x1200 is my display resolution.)  nomodeset works as a kernel parameter on the running system to stop that.
Comment 2 Matěj Cepl 2009-04-10 09:29:52 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) from the running system to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also add /var/log/anaconda.xlog?

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Allen Kistler 2009-04-10 16:42:48 EDT
I don't currently have X on the subject system, so there's no xorg.conf or Xorg.*.log.  It will be a little challenge to add X, but it's doable.

In the meantime, I'll add anaconda.xlog.
Comment 4 Allen Kistler 2009-04-10 16:44:16 EDT
Created attachment 339132 [details]
anaconda.xlog with xdriver=vesa
Comment 5 Allen Kistler 2009-04-10 21:33:39 EDT
X installed from DVD.  No rawhide.
It appears to work fine with the intel driver.
Too bad the same isn't true in anaconda.

Attaching xorg.conf and Xorg.0.log.
Comment 6 Allen Kistler 2009-04-10 21:34:36 EDT
Created attachment 339149 [details]
xorg.conf with intel driver
Comment 7 Allen Kistler 2009-04-10 21:35:13 EDT
Created attachment 339150 [details]
Xorg.0.log with intel driver
Comment 8 Allen Kistler 2009-04-10 22:37:01 EDT
Created attachment 339151 [details]
xorg.conf forcing the vesa driver
Comment 9 Allen Kistler 2009-04-10 22:37:55 EDT
Created attachment 339152 [details]
Xorg.0.log with the forced vesa driver
Comment 10 Mike Wolf 2009-04-15 20:22:48 EDT
Allen,

I experienced the bug you reported (Bug 495032), which lead me to this bug.  I've tried to recreate this bug with two separate machines that also have the 865G graphics, and have been unsuccessful.  However, I've only been able to test with monitors whose highest resolutions are 1280x1024 and 1680x1050.  The one thing I noticed was that when installing with the 1680x1050 monitor, anaconda actually used 1280x1024 resolution.  This makes me wonder if the problem is specific to the 1600x1200 resolution that you're using.  Do you have another monitor with a lesser resolution on which to test this?

For the record, I'm not part of the team fixing this - I'm just an interested beta tester who wants to help.

Thanks,

Mike
Comment 11 Allen Kistler 2009-04-16 00:55:47 EDT
Mike:

1600x1200 is the only monitor I've got.  Sorry.

The xorg files and the kernel that anaconda uses appear to be the same as the ones installed.  Once installed, everything runs fine.  It's just in anaconda that the GUI is screwed up.
Comment 12 Allen Kistler 2009-04-20 21:15:19 EDT
So here's a simple question that occurs to me.

The video card has 1M of memory.
The vesa driver figures out that 1M of RAM means 640x480x16bpp.
You can read that in the anaconda.xlog file.

Is the essence of the problem that something no longer knows how to deal with a graphics area as small as 640x480?
Comment 13 Adam Jackson 2009-05-07 17:53:20 EDT
Anaconda's UI has never been able to deal with anything smaller than 800x600.  Don't know why you were trying to install with vesa though, it's really a last resort kind of thing.
Comment 14 Allen Kistler 2009-05-07 17:59:19 EDT
800x600 would work, except it doesn't.
Can you make 800x600 work, since that's your criterion?
Comment 15 Allen Kistler 2009-05-07 18:09:00 EDT
Regarding 800x600 being the lowest res mode, from
http://fedoraproject.org/wiki/Anaconda/Options

lowres
Force GUI installer to run at 640x480

As to why I'm using the vesa driver...
Well, the intel driver is even more broken (invisible mouse) and text mode had a bunch of functionality ripped out.  But whatever the reason, if somebody needs the last ditch resort, shouldn't the last ditch resort work?
Comment 16 Adam Jackson 2009-05-08 13:39:39 EDT
"Force" means "even though the UI will have lots of elements offscreen, do it anyway", not "resize the UI to be smaller".

It would be lovely if the vesa driver worked in all cases, but there's any number of reasons why it might fail.  It does very little more than call to BIOS routines to set up the video mode, and if those don't work, there's nothing we can do.  In this case, since you have so little video memory set up by the BIOS, we filter out all the video modes that wouldn't fit, and the only thing that's left happens to be 640x480.  Unfortunate, but the BIOS really won't let us do anything else.

Some machines have options in the BIOS setup to control how much video memory is allocated to the graphics chip at boot time.  If yours does, that might make vesa work at larger than 640x480.

The invisible cursor bug on with the intel driver on 865 is already known and should be fixed for F11.

Note You need to log in before you can comment on or make changes to this bug.