Bug 495032 - No mouse cursor, then lock-up
No mouse cursor, then lock-up
Status: CLOSED DUPLICATE of bug 488980
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-09 04:33 EDT by Allen Kistler
Modified: 2009-06-08 14:43 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-08 14:43:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/tmp/X.log from running anaconda (29.83 KB, text/plain)
2009-04-20 15:55 EDT, Allen Kistler
no flags Details
/tmp/anaconda.log from running anaconda (16.13 KB, text/plain)
2009-04-20 16:13 EDT, Allen Kistler
no flags Details
anaconda.xlog from Preview installation (36.61 KB, text/plain)
2009-05-06 21:54 EDT, Allen Kistler
no flags Details

  None (edit)
Description Allen Kistler 2009-04-09 04:33:06 EDT
Description of problem:
Starting anaconda with "Install or upgrade an existing system" results in no visible mouse cursor.  There *is* a mouse, since I can actually click on things if I get lucky (e.g., Timezone selection), but it's invisible.  Using keyboard shortcuts is more certain, but eventually anaconda locks up.

Version-Release number of selected component (if applicable):
11.5.0.38 (on the Beta DVD)

How reproducible:
Always

Steps to Reproduce:
1. Choose "Install or upgrade an existing system"
2. Observe the lack of a cursor
3. Observe the eventual lock-up
  
Actual results:
No cursor.  Locks up.

Expected results:
Cursor.  No lockup.

Additional info:
00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics
Controller (rev 02)

The display is 1600x1200, which anaconda uses.
Passing lowres as an option has no effect.
Passing resolution=<mode> has no effect.  (Tried 800x600 and 1024x768.)

I had slightly more success adding nomodeset.  nomodeset gives me a usable cursor, unfortunately the machine eventually locks up while detecting storage devices.  This time there's a sort of checkerboard pattern filling the screen and a clearly visible "watch" cursor.  nomodeset results in really heavy DVD activity that causes about 5 minutes between screens (before the lock-up), too.

I eventually had the most success with xdriver=vesa (but see Bug 495019).
Comment 1 Chris Lumens 2009-04-09 10:04:36 EDT
Is the mouse cursor ever present?  Does it start out there and then disappears at a particular point?
Comment 2 Allen Kistler 2009-04-09 12:40:36 EDT
Without nomodeset (or xdriver=vesa), the mouse cursor is never there.

I can observe the effects of the mouse, like a combobox changing color when the mouse is over it or the cities changing on the timezone map, but not the mouse itself.
Comment 3 Mike Wolf 2009-04-15 00:04:46 EDT
I've had the same problem on both a Dell Optiplex GX270 and Dell Dimension B110, which share the Intel 865G graphics.  However, the "Install system with basic video driver" option works for me (at least in the B110), without the issue described in Bug 495019.  If it makes a difference, the monitor on each of those machines is only 1280x1024.

As soon as the B110 is done with the install, I'll let you know if I have similar success on the GX270.
Comment 4 Thomas J. Baker 2009-04-16 14:37:26 EDT
Optiplex GX260, same 865 graphics, and no mouse cursor when using no config file.
Comment 5 Thomas J. Baker 2009-04-16 14:37:57 EDT
I should have added, F11Beta+rawhide updates, i386.
Comment 6 Matěj Cepl 2009-04-20 10:34:08 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

When the anaconda crashes, please, switch to the console (Ctrl+Alt+F2) and copy /tmp/X* and /var/log/anaconda.xlog to some other place -- USB stick, some other computer via network, some on the Internet, and please attach it to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 7 Allen Kistler 2009-04-20 15:55:57 EDT
Created attachment 340423 [details]
/tmp/X.log from running anaconda

When anaconda locks up, the only button that does anything is the power button.  Alt-Ctrl-F2 (and any keyboard key) does nothing.

However, before anaconda crashes, Alt-Ctrl-F2 works fine.  I'm attaching /tmp/X.log, which I suspect eventually becomes /var/log/anaconda.xlog.  While anaconda is running, there is no /var/log directory.
Comment 8 Allen Kistler 2009-04-20 16:13:51 EDT
Created attachment 340427 [details]
/tmp/anaconda.log from running anaconda

For good measure, here's a copy of /tmp/anaconda.log.  I tried installing twice this time.  The first attempt locked up on the timezone map.  The second attempt locked up on the root password.  The attached files are from the second attempt before it locked up.  No attempt I've ever done has made it past disk setup (at least not with the intel driver).
Comment 9 Allen Kistler 2009-04-20 21:27:16 EDT
Looking through the X.log file, here's what I notice.

The video card has 1M of RAM, but the intel driver seems to think it has 4G of RAM.  Should I be amazed it worked at all?
Comment 10 Allen Kistler 2009-05-06 21:54:45 EDT
Created attachment 342754 [details]
anaconda.xlog from Preview installation

On the Preview DVD, passing in "nomodeset" to anaconda results in the mouse being visible on my machine.  Also anaconda does not lockup.

The attached anaconda.xlog is from the Preview DVD installation run (with "nomodeset").  There are two things to note.

1. The reported VideoRAM is 128M, despite the real value being 1M.
   Still, it's an improvement over reporting that there's 4G of VideoRAM.
   I'm a bit perplexed how anaconda worked in 1600x1200x32 mode with 1M of RAM.
   (BTW this is a machine that spends its life at runlevel 3.)

2. The xlog file ends rather abruptly with a strange error, even though
   anaconda seemed to run okay graphically.

Without "nomodeset" the mouse is still invisible.  I didn't check to see if installation still locks up under that condition.
Comment 11 Adam Williamson 2009-05-12 17:58:09 EDT
The missing cursor bug is fully known and has its own report:

https://bugzilla.redhat.com/show_bug.cgi?id=488980

the reported amount of memory is, according to ajax, almost certainly irrelevant. For the record, Intel graphics chips do not come with dedicated video RAM, they share system memory, and can use as much or as little as they need.
Comment 12 Allen Kistler 2009-06-08 14:43:03 EDT
I think the only unresolved issues with this bug were those that ended up being the same as Bug 488980.  Closing this one as a dupe.

*** This bug has been marked as a duplicate of bug 488980 ***

Note You need to log in before you can comment on or make changes to this bug.