Bug 495029 - useless mount appears in nautilus's sidebar on the livecd
useless mount appears in nautilus's sidebar on the livecd
Status: CLOSED DUPLICATE of bug 495033
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-09 04:19 EDT by Tomeu Vizoso
Modified: 2015-03-03 17:40 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-09 15:48:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomeu Vizoso 2009-04-09 04:19:52 EDT
Description of problem:

On the live image, nautilus displays on the sidebar a volume representing the media from where we booted. After double clicking on it, nothing happens (error while trying to mount it?).

How reproducible:

Always.

Steps to Reproduce:
1. Boot the beta f11 live image on an usb stick
2. Open a nautilus window
3. Look in the sidebar on the right for a volume with the same label as the partition from where the live system booted.
4. Double click it

Actual results:

Nothing happens

Expected results:

Either Nautilus' main-view should display the contents of that volume, or the volume shouldn't appear in the sidebar.

Additional info:

This is also a problem for Sugar, which uses a very similar way of displaying mountable devices. That's why I'm adding davidz to cc, because gvfs and gdu are involved.
Comment 1 David Zeuthen 2009-04-09 11:41:16 EDT
More details please

 - gvfs-mount -li
 - devkit-disks --dump
 - maybe a screenshot

This might also be a dupe of bug 495018 since my guess is that you are talking about iso9660 media. Please check if this is the case.
Comment 2 Tomeu Vizoso 2009-04-09 14:18:34 EDT
See bug 495033 for logs and a screenshot.

AFAIK, there's no iso9660 media involved here, this is an eeepc booting out of live media created with:

./livecd-iso-to-disk.sh --overlay-size-mb 100 --home-size-mb 80 --delete-home --unencrypted-home F11-Beta-i686-Live.iso /dev/sdb1

Sorry if having two bugs are confusing, when I entered them they looked like two different (though related) issues.
Comment 3 David Zeuthen 2009-04-09 15:48:48 EDT
Let's close this as a dupe of bug 495033 for now. Please reinvestigate when bug 495033 is resolved. Thanks.

*** This bug has been marked as a duplicate of bug 495033 ***
Comment 4 Tomeu Vizoso 2009-04-15 12:50:29 EDT
Confirming this is fixed in latest devicekit-disks/gdu/gvfs

Note You need to log in before you can comment on or make changes to this bug.