Bug 495033 - read-only live partition appears in nautilus in the live images
read-only live partition appears in nautilus in the live images
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gvfs (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
: 495029 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-09 04:39 EDT by Tomeu Vizoso
Modified: 2015-03-03 17:40 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-09 22:05:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (13.36 KB, image/png)
2009-04-09 14:06 EDT, Tomeu Vizoso
no flags Details
gvfs-mount -li (2.17 KB, text/plain)
2009-04-09 14:08 EDT, Tomeu Vizoso
no flags Details
devkit-disks --dump (12.23 KB, text/plain)
2009-04-09 14:09 EDT, Tomeu Vizoso
no flags Details

  None (edit)
Description Tomeu Vizoso 2009-04-09 04:39:03 EDT
Description of problem:

Fedora live images have a read-only partition and a rw overlay on top of it, mounted in /. The unioned root partition appears correctly in nautilus as the "File System" entry in the sidebar and works as expected. But the read-only component of it also appears as a volume called F11-Beta-i686-Live.

Users may get confused about it if they don't know the details of how live images work.

How reproducible:

Always.

Steps to Reproduce:
1. Boot the beta f11 live image on an usb stick.
2. Open a nautilus window.
  
Actual results:

A volume called F11-Beta-i686-Live appears in the sidebar and is browseable.

Expected results:

The read-only partition doesn't appear in nautilus.

Additional info:

This also is a problem in Sugar, where 99% of users are non-technical and get confused. Adding davidz to CC because both nautilus and sugar use gvfs/gdu to display the available volumes.
Comment 1 David Zeuthen 2009-04-09 11:04:35 EDT
Please attach the output of 

 - gvfs-mount -li
 - devkit-disks --dump

Btw, is bug 495029 a duplicate of this?
Comment 2 Tomeu Vizoso 2009-04-09 11:31:38 EDT
(In reply to comment #1)
> Please attach the output of 
> 
>  - gvfs-mount -li
>  - devkit-disks --dump

Will do in a bit.

> Btw, is bug 495029 a duplicate of this?  

No, this bug is about the read-only squashfs partition confusing people. Bug 495029 is about a partition that cannot be mounted.
Comment 3 Tomeu Vizoso 2009-04-09 14:06:20 EDT
Created attachment 338964 [details]
screenshot
Comment 4 Tomeu Vizoso 2009-04-09 14:08:48 EDT
Created attachment 338967 [details]
gvfs-mount -li
Comment 5 Tomeu Vizoso 2009-04-09 14:09:36 EDT
Created attachment 338968 [details]
devkit-disks --dump
Comment 6 Tomeu Vizoso 2009-04-09 14:12:45 EDT
The screenshot is of nautilus displaying computer:// and using the sugar gtk engine and icon theme.
Comment 7 Tomeu Vizoso 2009-04-09 15:32:48 EDT
(09:09:42 PM) davidz: tomeu: so.. can you make a quick comment in the bug about what volumes/mounts are [unwanted]? Please use device files to refer to them

/dev/sda1: it's a partition in the internal hard disk and would be nice to have it mounted rw somewhere in /media. not sure why it appears with the label /boot there.

/dev/sdb1: it's the device from where the live stuff was booted, should appear mountable in /media

/dev/dm-1: is the squashfs partition and shouldn't appear at all

/dev/dm-2: already mounted in '/', so shouldn't appear at all

---

[root@localhost live]# cat /proc/self/mountinfo
23 1 253:0 / / rw,noatime - ext3 /dev/mapper/live-rw rw,errors=continue,user_xattr,acl,data=ordered
24 23 0:15 / /dev rw - tmpfs udev rw,mode=755
25 23 0:3 / /proc rw - proc /proc rw
26 23 0:0 / /sys rw - sysfs /sys rw
16 25 0:14 / /proc/bus/usb rw - usbfs /proc/bus/usb rw
27 24 0:10 / /dev/pts rw - devpts devpts rw,gid=5,mode=620,ptmxmode=000
28 24 0:16 / /dev/shm rw - tmpfs tmpfs rw
29 25 0:17 / /proc/sys/fs/binfmt_misc rw - binfmt_misc none rw
30 23 8:17 / /mnt/live rw - ext2 /dev/sdb1 rw,errors=continue
31 23 7:5 / /home rw - ext3 /dev/loop5 rw,errors=continue,user_xattr,acl,data=ordered
32 23 0:18 / /var/cache/yum rw - tmpfs varcacheyum rw,mode=755
33 23 0:19 / /tmp rw - tmpfs /tmp rw
34 23 0:20 / /var/tmp rw - tmpfs vartmp rw

[root@localhost live]# cat /etc/mtab
/dev/mapper/live-rw / ext3 rw,noatime 0 0
proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
devpts /dev/pts devpts rw,gid=5,mode=620 0 0
tmpfs /dev/shm tmpfs rw 0 0
none /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
/dev/sdb1 /mnt/live ext2 rw 0 0
/dev/loop5 /home ext3 rw 0 0
varcacheyum /var/cache/yum tmpfs rw,mode=0755 0 0
/tmp /tmp tmpfs rw 0 0
vartmp /var/tmp tmpfs rw 0 0

[root@localhost live]# cat /etc/fstab
/dev/root  /         ext3    defaults,noatime 0 0
devpts     /dev/pts  devpts  gid=5,mode=620   0 0
tmpfs      /dev/shm  tmpfs   defaults         0 0
proc       /proc     proc    defaults         0 0
sysfs      /sys      sysfs   defaults         0 0
Comment 8 David Zeuthen 2009-04-09 15:48:48 EDT
*** Bug 495029 has been marked as a duplicate of this bug. ***
Comment 9 David Zeuthen 2009-04-09 22:05:52 EDT
(In reply to comment #7)
> (09:09:42 PM) davidz: tomeu: so.. can you make a quick comment in the bug about
> what volumes/mounts are [unwanted]? Please use device files to refer to them
> 
> /dev/sda1: it's a partition in the internal hard disk and would be nice to have
> it mounted rw somewhere in /media. not sure why it appears with the label /boot
> there.

The label of the filesystem is /boot. It is not automounted because the live user by default lacks the authorization for the action 

 org.freedesktop.devicekit.disks.filesystem-mount-system-internal

With gnome-disk-utility-0.3-0.1.20090406git.fc11.x86_64 it can be mounted if you click on it (since the livecd password is blank no auth dialog is shown).

> /dev/sdb1: it's the device from where the live stuff was booted, should appear
> mountable in /media

The livecd boot scripts mounts this at /mnt/live and as such this device SHOULD be hidden (we only show stuff mounted in /media and $HOME). Since it is the only partition on that drive, the drive SHOULD also be hidden.

I fixed this bug with these patches

http://cgit.freedesktop.org/~david/gvfs/commit/?h=gdu-volume-monitor&id=d9a00cc6172e2bf82f6825023c7a619be7f56747
http://cgit.freedesktop.org/~david/gvfs/commit/?h=gdu-volume-monitor&id=346fdc3ddf383228ed58a48252e70919f6636b6e

> /dev/dm-1: is the squashfs partition and shouldn't appear at all

I agree it shouldn't appear. But due to the way things are set up on the live cd (I know because I wrote the initial version of the livecd code), this device nod is used to create a snapshot device. As such, it appears to the rest of the system just like a device node with a mountable filesystem. Thus, we show it in the UI so the user can get to the data.

The fix here is to make the livecd boot scripts mount this device node in /mnt/squashfs or something and that way we will not show it (since /mnt/squashfs is not a user-visible location, only /media and $HOME is).

I will file a bug about against livecd-tools about this.

> /dev/dm-2: already mounted in '/', so shouldn't appear at all

Same story as /dev/sdb1. Fixed with the same patches.

Fixed in gvfs-1.2.1-3.fc11.

http://koji.fedoraproject.org/koji/buildinfo?buildID=97280

If you want to try this on a live cd you will need to update to at least the following package versions

 gnome-disk-utility-ui-libs-0.3-0.1.20090406git.fc11.x86_64
 gnome-disk-utility-devel-0.3-0.1.20090406git.fc11.x86_64
 gnome-disk-utility-libs-0.3-0.1.20090406git.fc11.x86_64
 gnome-disk-utility-0.3-0.1.20090406git.fc11.x86_64
 gnome-disk-utility-ui-devel-0.3-0.1.20090406git.fc11.x86_64
 gvfs-obexftp-1.2.1-3.fc11.x86_64
 gvfs-devel-1.2.1-3.fc11.x86_64
 gvfs-fuse-1.2.1-3.fc11.x86_64
 gvfs-1.2.1-3.fc11.x86_64
 gvfs-archive-1.2.1-3.fc11.x86_64
 gvfs-smb-1.2.1-3.fc11.x86_64
 gvfs-gphoto2-1.2.1-3.fc11.x86_64
 DeviceKit-disks-004-0.4.20090406git.fc11.x86_64
 DeviceKit-disks-devel-004-0.4.20090406git.fc11.x86_64

then logout. Then login on VT2 as root and do

 - for i in /sys/class/block/* ; do echo change > $i/uevent ; done
 - killall devkit-disks-daemon

and then switch back to gdm and log in. Then things should work.

It's probably easier to just spin a new live cd against Rawhide.
Comment 10 David Zeuthen 2009-04-09 22:27:16 EDT
(In reply to comment #9)
> The fix here is to make the livecd boot scripts mount this device node in
> /mnt/squashfs or something and that way we will not show it (since
> /mnt/squashfs is not a user-visible location, only /media and $HOME is).
> 
> I will file a bug about against livecd-tools about this.

This is bug 495170.

    David
Comment 11 Tomeu Vizoso 2009-04-15 12:51:28 EDT
Confirming this is fixed in latest devicekit-disks/gdu/gvfs

Note You need to log in before you can comment on or make changes to this bug.