Bug 495071 - [UEFI Test Day] efidisk.img fails on Apple Macintosh mini Intel CPU
[UEFI Test Day] efidisk.img fails on Apple Macintosh mini Intel CPU
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
: 495123 495163 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-09 11:39 EDT by John Reiser
Modified: 2009-11-28 13:05 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-28 13:05:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2009-04-09 11:39:58 EDT
Description of problem: efidisk.img fails to get into anaconda when booted on Apple Macintosh mini with Intel CPU.


Version-Release number of selected component (if applicable):
md5sum
b23a32eefd42d39b81127ccadbff42c3  http://mirror.hiwaay.net/pub/fedora/linux/releases/test/11-Beta/Fedora/i386/os/images/efidisk.img


How reproducible: every time


Steps to Reproduce:
1. Download Fedora 11 Beta i386 images/efidisk.img
2. dd onto USB flash storage device, creating "disk" device with GPT partition table.
3. Boot on Apple Macintosh mini with Intel CPU (hold down Option key during chime that follows boot after PowerOn or Reboot)
  
Actual results: Two icons are offered for boot: internal harddrive icon labeled "Macintosh HD" and golden-colored external enclosure icon with USB logo labeled "EFI Boot".  Choosing EFI Boot gives "No startup drive" icon (slowly-flashing question mark in 3cm icon of gray folder) for a few seconds, then switches to Apple logo and usual boot into MacOS 10.5.6 from harddrive.


Expected results: Enter anaconda for install of Fedora 11.


Additional info: Apple Boot ROM version MM11.0055B08, MacOS 10.5.6.  Intel Core Duo (i686 only; not Core 2 Duo, which would be x86_64.)
Comment 1 John Reiser 2009-04-09 11:51:13 EDT
After logging in to Apple MacOS 10.5.6, then I see an alert from the OS that "The disk you inserted is not recognized" and there is no logo for it displayed on the desktop, like there is when inserting a USB flash drive that has a DOS partition table with 4 partitions, one partition of which is FAT.
Comment 2 John Reiser 2009-04-09 13:25:38 EDT
Trying the x86_64 version of efidisk.img on a MacBookPro, I'm offered the same two icons for boot (internal harddrive, external USB drive) but this time the activity LED on the USB flash memory drive keeps flashing until I make a choice.  When I choose EFI Boot then I get a GRUB console with prompt (looks like 640x480 VGA text centered in 1440x900 display).  Entering "help\r" gives the usual cue sheet, but no literal example.  I don't know what to type.  So I wait a couple minutes, then something times out, and I get the usual Apple boot from harddrive.  Boot ROM version MBP31.0070.B07.  md5sum dede1c9a006a22853db470ecd7fa61e8  efidisk-x86_64.img.
Comment 3 Peter Jones 2009-05-07 10:50:18 EDT
Can you try this again with a recent rawhide?  These problems might both be fixed.
Comment 4 Peter Jones 2009-05-07 10:57:58 EDT
This should be fixed with grub-0.97-47 .
Comment 5 Peter Jones 2009-05-07 10:58:01 EDT
*** Bug 495123 has been marked as a duplicate of this bug. ***
Comment 6 Peter Jones 2009-05-07 10:59:03 EDT
*** Bug 495163 has been marked as a duplicate of this bug. ***
Comment 7 John Reiser 2009-05-07 13:18:15 EDT
Trying today's (Thurs. 2009-05-07) i386 efidisk.img (md5sum 5bf149152ead74c09cfa86af4523f317) on a USB2.0 flash memory device fails in a different way.  Initially I see three boot icons: MacOS, Windows, EFI disk.  

Selecting and booting EFI disk gives a 640x480 grub screen.  Letting the 5-second countdown expire, or entering GRUB and explicitly booting by typing 'b', both hang the machine (Mac mini Intel Core Duo i686 only) with no response to keyboard; the screen continues displaying the last GRUB contents.

Selecting and booting Windows gives an all-white screen for about 4 seconds, then "Missing operating system" in VGA text of white letters on an all-black background, and hangs the machine with no response to keyboard.
Comment 8 John Reiser 2009-05-08 12:03:23 EDT
It still fails today the same as yesterday, presumably with anaconda-11.5.0.51-1.fc11 according to Rawhide Report.
-rw-rw-r-- 1 jreiser jreiser 22493184 2009-05-08 08:27 efidisk.img
07506533b1fd17021d2c5324556749b9  efidisk.img
Comment 9 Bug Zapper 2009-06-09 09:33:02 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 W. Michael Petullo 2009-06-15 01:01:37 EDT
I am trying to boot using Netboot. I have TFTP and DHCP services running and I point my MacBook (5,1) at BOOTX64.efi from i386/os/images/efiboot.img. My kernel and initrd.gz come from  i386/os/images/efidisk.img.

This seems to be similar to comment #7, only using Netboot instead of a flash disk. My kernel and initrd.gz are on my internal disk, on a filesystem readable by GRUB.

My results are the same. I get to the GRUB prompt and do the following:

grub> kernel (hd0,2)/vmlinuz
[Linux-EFI, setup=0x1010, size=0x2e19b0]

grub> initrd (hd0,2)/initrd.gz
[Initrd, addr=0x79921000, size=0x121b34a]

grub> boot

...and GRUB hangs.
Comment 11 Vedran Miletić 2009-11-28 04:46:06 EST
How about Fedora 12?
Comment 12 John Reiser 2009-11-28 12:55:24 EST
Trying fedora/linux/releases/12/Fedora/i386/os/images/efidisk.img (08-Nov-2009, md5sum cb9e4f1e588ffb21c3fa0c971829549c) does boot, runs and displays GRUB, and starts the installer.  However, the user interface is poor.

The delay is about 33 seconds between the expired countdown "Booting Fedora 12 in 0 seconds ..." and any change in the screen (becoming the full-screen blue background with "Welcome to Fedora i386" in text in the upper left.)  There is no visual feedback of "Loading vmlinuz...  Loading initrd..." on a VGA-style text console.  Half a minute is an eternity when there is no indication that anything is happening.  When /sbin/loader begins, then there is an additional delay of 15 seconds or so with no feedback before the dialog "Choose a language" appears.

The display sizing also has quirks.  On a monitor with 1280x1024 native resolution, only the top 1152 rasters are used.  The bottom 128 rasters have (16+16) horizontal stripes of solid black (4 pixels tall) alternating with random binary data (4 pixels tall).  Instead of being centered, the text dialog boxes are shifted a couple centimeters towards the top and towards the right.
Comment 13 Vedran Miletić 2009-11-28 13:05:44 EST
OK, thanks for reporting back. Please open two separate bugs for 30 second delay and display sizing.

I will close this one now, as it's fixed.

Note You need to log in before you can comment on or make changes to this bug.