Bug 495081 - [PATCH] Invalid syntax in /etc/init.d/halt: missing ']'
[PATCH] Invalid syntax in /etc/init.d/halt: missing ']'
Status: CLOSED DUPLICATE of bug 480799
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-09 13:03 EDT by Pavel Roskin
Modified: 2014-03-16 23:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-09 13:08:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch (253 bytes, patch)
2009-04-09 13:03 EDT, Pavel Roskin
no flags Details | Diff

  None (edit)
Description Pavel Roskin 2009-04-09 13:03:15 EDT
Created attachment 338947 [details]
Patch

Description of problem:
There is a message briefly appearing on reboot:
S01reboot: line 178: [: missing `]'

Version-Release number of selected component (if applicable):
initscripts-8.86.2-1.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Run "reboot" locally
2. Look carefully at the screen
  
Actual results:
The message appears

Expected results:
The message doesn't appear

Additional info:
/etc/rc.6/S01reboot is a link to /etc/init.d/halt.  Bash doesn't allow ']' (as part of the '[' command ) to be glued to the previous token.
Comment 1 Bill Nottingham 2009-04-09 13:08:30 EDT
Please upgrade to 8.86.3.

*** This bug has been marked as a duplicate of bug 480799 ***

Note You need to log in before you can comment on or make changes to this bug.