Bug 495088 - high system load with lot of time spent in processing soft interupts
high system load with lot of time spent in processing soft interupts
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.3
i386 Linux
low Severity medium
: rc
: ---
Assigned To: David Howells
Red Hat Kernel QE team
:
: 495086 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-09 13:42 EDT by Stefan Kaltenbrunner
Modified: 2014-09-15 07:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-03 08:30:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (44 bytes, text/plain)
2009-04-09 13:42 EDT, Stefan Kaltenbrunner
no flags Details
lsmod output (43 bytes, text/plain)
2009-04-09 13:43 EDT, Stefan Kaltenbrunner
no flags Details

  None (edit)
Description Stefan Kaltenbrunner 2009-04-09 13:42:05 EDT
Created attachment 338959 [details]
dmesg

Description of problem:

On a fresh install of CentOS 5.3/i386 on a HP DL140 (Single core Xeon with HT enabled, 1GB of RAM and two 250GB IDE disks in a software raid 1)


Version-Release number of selected component (if applicable):

While this is CentOS I still though it could be of interest. The OS is CentOS 5.3 with the kernel upgraded to the latest available:

2.6.18-128.1.6.el5

How reproducible:

always


Steps to Reproduce:

simply installing the OS,rebooting and running top/vmstat shows that the box is spending significant time in system time/soft interupts. load average hovers between 1 and 2 on a completely idle box. Interactive performance is fairly sluggish as well.

booting the kernel with profile=2 shows the following profile:

3726021 total                                      1.7179
2706291 default_idle                             30407.7640
977239 delay_tsc                                51433.6316
 62680 *unknown*
 33245 use_tsc_delay                            3022.2727
   778 __const_udelay                            21.0270
   675 kunmap_atomic                              6.7500
   666 do_page_fault                              0.5367
   420 do_wp_page                                 0.4062
   390 get_page_from_freelist                     0.4762
   348 context_struct_compute_av                  0.5404
   244 __handle_mm_fault                          0.1071
   236 avtab_search_node                          2.3137
   209 generic__raw_read_trylock                 12.2941
   158 _spin_lock                                10.5333
   146 vgacon_do_font_op                          0.1619
   143 unmap_vmas                                 0.1077
   132 end_page_fs_misc                           3.1429
   111 system_call                                2.7073
   111 mpihelp_submul_1                           0.6607
Comment 1 Stefan Kaltenbrunner 2009-04-09 13:43:55 EDT
Created attachment 338960 [details]
lsmod output
Comment 2 Anton Arapov 2009-04-10 03:07:53 EDT
*** Bug 495086 has been marked as a duplicate of this bug. ***
Comment 3 Tom Wood 2009-12-21 11:38:07 EST
Same issue on Dell Poweredge 650, software RAID1, two WD 320 GB PATA drives.  Machine extremely sluggish - even the install took hours and was quite nonresponsive to console input.
Comment 6 RHEL Product and Program Management 2014-03-07 07:45:28 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 7 RHEL Product and Program Management 2014-06-03 08:30:38 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.