Bug 495090 - KMS freeze on suspend-to-disk/resume on Mobility Radeon X1300 [1002:7149]
KMS freeze on suspend-to-disk/resume on Mobility Radeon X1300 [1002:7149]
Status: CLOSED DUPLICATE of bug 522070
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
http://www.smolts.org/client/show/pub...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-09 13:51 EDT by Stefan Becker
Modified: 2009-09-12 04:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-12 04:16:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X server logfile (41.58 KB, text/plain)
2009-04-09 13:51 EDT, Stefan Becker
no flags Details
dmesg logfile (44.76 KB, text/plain)
2009-04-09 13:51 EDT, Stefan Becker
no flags Details

  None (edit)
Description Stefan Becker 2009-04-09 13:51:03 EDT
Created attachment 338962 [details]
X server logfile

Description of problem:

Latest kernel/driver breaks suspend-to-disk/resume with KMS. Either the machine freezes directly when suspend-to-disk is initiated or when resume tries to restart the tasks.

When the machine freezes the picture on the LCD looks like the CRTC is wrongly set up, e.g. you can see the vertical/horizontal blank periods. The picture parts don't show any content, just colors.

Version-Release number of selected component (if applicable):
kernel-2.6.29.1-54.fc11.i586
pm-utils-1.2.4-2.fc11.i586
xorg-x11-drv-ati-6.12.1-9.fc11.i586

How reproducible:
very often

Additional info:

Smolt profile attached as URL

As far as I can tell:

 - KMS disabled: suspend-to-RAM/suspend-to-disk works perfectly
 - KMS enabled: suspend-to-RAM works perfectly

An active WLAN connection (iwl3945) seems to be related to the freeze. Maybe this is an interrupts-not-disabled problem?

/proc/interrupts:

           CPU0       CPU1       
  0:     153783          0   IO-APIC-edge      timer
  1:        198          0   IO-APIC-edge      i8042
  8:         13          0   IO-APIC-edge      rtc0
  9:        673        758   IO-APIC-fasteoi   acpi
 12:       2540       8291   IO-APIC-edge      i8042
 14:       6397          0   IO-APIC-edge      ata_piix
 15:          0          0   IO-APIC-edge      ata_piix
 16:      78476          0   IO-APIC-fasteoi   uhci_hcd:usb2, radeon, yenta
 17:        316          0   IO-APIC-fasteoi   uhci_hcd:usb3, HDA Intel
 18:          0          0   IO-APIC-fasteoi   uhci_hcd:usb4
 19:         28          0   IO-APIC-fasteoi   ehci_hcd:usb1, uhci_hcd:usb5
 29:       3168       6664   PCI-MSI-edge      ahci
 30:          4        351   PCI-MSI-edge      eth0
 31:       8168          0   PCI-MSI-edge      iwl3945
NMI:          0          0   Non-maskable interrupts
LOC:      49660     116435   Local timer interrupts
RES:      16266      15656   Rescheduling interrupts
CAL:         47         79   Function call interrupts
TLB:         31        120   TLB shootdowns
TRM:          0          0   Thermal event interrupts
SPU:          0          0   Spurious interrupts
ERR:          0
MIS:          0
Comment 1 Stefan Becker 2009-04-09 13:51:33 EDT
Created attachment 338963 [details]
dmesg logfile
Comment 2 Bug Zapper 2009-06-09 09:33:38 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Stefan Becker 2009-09-09 23:50:23 EDT
Fedora 12 Radeon Test Day: still no luck with KMS & suspend. Now tested also on the r6xx HW: HD3200 [1002:9610]

kernel-2.6.31-0.219.rc9.git2.fc12.i686
xorg-x11-drv-ati-6.13.0-0.3.20090908git651fe5a47.fc12.i686
libdrm-2.4.12-0.9.fc12.i686
mesa-libGL-7.6-0.11.fc12.i686

T60 does hibernate/resume when KMS is disabled.
Comment 4 Stefan Becker 2009-09-09 23:52:20 EDT
See also bug #522070. Could be duplicate.
Comment 5 Stefan Becker 2009-09-12 04:16:50 EDT
The story continues into F12.

I doubt this will ever be fixed for F11, because it still uses the old radeon code base.

*** This bug has been marked as a duplicate of bug 522070 ***

Note You need to log in before you can comment on or make changes to this bug.