Bug 495095 - pkg-config reports wrong --libs output for lua-devel in EPEL on 64-bit OS
pkg-config reports wrong --libs output for lua-devel in EPEL on 64-bit OS
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: lua (Show other bugs)
el5
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: rob
Fedora Extras Quality Assurance
ActualBug
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-09 14:11 EDT by Chloe Lopez
Modified: 2010-10-26 14:01 EDT (History)
5 users (show)

See Also:
Fixed In Version: lua-5.1.4-4.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-26 14:01:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chloe Lopez 2009-04-09 14:11:49 EDT
Description of problem:
lua-devel package in EPEL for RHEL5 reports incorrect libs argument "-L/usr/lib" from pkg-config on 64-bit architectures. Should be "-L/usr/lib64"

Version-Release number of selected component (if applicable):
5.1.2-1

How reproducible:
Every time.

Steps to Reproduce:
1. Run "pkg-config lua --libs" on a RHEL5 64-bit OS that has lua-devel installed.
2.
3.
  
Actual results:
-L/usr/lib -llua -lm -ldl  


Expected results:
-L/usr/lib64 -llua -lm -ldl  


Additional info:
I see that there was some debate (Bug 399101) a year or two ago about whether this bug was important enough to fix in previously released versions, though it was fixed in Rawhide some time back. EPEL may or may not fall under that category of product, but for us using RHEL in a university setting for course work the impact is that computational instruction is disrupted by having to use pedagogically irrelevant workarounds. If this fix is not appropriate for EPEL, then we will have to rebuild the package for our own repositories, which is not the end of the world, but I wanted to give EPEL a chance to fix the bug first.
Comment 1 Kevin Fenzi 2010-10-02 00:44:43 EDT
ok. I took a look at fixing this. 

I had to tweak the patch thats available in the master branch for some reason, but I think I have a package that will work. 

Can you please test: 
http://koji.fedoraproject.org/koji/taskinfo?taskID=2507529

I'd love some feedback before pushing this as an update. Thanks.
Comment 2 Fedora Update System 2010-10-07 00:32:37 EDT
lua-5.1.4-4.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/lua-5.1.4-4.el5
Comment 3 Fedora Update System 2010-10-07 15:29:37 EDT
lua-5.1.4-4.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update lua'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/lua-5.1.4-4.el5
Comment 4 Jose Pedro Oliveira 2010-10-08 19:54:53 EDT
(In reply to comment #2)
> lua-5.1.4-4.el5 has been submitted as an update for Fedora EPEL 5.
> https://admin.fedoraproject.org/updates/lua-5.1.4-4.el5

Just increased the karma level by one.


Comments about the lua-5.1.4-4.el5 RPMS in epel-5-testing

 * they solve the two problems initially reported

 * successfully built a modified wireshark 1.4.0 with lua support for
   Centos 5.5 x86_64 (couldn't been done with the lua 5.1.2 RPMS of EPEL5
   due to the problems reported).

/jpo
Comment 5 Fedora Update System 2010-10-26 14:01:23 EDT
lua-5.1.4-4.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.