Bug 495102 - piranha removes slashes from monitoring script send commands
piranha removes slashes from monitoring script send commands
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: piranha (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Marek Grac
Cluster QE
:
Depends On:
Blocks: 497828
  Show dependency treegraph
 
Reported: 2009-04-09 14:31 EDT by John Ruemker
Modified: 2009-09-02 07:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 497828 (view as bug list)
Environment:
Last Closed: 2009-09-02 07:58:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch (1.89 KB, patch)
2009-04-27 09:28 EDT, Marek Grac
no flags Details | Diff

  None (edit)
Description John Ruemker 2009-04-09 14:31:35 EDT
Description of problem: When editing a virtual service, any slash entered in the Send box will be removed when written to the configuration.  The default Send command contains slashes, so simply leaving it as-is and hitting Accept will result in HTTP/1.0rnrn as opposed to HTTP/1.0\r\n\r\n.  This in turn results in nanny timing out waiting for the real server to respond, when it never will because it didn't receive the two carriage returns.  

This is caused by the unnecessary stripslashes call in web/web/secure/virtual_edit_services.php:

       $send           = stripslashes($_GET['send']);



Version-Release number of selected component (if applicable): piranha-0.8.4-11.el5

How reproducible: Always

Steps to Reproduce:
1. Create a new virtual server or edit an existing one
2. Go to the Monitoring Scripts tab
3. Enter value (or leave defaults) of "GET / HTTP/1.0\r\n\r\n"
4. Hit Accept
  
Actual results: lvs.cf has 'send = "GET / HTTP/1.0rnrn"'

Expected results: lvs.cf has 'send = "GET / HTTP/1.0\r\n\r\n"'

Additional info: This issue was fixed in RHEL 4 by BZ 199243.
Comment 1 Marek Grac 2009-04-27 09:28:21 EDT
Created attachment 341428 [details]
Patch

Situation is slightly more complicated. Usage of stripslashes() is not useless when php is configured with 'magic_quotes_gpc = On'. Attached patch should work with both of the situations.
Comment 4 errata-xmlrpc 2009-09-02 07:58:31 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1396.html

Note You need to log in before you can comment on or make changes to this bug.