Bug 495144 - unable to partition disk with LVM during EFI installation
unable to partition disk with LVM during EFI installation
Status: CLOSED DUPLICATE of bug 491746
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 495367 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-09 18:00 EDT by Chris McDermott
Modified: 2009-04-15 16:08 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-15 16:08:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda dump (273.23 KB, text/plain)
2009-04-09 18:05 EDT, Chris McDermott
no flags Details

  None (edit)
Description Chris McDermott 2009-04-09 18:00:53 EDT
After applying the patch for bug 495075, I attempted to create an LVM-based partition layout, using the auto-partitioning 'Use Entire Drive' selection. However, lvcreate fails. The Anaconda traceback is:

Traceback (most recent call first):
  File "/tmp/updates/storage/devicelibs/lvm.py", line 357, in lvcreate
    raise LVMError("lvcreate failed for %s/%s" % (vg_name, lv_name))
  File "/tmp/updates/storage/devices.py", line 1998, in create 
    lvm.lvcreate(self.vg.name, self._name, self.size)
  File "/tmp/updates/storage/deviceaction.py", line 203, in execute
    self.device.create(intf=intf)
  File "/tmp/updates/storage/devicetree.py", line 658, in processActions
    action.execute(intf=self.intf)
  File "/tmp/updates/storage/__init__.py", line 229, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 115, in turnOnFilesystems
    anaconda.id.storage.doIt()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1323, in nextClicked
    self.anaconda.dispatch.gotoNext()
LVMError: lvcreate failed for vg_elm3b55/lv_root

Anaconda log to follow.
Comment 1 Chris McDermott 2009-04-09 18:05:05 EDT
Created attachment 339008 [details]
Anaconda dump
Comment 2 Chris Lumens 2009-04-13 10:18:44 EDT
*** Bug 495367 has been marked as a duplicate of this bug. ***
Comment 3 Chris Lumens 2009-04-15 16:08:39 EDT

*** This bug has been marked as a duplicate of bug 491746 ***

Note You need to log in before you can comment on or make changes to this bug.