Bug 495232 - Version in repository needs to be updated to allow syncing
Version in repository needs to be updated to allow syncing
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: anki (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Christian Krause
Fedora Extras Quality Assurance
:
: 495346 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-10 11:36 EDT by Truman
Modified: 2009-04-27 17:48 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.9.9.7.4-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-27 17:38:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Here is my strace log (302.87 KB, text/x-log)
2009-04-16 11:33 EDT, Martin Ellison
no flags Details

  None (edit)
Description Truman 2009-04-10 11:36:43 EDT
Description of problem:

An update to Anki involves a sync protocol change. Need update to be able to interact with online collections


Version-Release number of selected component (if applicable):

0.9.9.7.3

How reproducible:

Attempt to sync using any version but the latest
  
Actual results:

"The sync protocol has changed. Please upgrade."

Expected results:

Successful sync
Comment 1 Fedora Update System 2009-04-11 07:37:22 EDT
anki-0.9.9.7.4-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/anki-0.9.9.7.4-1.fc10
Comment 2 Fedora Update System 2009-04-11 08:04:36 EDT
anki-0.9.9.7.4-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/anki-0.9.9.7.4-1.fc9
Comment 3 Christian Krause 2009-04-12 04:32:44 EDT
(In reply to comment #0)
> An update to Anki involves a sync protocol change. Need update to be able to
> interact with online collections

Thanks for the bug report. I've updated anki to 0.9.9.7.4 in F9, F10 and rawhide.

I've tested syncing with the new package and it works fine for me.

Once the package is pushed into updates-testing, you'll be notified. If you get a chance, please test it then. ;-) Thanks!
Comment 4 Christian Krause 2009-04-12 10:38:05 EDT
*** Bug 495346 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2009-04-13 15:38:05 EDT
anki-0.9.9.7.4-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update anki'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-3551
Comment 6 Fedora Update System 2009-04-13 15:39:48 EDT
anki-0.9.9.7.4-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update anki'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-3561
Comment 7 Martin Ellison 2009-04-15 12:36:30 EDT
I am getting a message at startup:

~> /usr/bin/anki
You have libanki 0.9.9.7.4, but this is ankiqt 0.9.9.7

Please install the latest libanki.

(and then anki terminates)

[I also have a direct install of anki, but that is sitting in ~/anki, so it should not affect the official version in /usr/bin/anki]
Comment 8 Christian Krause 2009-04-15 17:01:27 EDT
(In reply to comment #7)
> I am getting a message at startup:
> 
> ~> /usr/bin/anki
> You have libanki 0.9.9.7.4, but this is ankiqt 0.9.9.7
> 
> [I also have a direct install of anki, but that is sitting in ~/anki, so it
> should not affect the official version in /usr/bin/anki]  

It seems that the official anki in /usr/bin finds parts of your local installation anyway.

Here are some ideas how the problem can be found:

1. Try out to run anki as a different (newly created) test user on your machine.
If this works, then it is a problem with the user you normally use.

2. Rename your local anki installation temporarely (e.g. mv ~/anki ~/anki.test) and try to run /usr/bin/anki again

3. Try to run anki using the following command line:
"strace -eopen -o /tmp/anki-strace.log anki"
This will protocol all "open" system calls and will reveal where the globally installed anki will use parts of your local installation. You should check this file whether it contains private information (e.g. last used deck) and when you are ok with it, please attach it to the bug report.
Comment 9 Martin Ellison 2009-04-16 11:31:55 EDT
ok, did those things. In each case I got the same results. 

I think what has happened is that the local install of anki updated the python libraries (/usr/lib/python2.5/site-packages/ ?) and that the yum/rpm install did not override this.

In other words, my problem is probably local to my system. I can keep using my local install; the only problem is that I have to install new versions myself.
Comment 10 Martin Ellison 2009-04-16 11:33:30 EDT
Created attachment 339861 [details]
Here is my strace log

As requested. There should not be anything confidential in there.
Comment 11 Christian Krause 2009-04-17 15:02:53 EDT
I've checked the strace log and I assume the files in /usr/lib/python2.5/site-packages/ankiqt-0.9.9.7-py2.5.egg cause the problems.

Since they were copied/installed manually into this location, rpm doesn't know about these files and so they weren't be deleted when you've updated anki.

You can do the following:
- delete this directory manually
- verify with "rpm -V anki" that your anki installation is still complete
- in future when you want to try out new versions of anki before they're packaged, you can do this just with your user account without installing it into the system (anki can just be started using ./anki from the untarred sources).
Comment 12 Martin Ellison 2009-04-18 09:54:30 EDT
I have done that and it is working now thank you.

If I run /usr/bin/anki from the command line I get messages "please install pysqlite 2.4 for better progress dialogs" but I can live with that.
Comment 13 Fedora Update System 2009-04-27 17:37:56 EDT
anki-0.9.9.7.4-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2009-04-27 17:38:34 EDT
anki-0.9.9.7.4-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.