Bug 495255 - Trying to hide certain types of volumes from showing up on desktop
Trying to hide certain types of volumes from showing up on desktop
Status: POST
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: nautilus (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Alexander Larsson
desktop-bugs@redhat.com
http://webpages.uncc.edu/~jbikman/
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-10 15:42 EDT by Jesse Bikman
Modified: 2016-03-28 18:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-03 08:36:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Bikman 2009-04-10 15:42:46 EDT
I want to mount a ramdisk and have it show up in places, but not on the desktop. When I look at the desktop folder from within nautilus, the ramdisk does not sure up. When I look at the desktop from the desktop however, the icon shows up. I understand that this is due to gconf, so I run gconf-editor to prevent volumes from showing up on the desktop.
I can run:

gconftool-2 -t bool /apps/nautilus/desktop/volumes_visible -s true

to show the icons, and run:

gconftool-2 -t bool /apps/nautilus/desktop/volumes_visible -s false

to hide the icons. 

What I want to do is hide some of the icons, for example, I would like for flash drives to show up on the desktop, but not ramdisks. What I mean to say is that I would like to have  

gconftool-2 -t bool /apps/nautilus/desktop/volumes_visible -s true

set and be able to hide volumes from the system still.


The ramdisk I had mounted was done by following these steps:

First, I edited my /etc/fstab to include this line:

ramdisk		        /dev/ramdisk            tmpfs  	gid=5,mode=620	0 0

I then ran:
sudo mount -t tmpfs /dev/ramdisk /mnt/ramdisk
using the /mnt/ramdisk directory I had already created.
The drive mounted, but I couldn't figure out a way to hide it!
I tried editing /usr/share/hal/fdi/policy/10osvendor/20-storage-methods.fdi by adding: 

	<!--Ignore tmpfs/ramdisk drives -->
        <match key="volume.fstype" string="tmpfs">
	    <merge key="volume.ignore" type="bool">true</merge>
	</match>

I did this because I expected my ramdisk to be ignored since it had a fstype of tmpfs. I based it off of another clause in the same file which was for hiding recovery partitions on HP desktops of type vfat. Shown below is the clause I mimicked: 

        <!-- HP ships desktops with a recovery partition -->
        <match key="volume.fstype" string="vfat">
	  <match key="volume.label" string="HP_RECOVERY">
	    <merge key="volume.ignore" type="bool">true</merge>
	  </match>
        </match>




Assuming my clause was accurate based on syntax, I restarted my machine however, upon reboot, I still did not find that my ramdisk had disappeared. This is somewhat a continuation of this bug: https://bugzilla.redhat.com/show_bug.cgi?id=400351
from Fedora 8, however, it still applies to me, who is using Redhat Enterprise 5.

Basically, I would like to have ramdisks hidden from showing up on the desktop and have flashdrives and external hard drives show up on the desktop. How can I do this, and am I following even remotely the correct procedure for doing so?
Comment 1 RHEL Product and Program Management 2014-03-07 08:37:59 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 2 RHEL Product and Program Management 2014-06-03 08:36:59 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).
Comment 3 Jesse Bikman 2016-01-04 08:28:49 EST
I need to stop receiving weekly emails about this bug I opened seven years ago. Please make that happen.
Comment 4 Mike McCune 2016-03-28 18:14:36 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Note You need to log in before you can comment on or make changes to this bug.