Bug 495261 - libaudit.so.0 not found for dbus-daemon on os/images/boot.iso
libaudit.so.0 not found for dbus-daemon on os/images/boot.iso
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fedora-release (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
: 495263 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-10 17:30 EDT by John Reiser
Modified: 2013-01-10 00:09 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-14 13:35:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2009-04-10 17:30:52 EDT
Description of problem: boot.iso for Fedora-11-Snap1-ppc does not boot because /sbin/sbus-daemon cannot load libaudit.so.0


Version-Release number of selected component (if applicable):
Fedora-11-Snap1-ppc

How reproducible: every time


Steps to Reproduce:
1. download and boot Fedora-11-Snap1-ppc on Apple Macintosh mini PowerPC (32-bit)
2.
3.
  
Actual results:
   [snip]
/sbin/sbus-daemon: error while loading shared libraries: libaudit.so.0: cannot open shared object file: No such file or directory
   [snip]
running install...
   [snip]
waiting for hardware to initialize...

** (process:665): WARNING **: Couldn't connect to system bus: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory
   [above message repeats forever at 1 Hz]

Expected results: successful boot


Additional info:
Comment 1 John Reiser 2009-04-10 19:02:30 EDT
The same problem also occurs on i386 and x86_64 when booting os/images/boot.iso from today's rawhide (2009-04-10; Friday.)
Comment 2 Geoff Levand 2009-04-10 19:07:03 EDT
*** Bug 495263 has been marked as a duplicate of this bug. ***
Comment 3 John Reiser 2009-04-11 10:49:35 EDT
Typo "sbus" ==> "dbus"   [It doesn't help that the words "system bus" appear in the long message with the WARNING.]
Comment 4 Geoff Levand 2009-04-11 16:06:48 EDT
I tested today's build (11-Apr-2009 08:28) and got the same result.

  sha1sum ppc/ppc64/{vmlinuz,ramdisk.image.gz}
  0fa8ea4870801f33b2518201d5c68e8ca9b8a709  ppc/ppc64/vmlinuz
  2e803dd8cd3e07a20e3722f4fc538c6953fc8db1  ppc/ppc64/ramdisk.image.gz

-Geoff
Comment 5 Matthieu Araman 2009-04-13 14:15:48 EDT
Same problem with boot.iso 20090412 on x64
makes testing rawhide installation completely impossible...
Comment 6 Michal Nowak 2009-04-14 05:35:25 EDT
x86_64, today's Rawhide, KVM. This might affect "Test Day:AnacondaStorageRewrite 2009-04-14".
Comment 7 Geoff Levand 2009-04-14 13:18:50 EDT
I tested today's build (14-Apr-2009 07:52) and did not see this problem.
Tested with 'text install' on PS3 game console.

-Geoff

Note You need to log in before you can comment on or make changes to this bug.